Results 1 to 3 of 3

Thread: SMTP Authorisation isn't working anymore

  1. #1
    Adrian Barone is offline Starter Member
    Join Date
    Nov 2012
    Posts
    3
    Rep Power
    2

    Default [SOLVED] SMTP Authorisation isn't working anymore

    Hi all,

    I'm running now zimbra since approx 3 years without any problems… Now I have a really strange issue I can't fix.

    Everything runs smooth when using the webclient. But when I'm using the IMAP client wherever I can get my mails, but I can't send… The following is in the zimbra.log…

    Nov 21 14:19:25 zimbra postfix/smtpd[6321]: connect from < client >
    Nov 21 14:19:25 zimbra postfix/smtpd[6321]: setting up TLS connection from < client >
    Nov 21 14:19:25 zimbra postfix/smtpd[6321]: Anonymous TLS connection established from < client >: TLSv1 with cipher AES128-SHA (128/128 bits)
    Nov 21 14:19:25 zimbra saslauthd[31180]: zmauth: authenticating against elected url 'https://zimbra.domain.com:7071/service/admin/soap/' ...
    Nov 21 14:19:25 zimbra saslauthd[31180]: authentication against url 'https://zimbra.domain.com:7071/service/admin/soap/' caused error 'curl_easy_perform: error(56): Received HTTP code 403 from proxy after CONNECT'
    Nov 21 14:19:25 zimbra saslauthd[31180]: url 'https://zimbra.domain.com:7071/service/admin/soap/' will not be used for (at least) 600 seconds
    Nov 21 14:19:25 zimbra saslauthd[31180]: Authentication cycle re-elected url https://zimbra.domain.com:7071/service/admin/soap/, giving up ...
    Nov 21 14:19:25 zimbra saslauthd[31180]: auth_zimbra: user@domain.com auth failed: curl_easy_perform: error(56): Received HTTP code 403 from proxy after CONNECT
    Nov 21 14:19:25 zimbra saslauthd[31180]: do_auth : auth failure: [user=user@domain.com] [service=smtp] [realm=domain.com] [mech=zimbra] [reason=Unknown]
    Nov 21 14:19:25 zimbra postfix/smtpd[6321]: warning: SASL authentication failure: Password verification failed
    Nov 21 14:19:25 zimbra postfix/smtpd[6321]: warning: < client >: SASL PLAIN authentication failed: authentication failure
    Nov 21 14:19:25 zimbra postfix/smtpd[6321]: lost connection after AUTH from < client >

    This worked some days before… I've updated from 7.2.0 to 7.2.1, hoping this would fix the issue. But I simply can't explain why this isn't working:

    # zmprov getServer `zmhostname`| grep Auth
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: zimbra.domain.com
    zimbraMtaAuthTarget: TRUE
    zimbraMtaAuthURL: https://zimbra.domain.com:443/service/soap/
    zimbraMtaSaslAuthEnable: yes
    zimbraMtaTlsAuthOnly: TRUE

    The SSL certificate can't be the problem, this is still valid:

    # mcertmgr viewdeployedcrt
    ::service mta::
    notBefore=Feb 22 14:54:24 2011 GMT
    notAfter=Feb 22 14:54:24 2014 GMT
    subject= /CN=*.domain.com/emailAddress=mail@domain.com
    SubjectAltName= domain.com, *.domain.com
    ( same cert for every service )

    Are there any more logging informations, why this authentication request fails?

    I would be glad if someone could help me... Thanks in advance..
    Last edited by Adrian Barone; 11-26-2012 at 08:29 AM. Reason: problem solved

  2. #2
    shanxt is offline Active Member
    Join Date
    Jul 2012
    Location
    Bangalore, India
    Posts
    34
    Rep Power
    2

    Default

    Received HTTP code 403 from proxy after CONNECT
    That error seems really strange, as Zimbra shouldn't be connecting to a proxy in the first place I think.

    Is it a multiserver setup? Could you check your DNS settings, if by any chance the Zimbra server is looping to itself via an external proxy?

  3. #3
    Adrian Barone is offline Starter Member
    Join Date
    Nov 2012
    Posts
    3
    Rep Power
    2

    Default

    Quote Originally Posted by shanxt View Post
    That error seems really strange, as Zimbra shouldn't be connecting to a proxy in the first place I think.
    Interesting, I found the problem. The saslauthd uses the local bash environment for the https connector when authorizing. Since we use a cache-proxy for every dmz-host, every request is going to that proxy. We've configured that into /etc/profile.d and, obviously, Zimbra sources those configs as well.

    Now I've put the following lines into the /opt/zimbra/.bash_profile:

    # User specific environment and startup programs
    unset http_proxy
    unset https_proxy
    unset ftp_proxy
    Now it works! Thanks a lot – simple solution in the end…

    But why does the Zimbra environment includes the system specific configuration in /opt/zimbra/.bashrc?

    # Source global definitions
    if [ -f /etc/bashrc ]; then
    . /etc/bashrc
    fi

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra not working anymore on iPhone
    By LeonAragon in forum Mobility
    Replies: 3
    Last Post: 05-29-2012, 02:55 AM
  2. zmbkpose 1.0.0 not working well anymore
    By sevilla in forum Administrators
    Replies: 1
    Last Post: 09-30-2010, 04:09 PM
  3. Exchange IMAP not working anymore since 2 beta1
    By seanb in forum General Questions
    Replies: 0
    Last Post: 02-16-2010, 01:50 PM
  4. Exchange IMAP not working anymore since 2 beta1
    By seanb in forum Error Reports
    Replies: 0
    Last Post: 02-16-2010, 01:50 PM
  5. [SOLVED] 5.0GA: zmprov not working anymore
    By fisch09 in forum Installation
    Replies: 3
    Last Post: 01-05-2008, 08:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •