Results 1 to 6 of 6

Thread: Moving zimbra 7.1.4 CentOS 64 bit to Ubuntu 12.04 64 bit

  1. #1
    juanpablo is offline Intermediate Member
    Join Date
    Sep 2012
    Posts
    19
    Rep Power
    2

    Default Moving zimbra 7.1.4 CentOS 64 bit to Ubuntu 12.04 64 bit

    Hi,

    I need some help.
    I have a Zimbra 7.1.4 on CentOS 64bit, I want this server move to Ubuntu 12.04 64 bit. Ubuntu is a fresh install, no zimbra yet. Could anyone please point me some documents how to do this. I am new to zimbra and I am no expert on this.
    My goal is to have a Zimbra 8 on the new Ubuntu.

    thanks,
    warren

  2. #2
    juanpablo is offline Intermediate Member
    Join Date
    Sep 2012
    Posts
    19
    Rep Power
    2

    Default

    my mistake, Zimbra 7.1.4 does not support Ubuntu 12.04. I will install Ubuntu 10.04

  3. #3
    federico.bertola's Avatar
    federico.bertola is offline Special Member
    Join Date
    Jul 2006
    Location
    Verona, Italy
    Posts
    153
    Rep Power
    9

    Default

    Hello,
    the official documentation for zimbra-to-zimbra migration is on the wiki: Zimbra_to_Zimbra_Migration, but to migrate straight from your current Zimbra install to Zimbra 8/Ubuntu 12.04 I would use ZeXtras Migration Tool. It is a free tool made to migrate all zimbra data between any different operating system and architecture.

    My 2 cent
    Federico Bertola
    CTO @ StudioStorti

  4. #4
    juanpablo is offline Intermediate Member
    Join Date
    Sep 2012
    Posts
    19
    Rep Power
    2

    Default

    Hi,

    thanks for this info. I read through the ZxBackup but it shows it does not support external restore for Network Edition, my system is NE 7.1.4.
    for the Zimbra to Zimbra migration tool zmztozmig, the first step is,
    Provisioning the accounts on the destination server before running zmztozmig
    how to do this?

    My current Zimbra is hosted on a remote location and the new intended zimbra is also hosted on another location. There is 500G of data, I started copying over to new zimbra but this will take so much time around 5 days. I cannot take down the mail server for 5 days. Is there a way to like a live migration?

  5. #5
    federico.bertola's Avatar
    federico.bertola is offline Special Member
    Join Date
    Jul 2006
    Location
    Verona, Italy
    Posts
    153
    Rep Power
    9

    Default

    Hello,

    I did quite some migrations from and to NE, I found no limitations here.
    About the live migration it's possible (they call it "Incremental", it's in the docs).

    If you still want to go with the zmztozmig you can do the provisioning with the Migration Wizard of Zimbra 8 but you will still need to manually create all the shares in the new accounts.

    Good luck...
    Federico Bertola
    CTO @ StudioStorti

  6. #6
    juanpablo is offline Intermediate Member
    Join Date
    Sep 2012
    Posts
    19
    Rep Power
    2

    Default

    For the sake of sharing information, I have here my experience on migration.
    Original Zimbra:
    ZCS NE 7.1.4 CentOS 5.6 64bit

    Migrated to
    ZCS NE 8.0.0 CentOS 6.3 64bit

    Steps:
    1. I setup a new server using CentOS 6.3 64bit. Applied all the updates.
    2. I used ZCS to ZCS rsync method. I installed the same version 7.1.4 to new CentOS 6.3 using ./install.sh -s --override-platform
    3. rsync the /opt/zimbra directory from oldserver to newserver
    4. then followed the other steps on the rsync method. Platform and OS Independent ZCS to ZCS Migration Using Rsync - Zimbra :: Wiki
    5. then ran the installer without the -s flag. ./install.sh --override-platform
    During the last part of the upgrade I ran into lots of error. The ldap won't run, the zmconfigd, mailbox won't run,etc.. there are bunch of errors I already forgot what the others. I even ran into a looping error, like Starting ldap..done, ldap is not running, starting ldap..done, and so on.
    In my frustration, I restarted the machine and I ran the 8.0.0 NE installer. To my surprise, it went smoothly. The upgrade just ran perfectly without errors. Even the services in just one try it all started quickly. Starting ldap...done, starting zmconfigd...done, starting mailbox...done, etc...
    Now I am using 8.0.0 version, so far all good.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 09-21-2012, 11:25 AM
  2. Replies: 0
    Last Post: 09-21-2012, 06:45 AM
  3. moving from dead centos mchin to live ubuntu mahcine
    By hescominsoon in forum Administrators
    Replies: 0
    Last Post: 08-30-2012, 01:59 PM
  4. physical moving centos with zimbra
    By niky in forum Migration
    Replies: 3
    Last Post: 10-28-2010, 07:13 AM
  5. Replies: 2
    Last Post: 11-09-2009, 08:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •