Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Migration from 32 bit to 64 bit failed

  1. #1
    laluvirtual is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    23
    Rep Power
    5

    Default Migration from 32 bit to 64 bit failed

    i follow this (Network Edition: Moving from 32-bit to 64-bit Server - Zimbra :: Wiki)
    instruction but fail with following

    Code:
    Enabled services read from cache. Service list may be inaccurate.
            Starting zmconfigd...Done.
            Starting logger...Failed.
    Starting logswatch...[] FATAL: failed to initialize LDAP client
    com.zimbra.cs.ldap.LdapException: LDAP error: : invalid credentials
    ExceptionId:main:1328322259680:f86728ab789f35f3
    Code:ldap.LDAP_ERROR
            at com.zimbra.cs.ldap.LdapException.LDAP_ERROR(LdapException.java:88)
            at com.zimbra.cs.ldap.unboundid.UBIDLdapException.mapToLdapException(UBIDLdapException.java:72)
            at com.zimbra.cs.ldap.unboundid.UBIDLdapException.mapToLdapException(UBIDLdapException.java:38)
            at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.createConnPool(LdapConnectionPool.java:117)
            at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.createConnectionPool(LdapConnectionPool.java:64)
            at com.zimbra.cs.ldap.unboundid.UBIDLdapContext.init(UBIDLdapContext.java:95)
            at com.zimbra.cs.ldap.unboundid.UBIDLdapClient.init(UBIDLdapClient.java:37)
            at com.zimbra.cs.ldap.LdapClient.getInstance(LdapClient.java:63)
            at com.zimbra.cs.ldap.LdapClient.initialize(LdapClient.java:86)
            at com.zimbra.cs.account.ldap.LdapProv.<init>(LdapProv.java:46)
            at com.zimbra.cs.account.ldap.LdapProvisioning.<init>(LdapProvisioning.java:256)
            at com.zimbra.cs.account.ldap.LdapProvisioning.<init>(LdapProvisioning.java:253)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
            at java.lang.reflect.Constructor.newInstance(Constructor.java:525)
            at java.lang.Class.newInstance0(Class.java:372)
            at java.lang.Class.newInstance(Class.java:325)
            at com.zimbra.cs.account.Provisioning.getInstance(Provisioning.java:278)
            at com.zimbra.cs.account.Provisioning.getInstance(Provisioning.java:238)
            at com.zimbra.cs.account.ProvUtil.initProvisioning(ProvUtil.java:744)
            at com.zimbra.cs.account.ProvUtil.main(ProvUtil.java:3505)
    Caused by: LDAPException(resultCode=49 (invalid credentials), errorMessage='invalid credentials')
            at com.unboundid.ldap.sdk.LDAPConnection.bind(LDAPConnection.java:1837)
            at com.unboundid.ldap.sdk.LDAPConnectionPool.createConnection(LDAPConnectionPool.java:666)
            at com.unboundid.ldap.sdk.LDAPConnectionPool.<init>(LDAPConnectionPool.java:562)
            at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.createConnPool(LdapConnectionPool.java:113)
            ... 18 more
    zimbra logger service is not enabled!  failed.
    any suggestion?

    thanks for help

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by laluvirtual View Post
    any suggestion?
    We can't tell from that isolated error what the problem is, the likelihood is that you haven't followed those steps exactly - they do work. You've given no details about the exact steps you've done nor which version (or release) of Zimbra is on the source and destination servers nor whether your DNS records etc. are correct.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    technopop is offline Junior Member
    Join Date
    Nov 2009
    Posts
    9
    Rep Power
    5

    Default

    I may be remembering wrong, but I thought I'd come across another migration procedure where on your 32bit and 64bit machine, you have the same version of zimbra. Copy the install from the 32bit over to the 64bit and then re-run the installer, let it upgrade things for you.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by technopop View Post
    I may be remembering wrong, but I thought I'd come across another migration procedure where on your 32bit and 64bit machine, you have the same version of zimbra.
    That's correct and why I've asked which versions of ZCS are installed on both servers.

    Quote Originally Posted by technopop View Post
    Copy the install from the 32bit over to the 64bit and then re-run the installer, let it upgrade things for you.
    That will fail and there are additional step(s) for moving from 32bit to 64bit as described in that wiki article, the article has also been Certified by Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    laluvirtual is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    23
    Rep Power
    5

    Default

    @phoenix, technopop:
    yes i follow the step exactly same except "zmlocalconfig -e mailboxd_keystore_password=thepassword" thar because i use open source edition.
    my old zimbra is Release 5.0.18_GA_3011.RHEL5_20090707164432 CentOS5 FOSS edition an installed on Centos 5.3 32bit
    and news server is 8.0.1 (latest rellease) 64bit x86 and install on centos 6 64bit

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by laluvirtual View Post
    @phoenix, technopop:
    yes i follow the step exactly same except "zmlocalconfig -e mailboxd_keystore_password=thepassword" thar because i use open source edition.
    my old zimbra is Release 5.0.18_GA_3011.RHEL5_20090707164432 CentOS5 FOSS edition an installed on Centos 5.3 32bit
    and news server is 8.0.1 (latest rellease) 64bit x86 and install on centos 6 64bit
    Then I'm afraid you haven't followed the exact steps required. This is the second paragraph of that article:

    IMPORTANT: The ZCS release you install on the 64-bit server must be the same release as installed on the 32-bit server. The server can have a different operating system.
    You didn't do that.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    laluvirtual is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    23
    Rep Power
    5

    Default

    i follow your suggestion but after step
    k. Type /opt/zimbra/openldap/sbin/slapadd -q -b "" -F /opt/zimbra/data/ldap/config -cv -l /backup/ldap.bak.
    i get this message:
    Code:
    slapadd: slap_init no backend for ""

  8. #8
    laluvirtual is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    23
    Rep Power
    5

    Default

    hello... I'm not alone right?....

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by laluvirtual View Post
    hello... I'm not alone right?....
    No but at the time you've posted I was in bed. It takes you two days to reply to my post and then you demand an instant answer, you do realise that these forums are Community supported and people that post here do so when they have the time?

    You're still not following the correct instructions for your version of Zimbra, use the correct instructions for you version of ZCS.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    laluvirtual is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    23
    Rep Power
    5

    Default

    ok thank you for your kind respond, you are the best phoenix.
    again, i'll try that steps but more carefully, when i success i'll inform you

    regards

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Migration Failed
    By gbr in forum Administrators
    Replies: 2
    Last Post: 04-07-2011, 08:30 AM
  2. Migration Failed
    By gbr in forum Installation
    Replies: 2
    Last Post: 04-07-2011, 08:30 AM
  3. Migration Failed
    By chanck in forum Administrators
    Replies: 5
    Last Post: 06-22-2009, 06:32 AM
  4. Failed Migration: Rollback help?
    By sean.lutner in forum Migration
    Replies: 0
    Last Post: 09-23-2007, 12:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •