Results 1 to 7 of 7

Thread: Windows Phone 8 not connecting to IMAP

  1. #1
    YakkoWarner is offline Active Member
    Join Date
    Feb 2011
    Posts
    25
    Rep Power
    4

    Default Windows Phone 8 not connecting to IMAP

    I just got a Windows Phone 8, and it is refusing to connect to my Zimbra server. I'm using the same connection setup as I did in Windows Phone 7, but it just doesn't want to work.

    I turned on imap TRACE logging, and here's what I see when I try to sync:

    Code:
    2012-11-14 21:53:02,351 INFO  [ImapSSLServer-8] [] imap - [10.19.98.1] connected
    2012-11-14 21:53:02,351 TRACE [ImapSSLServer-8] [] imap - S: * OK cumorah.puddlestheshark.local Zimbra IMAP4rev1 server ready
    2012-11-14 21:53:02,458 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - C: A2 NOOP
    2012-11-14 21:53:02,458 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - S: A2 OK NOOP completed
    2012-11-14 21:53:02,531 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - C: A3 CAPABILITY
    2012-11-14 21:53:02,531 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - S: * CAPABILITY IMAP4rev1 AUTH=PLAIN AUTH=X-ZIMBRA ACL BINARY CATENATE CHILDREN CONDSTORE ENABLE ESEARCH ESORT I18NLEVEL=1 ID IDLE LIST-EXTENDED LIST-STATUS LITERAL+ LOGIN-REFERRALS MULTIAPPEND NAMESPACE QRESYNC QUOTA RIGHTS=ektx SASL-IR SEARCHRES SORT THREAD=ORDEREDSUBJECT UIDPLUS UNSELECT WITHIN XLIST
    2012-11-14 21:53:02,532 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - S: A3 OK CAPABILITY completed
    2012-11-14 21:53:02,606 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - C: A4 LOGIN ...
    2012-11-14 21:53:02,606 INFO  [ImapSSLServer-8] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - user djm@puddlestheshark.com authenticated, mechanism=LOGIN [TLS]
    2012-11-14 21:53:02,606 TRACE [ImapSSLServer-8] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - S: A4 OK [CAPABILITY IMAP4rev1 ACL BINARY CATENATE CHILDREN CONDSTORE ENABLE ESEARCH ESORT I18NLEVEL=1 ID IDLE LIST-EXTENDED LIST-STATUS LITERAL+ LOGIN-REFERRALS MULTIAPPEND NAMESPACE QRESYNC QUOTA RIGHTS=ektx SASL-IR SEARCHRES SORT THREAD=ORDEREDSUBJECT UIDPLUS UNSELECT WITHIN XLIST] LOGIN completed
    2012-11-14 21:53:02,668 INFO  [ImapSSLServer-8] [] imap - dropping connection for user djm@puddlestheshark.com (server-initiated)
    2012-11-14 21:53:02,668 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - S: * BYE cumorah.puddlestheshark.local Zimbra IMAP4rev1 server closing connection
    2012-11-14 21:53:02,668 INFO  [ImapSSLServer-8] [] ProtocolHandler - Handler exiting normally
    2012-11-14 21:53:02,892 INFO  [ImapSSLServer-8] [] imap - [10.19.98.1] connected
    2012-11-14 21:53:02,892 TRACE [ImapSSLServer-8] [] imap - S: * OK cumorah.puddlestheshark.local Zimbra IMAP4rev1 server ready
    2012-11-14 21:53:02,917 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - C: A5 NOOP
    2012-11-14 21:53:02,918 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - S: A5 OK NOOP completed
    2012-11-14 21:53:03,008 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - C: A6 CAPABILITY
    2012-11-14 21:53:03,008 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - S: * CAPABILITY IMAP4rev1 AUTH=PLAIN AUTH=X-ZIMBRA ACL BINARY CATENATE CHILDREN CONDSTORE ENABLE ESEARCH ESORT I18NLEVEL=1 ID IDLE LIST-EXTENDED LIST-STATUS LITERAL+ LOGIN-REFERRALS MULTIAPPEND NAMESPACE QRESYNC QUOTA RIGHTS=ektx SASL-IR SEARCHRES SORT THREAD=ORDEREDSUBJECT UIDPLUS UNSELECT WITHIN XLIST
    2012-11-14 21:53:03,008 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - S: A6 OK CAPABILITY completed
    2012-11-14 21:53:03,087 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - C: A7 LOGIN ...
    2012-11-14 21:53:03,087 INFO  [ImapSSLServer-8] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - user djm@puddlestheshark.com authenticated, mechanism=LOGIN [TLS]
    2012-11-14 21:53:03,087 TRACE [ImapSSLServer-8] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - S: A7 OK [CAPABILITY IMAP4rev1 ACL BINARY CATENATE CHILDREN CONDSTORE ENABLE ESEARCH ESORT I18NLEVEL=1 ID IDLE LIST-EXTENDED LIST-STATUS LITERAL+ LOGIN-REFERRALS MULTIAPPEND NAMESPACE QRESYNC QUOTA RIGHTS=ektx SASL-IR SEARCHRES SORT THREAD=ORDEREDSUBJECT UIDPLUS UNSELECT WITHIN XLIST] LOGIN completed
    2012-11-14 21:53:03,154 INFO  [ImapSSLServer-8] [] imap - dropping connection for user djm@puddlestheshark.com (server-initiated)
    2012-11-14 21:53:03,154 TRACE [ImapSSLServer-8] [ip=10.19.98.1;] imap - S: * BYE cumorah.puddlestheshark.local Zimbra IMAP4rev1 server closing connection
    2012-11-14 21:53:03,154 INFO  [ImapSSLServer-8] [] ProtocolHandler - Handler exiting normally
    The phone just gives an error code "80072F30", which doesn't tell me a thing (Google only reveals a handful of hits, which at best just have a forum post reporting the error (with no resolution), when it is related at all).

    Compare this to another client (Windows 8 desktop mail) connecting to the same server/account (I removed a guid and client version number to satisfy my own paranoia):
    Code:
    2012-11-14 22:01:53,068 INFO  [ImapSSLServer-10] [] imap - [10.19.98.1] connected
    2012-11-14 22:01:53,068 TRACE [ImapSSLServer-10] [] imap - S: * OK cumorah.puddlestheshark.local Zimbra IMAP4rev1 server ready
    2012-11-14 22:01:53,159 TRACE [ImapSSLServer-10] [ip=10.19.98.1;] imap - C: SF20 CAPABILITY
    2012-11-14 22:01:53,159 TRACE [ImapSSLServer-10] [ip=10.19.98.1;] imap - S: * CAPABILITY IMAP4rev1 AUTH=PLAIN AUTH=X-ZIMBRA ACL BINARY CATENATE CHILDREN CONDSTORE ENABLE ESEARCH ESORT I18NLEVEL=1 ID IDLE LIST-EXTENDED LIST-STATUS LITERAL+ LOGIN-REFERRALS MULTIAPPEND NAMESPACE QRESYNC QUOTA RIGHTS=ektx SASL-IR SEARCHRES SORT THREAD=ORDEREDSUBJECT UIDPLUS UNSELECT WITHIN XLIST
    2012-11-14 22:01:53,159 TRACE [ImapSSLServer-10] [ip=10.19.98.1;] imap - S: SF20 OK CAPABILITY completed
    2012-11-14 22:01:53,273 TRACE [ImapSSLServer-10] [ip=10.19.98.1;] imap - C: PGBB ID ("version" "16.<version number removed>" "os" "WINDOWS" "vendor" "ASUSTeK Computer Inc." "device" "K70AB" "AGUID" "MSFT-<guid removed>")
    2012-11-14 22:01:53,273 DEBUG [ImapSSLServer-10] [ip=10.19.98.1;] imap - IMAP client identified as: {AGUID=MSFT-<guid removed>, device=K70AB, os=WINDOWS, vendor=ASUSTeK Computer Inc., version=16.<version number removed>}
    2012-11-14 22:01:53,273 TRACE [ImapSSLServer-10] [ip=10.19.98.1;] imap - S: * ID ("NAME" "Zimbra" "VERSION" "7.2.1_GA_2790" "RELEASE" "20120815212042")
    2012-11-14 22:01:53,273 TRACE [ImapSSLServer-10] [ip=10.19.98.1;] imap - S: PGBB OK ID completed
    2012-11-14 22:01:53,362 TRACE [ImapSSLServer-10] [ip=10.19.98.1;] imap - C: 8I3Z LOGIN ...
    2012-11-14 22:01:53,362 INFO  [ImapSSLServer-10] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - user djm@puddlestheshark.com authenticated, mechanism=LOGIN [TLS]
    2012-11-14 22:01:53,363 TRACE [ImapSSLServer-10] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - S: 8I3Z OK [CAPABILITY IMAP4rev1 ACL BINARY CATENATE CHILDREN CONDSTORE ENABLE ESEARCH ESORT I18NLEVEL=1 ID IDLE LIST-EXTENDED LIST-STATUS LITERAL+ LOGIN-REFERRALS MULTIAPPEND NAMESPACE QRESYNC QUOTA RIGHTS=ektx SASL-IR SEARCHRES SORT THREAD=ORDEREDSUBJECT UIDPLUS UNSELECT WITHIN XLIST] LOGIN completed
    2012-11-14 22:01:53,464 TRACE [ImapSSLServer-10] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - C: 1TQG XLIST "" "*"
    2012-11-14 22:01:53,465 TRACE [ImapSSLServer-10] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - S: * XLIST (\HasChildren \Inbox) "/" "INBOX"
    <other folders listed, then...>
    2012-11-14 22:01:53,466 TRACE [ImapSSLServer-10] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - S: 1TQG OK XLIST completed
    2012-11-14 22:01:53,951 TRACE [ImapSSLServer-10] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - C: L6EH SELECT "INBOX"
    2012-11-14 22:01:53,952 DEBUG [ImapSSLServer-10] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - opening folder: INBOX
    2012-11-14 22:01:53,953 DEBUG [ImapSSLServer-10] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap -   ** iterating (collapseExpunged)
    2012-11-14 22:01:53,953 DEBUG [ImapSSLServer-10] [name=djm@puddlestheshark.com;ip=10.19.98.1;] imap - copying message data from existing session: INBOX
    <and it goes on from there>
    No earthly idea what I'm doing wrong. Windows Phone 7 worked fine with the exact same setup.

  2. #2
    comfix is offline Junior Member
    Join Date
    Apr 2010
    Location
    Perth
    Posts
    5
    Rep Power
    5

    Default

    Similar request here Windows 8 cannot add Zimbra account.
    got hi-jacked by Exchange account, which works well, even on Zimbra 5 server.

    MalFunction

  3. #3
    YakkoWarner is offline Active Member
    Join Date
    Feb 2011
    Posts
    25
    Rep Power
    4

    Default

    Trying as an Exchange account, now the phone is telling me my server "requires that certain security policies be enforced. Try syncing again to apply the policies. If you keep seeing this message, contact a support person or your service provider. Error code 85010013".

    This is the same error I had when I was once playing around with z-push. Never did figure out what was wrong, and I gave up on it.

    And it doesn't work outside my firewall, so I guess I need to open another port besides the IMAP ones. But which port?

  4. #4
    YakkoWarner is offline Active Member
    Join Date
    Feb 2011
    Posts
    25
    Rep Power
    4

    Default

    Oddly enough, my wife's phone spontaneously started connecting to the server. But with the same settings on my phone, it refuses. (I'm using IMAP4, since trying the Exchange route runs me into that "security policies" error that I've never been able to get around.)

    The difference seems to come down to that server-initiated IMAP connection drop, which is now only appearing when connecting from my phone. What is causing that, and, more importantly, how do I correct it?

  5. #5
    itparc is offline Starter Member
    Join Date
    Jul 2009
    Posts
    1
    Rep Power
    6

    Default

    Same error here. In my case, hijacking by Exchange account doesn't make sense because shared folders aren't visible. Any solutions?

  6. #6
    YakkoWarner is offline Active Member
    Join Date
    Feb 2011
    Posts
    25
    Rep Power
    4

    Default

    Just like my wife's phone, mine spontaneously started working, and continued to work fine for about a month. But today, I noticed that I didn't have any new email, which I thought was odd (I usually get *something*, even if it's just spam). Checked my phone, and sure enough, it's not working again. Other email clients are working without issue, so it doesn't appear to be any sort of network problem.

    Seriously, what the crap?

  7. #7
    YakkoWarner is offline Active Member
    Join Date
    Feb 2011
    Posts
    25
    Rep Power
    4

    Default

    In the continuing saga of weirdness. I have two accounts on my Zimbra server. My phone connects to both. (My wife's connects to one.) After about a week and a half, my phone started to successfully sync with *one* of the accounts, but not the other. Several days later, the second account started to sync. Then, a few days later, it stopped syncing with both again, which is where I am now. During this time, my wife's phone never was able to sync. Although her Android tablet never failed to sync, even when using the connection via her phone.

    I believe this should prove, if nothing else, that it's not some kind of network error (otherwise the tablet wouldn't sync over the phone's connection, nor would one phone connect to one account and not another). But I have no idea what it *could* be at this point.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 04-04-2012, 11:05 AM
  2. Replies: 4
    Last Post: 03-07-2012, 08:55 PM
  3. Experience with Windows Phone 7
    By tvone in forum Mobility
    Replies: 0
    Last Post: 01-18-2012, 03:13 AM
  4. [SOLVED] Connecting Zimbra Desktop to Exchange 2007 via IMAP
    By neoanderthal in forum General Questions
    Replies: 1
    Last Post: 10-08-2009, 09:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •