Results 1 to 7 of 7

Thread: 8 Install Fails

  1. #1
    carnold is offline Advanced Member
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default 8 Install Fails

    Trying to upgrade from 7.2 to 8 on SLES11. We have zimbra bound to a specific ip and NDS bound to a specific ip on this server. Here is the zmsetup log:
    Starting mysqld...done.
    Thu Oct 25 17:46:23 2012 done.
    Thu Oct 25 17:46:25 2012 This appears to be 7.2.0_GA
    Thu Oct 25 17:46:25 2012 Setting local config ssl_allow_untrusted_certs to true
    Thu Oct 25 17:46:25 2012 *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ssl_allow_untrusted_certs='true' 2> /dev/null
    Thu Oct 25 17:46:27 2012 Upgrading ldap data...
    Thu Oct 25 17:46:27 2012 done.
    Thu Oct 25 17:46:27 2012 Upgrading LDAP configuration database...
    Thu Oct 25 17:46:27 2012 done.
    Thu Oct 25 17:46:27 2012 Loading database...
    Thu Oct 25 17:46:27 2012 *** Running as zimbra user: /opt/zimbra/openldap/sbin/slapadd -q -b '' -F /opt/zimbra/data/ldap/config -l /opt/zimbra/data/ldap/ldap.80
    5089b333 mdb_db_open: database "" cannot be opened, err 12. Restore from backup!
    5089b333 backend_startup_one (type=mdb, suffix=""): bi_db_open failed! (12)
    slap_startup failed
    Thu Oct 25 17:46:27 2012 slapadd import failed.
    Thu Oct 25 17:46:27 2012 UPGRADE FAILED - exiting.

    How do i need to upgrade to 8 on this server when zcs needs to bound to a specific ip?

    ZCS 7 does not appear to start now:
    zmcontrol start
    Host domain.com
    Starting ldap...Done.
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    Starting zmconfigd...Done.
    Starting logger...Failed.
    Starting logswatch...[] FATAL: failed to initialize LDAP client
    com.zimbra.cs.ldap.LdapException: LDAP error: : invalid credentials
    ExceptionId:main:1351203110923:84916213a0d0a788
    Code:ldap.LDAP_ERROR
    at com.zimbra.cs.ldap.LdapException.LDAP_ERROR(LdapEx ception.java:88)
    at com.zimbra.cs.ldap.unboundid.UBIDLdapException.map ToLdapException(UBIDLdapException.java:72)
    at com.zimbra.cs.ldap.unboundid.UBIDLdapException.map ToLdapException(UBIDLdapException.java:38)
    at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.cr eateConnPool(LdapConnectionPool.java:117)
    at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.cr eateConnectionPool(LdapConnectionPool.java:64)
    at com.zimbra.cs.ldap.unboundid.UBIDLdapContext.init( UBIDLdapContext.java:95)
    at com.zimbra.cs.ldap.unboundid.UBIDLdapClient.init(U BIDLdapClient.java:37)
    at com.zimbra.cs.ldap.LdapClient.getInstance(LdapClie nt.java:63)
    at com.zimbra.cs.ldap.LdapClient.initialize(LdapClien t.java:86)
    at com.zimbra.cs.account.ldap.LdapProv.<init>(LdapPro v.java:46)
    at com.zimbra.cs.account.ldap.LdapProvisioning.<init> (LdapProvisioning.java:256)
    at com.zimbra.cs.account.ldap.LdapProvisioning.<init> (LdapProvisioning.java:253)
    at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(NativeConstructorAccessorImpl.java:57)
    at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Construc tor.java:525)
    at java.lang.Class.newInstance0(Class.java:372)
    at java.lang.Class.newInstance(Class.java:325)
    at com.zimbra.cs.account.Provisioning.getInstance(Pro visioning.java:278)
    at com.zimbra.cs.account.Provisioning.getInstance(Pro visioning.java:238)
    at com.zimbra.cs.account.ProvUtil.initProvisioning(Pr ovUtil.java:744)
    at com.zimbra.cs.account.ProvUtil.main(ProvUtil.java: 3505)
    Caused by: LDAPException(resultCode=49 (invalid credentials), errorMessage='invalid credentials')
    at com.unboundid.ldap.sdk.LDAPConnection.bind(LDAPCon nection.java:1837)
    at com.unboundid.ldap.sdk.LDAPConnectionPool.createCo nnection(LDAPConnectionPool.java:666)
    at com.unboundid.ldap.sdk.LDAPConnectionPool.<init>(L DAPConnectionPool.java:562)
    at com.zimbra.cs.ldap.unboundid.LdapConnectionPool.cr eateConnPool(LdapConnectionPool.java:113)
    ... 18 more
    zimbra logger service is not enabled! failed.

    I should have a backupexec backup of any files i might need. Help?!?!

  2. #2
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    What you should have done here has been documented in other threads. That is, re-run the slapadd command as the zimbra user, at which point it would have succeeded, and then re-run the installer. I don't know what you've done to your system since you hit the failure, which makes it virtually impossible to say what should be done at this point.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  3. #3
    carnold is offline Advanced Member
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default

    Quote Originally Posted by quanah View Post
    What you should have done here has been documented in other threads. That is, re-run the slapadd command as the zimbra user, at which point it would have succeeded, and then re-run the installer. I don't know what you've done to your system since you hit the failure, which makes it virtually impossible to say what should be done at this point.
    In the past, upgrading was as simply as running the install.sh. I had, i thought, no reason to do other than what i had done in the past. Is it possible to retrieve the old ldap info, uninstall zcs 8, install 7 and get it back working? Surely, i am not the first and only one who has done this.

    OR

    Uninstall the broken zcs 8, move users email to another place on the drive. Install 8 and get users email back?

  4. #4
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    Yes, unfortunately there is an issue that some people hit when upgrading to 8.0.0. There will be a fix for that in 8.0.1. As I noted, since I don't know what you've done to your system since your attempt at upgrading to 8.0, I don't really know how to advise you to proceed. Is it possible to get back to a functioning system? Yes. What will that take? Unfortunately, I don't know, since I don't know what steps you've already taken.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  5. #5
    winepress is offline Member
    Join Date
    Nov 2012
    Location
    Seattle, WA, US
    Posts
    14
    Rep Power
    2

    Default

    Hi Quanah,

    Now there's a much bigger problem in 8.0.1...literally. My data.mdb grew from 6.7 MB to 79 GB after upgrading from 8.0.0 to 8.0.1. This, of course, is a huge problem for backups. I only have so much allocated for that server, and to have the file grow over 12,000% is a serious problem. Any fixes on the way?

    Thanks,
    Kevin

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,483
    Rep Power
    56

    Default

    Do not add posts onto a thread that is not on the same topic as your question, it gets difficult to follw threads if you do that.

    Quote Originally Posted by winepress View Post
    Now there's a much bigger problem in 8.0.1...literally. My data.mdb grew from 6.7 MB to 79 GB after upgrading from 8.0.0 to 8.0.1. This, of course, is a huge problem for backups. I only have so much allocated for that server, and to have the file grow over 12,000% is a serious problem. Any fixes on the way?
    Bugs don't get fixed unless there's something filed in bugzilla and who said this was a bug? I'd suggest you (carefully) read this document: OpenLDAP Tuning Keys 8.0 - Zimbra :: Wiki
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    winepress is offline Member
    Join Date
    Nov 2012
    Location
    Seattle, WA, US
    Posts
    14
    Rep Power
    2

    Default

    Hi Bill,

    Sorry, there's a thread over here I'm communicating on now.

    As a side note, I carefully read the document you referred to. The default max size is set to 85899345920, which is the exact size of my file after the upgrade, and is clearly marked with a warning that data loss will occur if that size is met. The installation inflated my file size from 6.7 MB to 80 GB--a bad thing according to OpenLDAP Tuning Keys 8.0.

    I'll see if something's logged away in bugzilla.

    Thanks,
    Kevin

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SSL cert install fails (ver 6)
    By mahalito in forum Administrators
    Replies: 1
    Last Post: 12-17-2010, 08:28 AM
  2. SSL cert install fails (ver 6)
    By mahalito in forum Installation
    Replies: 0
    Last Post: 12-14-2010, 06:56 PM
  3. Install Fails
    By exothermic in forum Installation
    Replies: 2
    Last Post: 04-13-2006, 01:18 AM
  4. zimbra install fails
    By mikelurk in forum Installation
    Replies: 17
    Last Post: 11-08-2005, 03:29 PM
  5. Install fails on FC3
    By Nigel in forum Installation
    Replies: 2
    Last Post: 09-28-2005, 03:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •