Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Don't send email local after install zimbra with DNS external

  1. #1
    ltrgiang is offline New Member
    Join Date
    Oct 2012
    Posts
    3
    Rep Power
    2

    Default Don't send email local after install zimbra with DNS external

    Hello Everyone.
    I have a domain name public is: abc.com. In cpanel:
    I created A record is mail.abc.com and pointed to IP pubic 2.3.4.5.
    I created MX record and pointed mail.abc.com.
    After in CentOS 6.3, I configured:
    ip private 192.168.1.244/24
    in file /etc/hosts: 192.168.1.244 mail.abc.com mail
    hostname: mail.abc.com
    in file /etc/resolv.conf: nameserver 8.8.8.8
    I used tool nslookup and resolved domain abc.com. Then I installed zimbra with 7.2.1 Open source in centos 6.3 x86_64. I install everyone expected zimbra-proxy After finish this installation, I create to mailbox u1@abc.com and u2@abc.com. When I send mail from u1 to u2 and cc for u1, I didn't see email to u1. I see /var/log/maillog and I see:

    Oct 25 14:22:19 mail postfix/qmgr[35327]: 3E2CB16310C: from=<user1@abc.com>, size=1297, nrcpt=2 (queue active)
    Oct 25 14:22:19 mail postfix/smtp[52317]: 49D3D163108: to=<u1@abc.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=1, delays=0.09/0.04/0.06/0.83, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 3E2CB16310C)
    Oct 25 14:22:19 mail postfix/smtp[52317]: 49D3D163108: to=<u2@abc.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=1, delays=0.09/0.04/0.06/0.83, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 3E2CB16310C)
    Oct 25 14:22:19 mail postfix/qmgr[35327]: 49D3D163108: removed
    Oct 25 14:22:19 mail postfix/error[52321]: 3E2CB16310C: to=<u1@abc.com>, relay=none, delay=0.08, delays=0.01/0.06/0/0.01, dsn=5.0.0, status=bounced (abc.com)
    Oct 25 14:22:19 mail postfix/error[52321]: 3E2CB16310C: to=<u2@abc.com>, relay=none, delay=0.08, delays=0.01/0.06/0/0.01, dsn=5.0.0, status=bounced (abc.com)

    Oct 25 14:23:22 mail postfix/lmtp[52324]: connect to mail.abc.com[2.3.4.5]:7025: Connection timed out
    Oct 25 14:23:22 mail postfix/lmtp[52324]: 5669E163110: to=<user1@abc.com>, relay=none, delay=63, delays=0/0.01/63/0, dsn=4.4.1, status=deferred (connect to mail.abc.com[2.3.4.5]:7025: Connection timed out)

    Please help me to fix it. Thanks so much

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,581
    Rep Power
    57

    Default

    Quote Originally Posted by ltrgiang View Post
    I have a domain name public is: abc.com. In cpanel:
    I created A record is mail.abc.com and pointed to IP pubic 2.3.4.5.
    I created MX record and pointed mail.abc.com.
    After in CentOS 6.3, I configured:
    ip private 192.168.1.244/24
    in file /etc/hosts: 192.168.1.244 mail.abc.com mail
    hostname: mail.abc.com
    in file /etc/resolv.conf: nameserver 8.8.8.8
    None of what you've posted is correct if you're behind a NAT router (and you LAN IP shows you are). Go to the Split DNS wiki article and see what you need to configure to get this set-up correctly, you can also verify the setting by running all the commands in the 'Verify...' section of that article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    ltrgiang is offline New Member
    Join Date
    Oct 2012
    Posts
    3
    Rep Power
    2

    Default

    Hello phoenix.

    I config splitDNS. Now I can receive email from google and yahoo. But I can't send email from my domain to google and yahoo. I see in file /var/log/maillog:
    Oct 25 15:35:56 mail postfix/qmgr[4175]: EF94B16313E: from=<user1@abc.com>, size=1290, nrcpt=1 (queue active)
    Oct 25 15:35:56 mail postfix/smtp[17181]: 549C0163138: to=<abc@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.69, delays=0.04/0.03/0.02/0.59, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as ED7FA16313C)
    Oct 25 15:35:56 mail postfix/smtp[17181]: 549C0163138: to=<user1@abc.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.69, delays=0.04/0.03/0.02/0.59, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as ED7FA16313C)
    Oct 25 15:35:56 mail postfix/qmgr[4175]: 549C0163138: removed
    Oct 25 15:35:57 mail postfix/lmtp[17185]: EF94B16313E: to=<user1@abc.com>, relay=mail.abc.com[192.168.1.244]:7025, delay=0.09, delays=0/0.01/0/0.08, dsn=2.1.5, status=sent (250 2.1.5 Delivery OK)
    Oct 25 15:35:57 mail postfix/qmgr[4175]: EF94B16313E: removed
    Oct 25 15:36:05 mail zmmailboxdmgr[17487]: status requested
    Oct 25 15:36:05 mail zmmailboxdmgr[17487]: status OK
    Oct 25 15:36:24 mail zmmailboxdmgr[17692]: status requested
    Oct 25 15:36:24 mail zmmailboxdmgr[17692]: status OK
    Oct 25 15:36:24 mail zmmailboxdmgr[17701]: status requested
    Oct 25 15:36:24 mail zmmailboxdmgr[17701]: status OK
    Oct 25 15:36:27 mail postfix/smtp[15951]: connect to gmail-smtp-in.l.google.com[74.125.25.26]:25: Connection timed out
    Oct 25 15:36:57 mail postfix/smtp[15951]: connect to alt1.gmail-smtp-in.l.google.com[74.125.133.26]:25: Connection timed out
    Oct 25 15:37:26 mail zmmailboxdmgr[17974]: status requested
    Oct 25 15:37:26 mail zmmailboxdmgr[17974]: status OK
    Oct 25 15:37:26 mail zmmailboxdmgr[17983]: status requested
    Oct 25 15:37:26 mail zmmailboxdmgr[17983]: status OK
    Oct 25 15:37:27 mail postfix/smtp[15951]: connect to alt2.gmail-smtp-in.l.google.com[74.125.137.26]:25: Connection timed out
    Oct 25 15:37:55 mail postfix/smtpd[13135]: timeout after END-OF-MESSAGE from localhost[127.0.0.1]
    Oct 25 15:37:55 mail postfix/smtpd[13135]: disconnect from localhost[127.0.0.1]
    Oct 25 15:37:57 mail postfix/smtp[15951]: connect to alt3.gmail-smtp-in.l.google.com[173.194.68.26]:25: Connection timed out

    I configure DNS follow as:
    in file /var/named/chroot/etc/named.conf

    acl mynet {
    192.168.1.0/24;
    10.0.1.0/8;
    127.0.0.1;
    };

    options {
    directory "/var/named";
    query-source port 53;
    query-source-v6 port 53;
    dump-file "var/named/data/cache_dump.db";
    statistics-file "var/named/data/named_stats.txt";
    memstatistics-file "var/named/data/named_mem_stats.txt";
    notify yes;
    forwarders {8.8.8.8 ;};
    };

    zone "." IN {
    type hint;
    file "named.root";
    };

    zone "abc.com" IN {
    type master;
    file "abc.db";
    };

    in file /var/named/chroot/var/named/abc.db:
    $TTL 86400
    @ IN SOA mailserver.abc.com. root (
    42 ; serial (d. adams)
    3H ; refresh
    15M ; retry
    1W ; expiry
    1D ) ; minimum
    IN NS mailserver.abc.com.
    IN MX 10 mail.abc.com.
    mail IN A 192.168.1.244
    mailserver IN A 192.168.1.244

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,581
    Rep Power
    57

    Default

    You haven't posted any of the information that's required, what is the output of the commands in the 'Verify....' section of that article - did you check the configuration is correct by using those commands?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    ltrgiang is offline New Member
    Join Date
    Oct 2012
    Posts
    3
    Rep Power
    2

    Default

    Hello Pheonix.

    this is information that I verified in zimbra:
    [root@mail ~]# dig linuxopenlab.net mx

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.5 <<>> linuxopenlab.net mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14495
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;linuxopenlab.net. IN MX

    ;; ANSWER SECTION:
    linuxopenlab.net. 86400 IN MX 10 mail.linuxopenlab.net.

    ;; AUTHORITY SECTION:
    linuxopenlab.net. 86400 IN NS server.linuxopenlab.net.

    ;; ADDITIONAL SECTION:
    mail.linuxopenlab.net. 86400 IN A 192.168.1.244
    server.linuxopenlab.net. 86400 IN A 192.168.1.244

    ;; Query time: 23 msec
    ;; SERVER: 192.168.1.244#53(192.168.1.244)
    ;; WHEN: Fri Oct 26 21:33:08 2012
    ;; MSG SIZE rcvd: 108

    [root@mail ~]# dig linuxopenlab.net any

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.5 <<>> linuxopenlab.net any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5465
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;linuxopenlab.net. IN ANY

    ;; ANSWER SECTION:
    linuxopenlab.net. 86400 IN SOA server.linuxopenlab.net. root. 42 10800 900 604800 86400
    linuxopenlab.net. 86400 IN NS server.linuxopenlab.net.
    linuxopenlab.net. 86400 IN A 192.168.1.244
    linuxopenlab.net. 86400 IN MX 10 mail.linuxopenlab.net.

    ;; ADDITIONAL SECTION:
    server.linuxopenlab.net. 86400 IN A 192.168.1.244
    mail.linuxopenlab.net. 86400 IN A 192.168.1.244

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.244#53(192.168.1.244)
    ;; WHEN: Fri Oct 26 21:33:30 2012
    ;; MSG SIZE rcvd: 164

    Now I don't still send email to internet, but can send email local domain and can receive email from internet. when I send email to google, connection is time out
    Oct 26 21:26:55 mail postfix/smtp[41012]: connect to alt2.aspmx.l.google.com[74.125.140.27]:25: Connection timed out

    Please help me

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,581
    Rep Power
    57

    Default

    Quote Originally Posted by ltrgiang View Post
    this is information that I verified in zimbra:
    That's not all the information that's asked for in that article, I'd suggest you read the 'Verify...' section again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    snake_eyes's Avatar
    snake_eyes is offline Advanced Member
    Join Date
    Nov 2008
    Posts
    237
    Rep Power
    6

    Default

    Hello,
    I have the same problem, I've configured everything and still getting time out

    Any help please???
    - In a world without walls and fences who needs windows and gates?
    - I am Running Linux.. Finally, my PC is valid & Reliable Hereafter.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,581
    Rep Power
    57

    Default

    Quote Originally Posted by snake_eyes View Post
    Hello,
    I have the same problem, I've configured everything and still getting time out

    Any help please???
    Instead of posting a 'me too' how about giving some information about you installation, what's happening, when it started, what you've tried to resolve theproblem and some diagnostic information as asked for in previous posts in this thread.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    snake_eyes's Avatar
    snake_eyes is offline Advanced Member
    Join Date
    Nov 2008
    Posts
    237
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Instead of posting a 'me too' how about giving some information about you installation, what's happening, when it started, what you've tried to resolve theproblem and some diagnostic information as asked for in previous posts in this thread.
    Thank you Bill for your reply:

    hostname
    mail.domain.com
    cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    192.168.0.10 mail.domain.com mail
    cat /etc/resolv.conf
    nameserver 127.0.0.1
    pico /etc/bind/db.domain.com
    $TTL 3600
    @ 86400 IN SOA mail.domain.com. support.domain.me. (
    20050609 ; Serial
    86400 ; Refresh
    7200 ; Retry
    2419200 ; Expire
    86400 ) ; Negative Cache TTL

    IN NS mail.domain.com.
    IN MX 10 mail.domain.com.

    @ 14400 IN A 123.45.67.189
    mail 14400 IN A 123.45.67.189
    www 14400 IN CNAME domain.com.
    root@mail:~# dig domain.com mx
    ; <<>> DiG 9.7.0-P1 <<>> domain.com mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32464
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;domain.com. IN MX

    ;; ANSWER SECTION:
    domain.com. 3600 IN MX 10 mail.domain.com.

    ;; AUTHORITY SECTION:
    domain.com. 3600 IN NS mail.domain.com.

    ;; ADDITIONAL SECTION:
    mail.domain.com. 14400 IN A 123.45.67.189

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Nov 26 12:32:01 2012
    ;; MSG SIZE rcvd: 86
    root@mail:~# dig domain.com any
    ; <<>> DiG 9.7.0-P1 <<>> domain.com any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16557
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;domain.com. IN ANY

    ;; ANSWER SECTION:
    domain.com. 86400 IN SOA mail.domain.com. support.domain.me. 20050609 86400 7200 2419200 86400
    domain.com. 3600 IN NS mail.domain.com.
    domain.com. 3600 IN MX 10 mail.domain.com.
    domain.com. 14400 IN A 123.45.67.189

    ;; ADDITIONAL SECTION:
    mail.domain.com. 14400 IN A 123.45.67.189

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Nov 26 12:33:52 2012
    ;; MSG SIZE rcvd: 157
    - In a world without walls and fences who needs windows and gates?
    - I am Running Linux.. Finally, my PC is valid & Reliable Hereafter.

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,581
    Rep Power
    57

    Default

    You didn't answer any of the other questions that I posed, however, it would appear you don't have an A record for your server in that output. This is a question that's been answered many times in the forums and wiki, you could have found the answer without tagging onto this thread.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 02-24-2012, 11:17 AM
  2. Replies: 16
    Last Post: 07-31-2010, 05:56 AM
  3. Replies: 1
    Last Post: 07-02-2009, 02:56 AM
  4. Replies: 1
    Last Post: 12-22-2008, 09:47 PM
  5. Replies: 5
    Last Post: 09-26-2007, 02:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •