Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Certificate Install Error : JavaScript Error

  1. #1
    surajprakash is offline Starter Member
    Join Date
    Oct 2012
    Posts
    3
    Rep Power
    2

    Default Certificate Install Error : JavaScript Error

    Hello All,

    I installed Vmware Zimbra Version : zcs-8.0.0_GA_5434.RHEL6_64.20120907144639.

    When am going to install Self signed certificate then it gives error :
    OS : CentOS 6.2 (64Bit)

    JavaScript error encountered in method ZaCertWizard.prototype.finishWizard

    Please guide me further what i have to do,

    Thanks in Advance

    Surajprakash

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,504
    Rep Power
    57

    Default

    I'll move this thread to the correct forum as it's not a question aboit installing ZCS (which is where you've posted).

    Quote Originally Posted by surajprakash View Post
    I installed Vmware Zimbra Version : zcs-8.0.0_GA_5434.RHEL6_64.20120907144639.

    When am going to install Self signed certificate then it gives error :
    OS : CentOS 6.2 (64Bit)

    JavaScript error encountered in method ZaCertWizard.prototype.finishWizard

    Please guide me further what i have to do,
    What you have to do is provide exact details about what you've done, how you've done it and what commands you've used that gives the error. You also need to provide the full output form the error not just an out-of-context line that means nothing.
    Last edited by phoenix; 10-19-2012 at 09:38 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    jchelink is offline Starter Member
    Join Date
    Oct 2012
    Posts
    1
    Rep Power
    2

    Default

    Hi,

    Release 8.0.0.GA.5434.UBUNTU12.64 UBUNTU12_64 FOSS edition.
    OS : Ubuntu 12.04 LTS 64bits

    I had same issue with commercial SSL certificate from setup wizard, specifically when i tried to upload CSR and CA and click 'install'
    a javascript error occured :

    Erreur de JavaScript in method ZaCertWizard.prototype.finishWizard
    fileName: https://XXXXXXXXXX:7071/service/ziml...v=120907154502 lineNumber: 7839

    is that a bug or i did something wrong ? :-\

    Thanks in advance for your answer,

    JC

  4. #4
    jhtodd is offline Starter Member
    Join Date
    Oct 2012
    Posts
    1
    Rep Power
    2

    Default

    Another person here with the same error - this might be a bug?

    Ubuntu 12.04 LTS
    Release 8.0.0.GA.5434.UBUNTU12.64 UBUNTU12_64 FOSS

    Installation (install.sh) went smoothly (new system; not an upgrade.) Connecting to the :7071 administrative panel works upon first launch, and then it's clear that the first thing that needs to be done is creating a certificate for SSL access. I chose "self-signed" cert. I picked "2048" bit key, used the fully qualified hostname for the common name, left all the country/city/org name fields empty, left the "Subject Alternative Name" as the fully-qualified hostname, and chose "2000" days for cert duration. When I click on "Install" I get a pop-up that says "JavaScript error encountered in method ZaCertWizard.protype.finishWizard" and I can't proceed.

    I've tried with various values in the country/city/org name, hostname, cert duration, etc. I've even "install.sh -u" and tried again from scratch - no luck, same error.

    Any insights would be welcome, and I could give Zimbra staff root access to the device for debugging - contact me at my forum-registered email to discuss.

    [edit: I'd also say that this should be moved back to the "Installation" forum, since cert installation does seem to be pretty relevant to installing the package as a whole, though this error could happen at almost any time.]

  5. #5
    kminamoto's Avatar
    kminamoto is offline Intermediate Member
    Join Date
    Nov 2009
    Location
    Chile
    Posts
    17
    Rep Power
    5

    Default

    Hello, everyone.
    I have the same issue. I had to start a zimbra server from scratch, after a lightning stroke that burnt our old mail server.
    I installed Release 8.0.0_GA_5434.RHEL6_64_20120907144639 CentOS6_64 FOSS edition, and contacted my certificate supplier (COMODO) to reissue a valid cert.
    I connected through the :7071 admin panel, issued the CSR file and sent it to COMODO, which, within a couple of hours sent me the cert files.
    Using, again, the :7071 admin console, I tried to "install the commercially signed cert", but after I entered the 3 files and press Next and "Install", I get the same above described error window:
    JavaScript error encountered in method ZaCertWizard.
    prototype.finishWizard
    fileName: https://NNN.NN.NN.NN:7071/service/zi...=en&country=GB lineNumber: 7867


    I tried installing the cert + the root CA, w/o the intermediate (it's optional anyways), but I get the same error.
    Even more, if I go "Previous" and restart the process, within the same window, it won't find my files, so I had to logout, reenter and restart the process.

    Shall I have to install the cert via console?
    I guess there must be some way to work around this error.
    I appreciate any kind of help.
    Thanks in advance,
    KM.

    --- EDIT ---
    As usual, there's always a way through the console.
    Just follow this wiki page: http://wiki.zimbra.com/wiki/Commercial_Certificates

    Thank you very much and please accept my apologies.
    KM.
    Last edited by kminamoto; 10-24-2012 at 08:15 AM.

  6. #6
    mfehr is offline Senior Member
    Join Date
    Mar 2008
    Posts
    55
    Rep Power
    7

    Default

    I got the same issue as well. The install replaced my self-signed certificate during the upgrade from 7.2.0 to 8.0.0 (I was not happy about this). As the certificate anyway was changed, I wanted to change the description in the certificate through the wizard in the admin console. I was able to update the values from the certificate and hit the "Next" button. I then get prompted to enter the certificate validation days (default=365). The problem is that the Next button is greyed out. If I hit the "Install" button, I get the error "JavaScript error encountered in method ZaCertWizard.prototype.finishWizard"

  7. #7
    ccelis5215 is offline Elite Member
    Join Date
    Jun 2011
    Location
    Caracas Venezuela
    Posts
    462
    Rep Power
    4

    Default

    Quote Originally Posted by mfehr View Post
    I got the same issue as well. The install replaced my self-signed certificate during the upgrade from 7.2.0 to 8.0.0 (I was not happy about this). As the certificate anyway was changed, I wanted to change the description in the certificate through the wizard in the admin console. I was able to update the values from the certificate and hit the "Next" button. I then get prompted to enter the certificate validation days (default=365). The problem is that the Next button is greyed out. If I hit the "Install" button, I get the error "JavaScript error encountered in method ZaCertWizard.prototype.finishWizard"
    Hi mferh, look Bug 76842 – "Install self sign certificate" not working

    ccelis

  8. #8
    surajprakash is offline Starter Member
    Join Date
    Oct 2012
    Posts
    3
    Rep Power
    2

    Default

    Hello All,

    Any body can help me on this ?

    Thanks
    Surajprakash

  9. #9
    noname is offline Active Member
    Join Date
    Nov 2012
    Posts
    26
    Rep Power
    2

    Default

    i have the same issue when i try to setup commercial ssl key from comodo
    i use the last version 8.0.1_GA_5438
    Last edited by noname; 01-12-2013 at 07:11 PM.

  10. #10
    rakeone is offline Starter Member
    Join Date
    Nov 2012
    Posts
    1
    Rep Power
    2

    Default

    Same problem. Is there a bug fix coming or should I tell the company we are going an other way for a mail server ?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 09-16-2011, 08:51 PM
  2. JavaScript error
    By c.bossola in forum General Questions
    Replies: 0
    Last Post: 05-09-2011, 01:12 AM
  3. Replies: 0
    Last Post: 04-07-2011, 10:27 PM
  4. SSL Certificate install error?!
    By leSasch in forum Installation
    Replies: 1
    Last Post: 06-22-2010, 10:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •