Results 1 to 3 of 3

Thread: Migration issue from 32Bit to 64Bit Ubuntu

  1. #1
    mfehr is offline Senior Member
    Join Date
    Mar 2008
    Posts
    55
    Rep Power
    7

    Default Migration issue from 32Bit to 64Bit Ubuntu

    Hi,

    I want to migrate my Ubuntu 8.04 based 7.2.1 32 bit Zimbra installation to Ubuntu 10.04 64 Bit. This will be the 64bit foundation for the further upgrade to Zimbra 8. I followed the guidance Network Edition: Moving from 32-bit to 64-bit Server - Zimbra :: Wiki . A test of the zimbra install before moving data to the 64 bit platform was successful. After moving data and certificates I repeatedly ran into issues. I did the whole procedure 3 times with the same unsuccessful result.

    When starting zimbra, I get the following output:

    Code:
    zimbra@mail:~$ zmcontrol start 
    Host mail.server
    	Starting ldap...Done.
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    	Starting zmconfigd...Done.
    	Starting logger...Failed.
    Starting logswatch...ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.net.ssl.SSLHandshakeException sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: signature check failed)
    zimbra logger service is not enabled!  failed.
    
    	Starting mailbox...Done.
    	Starting antispam...Done.
    	Starting antivirus...Done.
    	Starting snmp...Done.
    	Starting spell...Done.
    	Starting mta...Done.
    	Starting stats...Done.
    It seems to me that there is a problem with the certificates and LDAP. The following certificates where transferred from the 32bit to the 64bit system:

    /opt/zimbra/conf/*.crt ==> nginx/slapd/smtpd
    /opt/zimbra/conf/*.key ==> nginx/slapd/smtpd
    /opt/zimbra/java/jre/lib/security/cacerts
    /opt/zimbra/mailboxd/etc/keystore

    I made sure that all these files have the same ownership and permissions as from the original install on the 64 bit server

    How can I fix these issues?

    Part of zmmailboxd.log
    Code:
    ...
    Zimbra server reserving server socket port=110 bindaddr=null ssl=false
    Zimbra server reserving server socket port=995 bindaddr=null ssl=true
    Fatal error: exception while binding to ports
    java.net.SocketException: Unbound server sockets not implemented
    ...
    Start of zmconfigd.log
    Code:
    2012-10-15 23:59:41,247 zmconfigd CRITICAL [20579-MainThread] zmconfigd started on mail.server with loglevel=3 pid=20579
    2012-10-15 23:59:41,358 zmconfigd WARNING [20579-MainThread] Fetching All configs
    log4j:WARN No appenders could be found for logger (zimbra.ldap).
    log4j:WARN Please initialize the log4j system properly.
    log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
    2012-10-15 23:59:47,078 zmconfigd ERROR [20579-sc] Executed: <function getserver at 0x9> returned 1 (14 - 144) (0.07 sec)
    2012-10-15 23:59:47,079 zmconfigd ERROR [20579-gc] Executed: <function getglobal at 0x5> returned 1 (14 - 144) (0.07 sec)
    2012-10-15 23:59:47,115 zmconfigd CRITICAL [20579-gc] Skipping Global system configuration update.
    2012-10-15 23:59:47,111 zmconfigd CRITICAL [20579-sc] Skipping Configuration for server  update.
    2012-10-15 23:59:47,111 zmconfigd ERROR [20579-mc] Executed: <function garpu at 0x7> returned 1 (14 - 144) (0.09 sec)
    2012-10-15 23:59:47,134 zmconfigd CRITICAL [20579-mc] Skipping All Reverse Proxy URLs update.
    2012-10-15 23:59:47,138 zmconfigd CRITICAL [20579-gc] gacf <function getglobal at 0x5>(None) 1 com.zimbra.common.service.ServiceException: system failure: ZimbraLdapContext ExceptionId:gc:1350338387073:736deff89f5ae539 Code:service.FAILURE
    2012-10-15 23:59:47,144 zmconfigd CRITICAL [20579-sc] gs <function getserver at 0x9>(None) 1 com.zimbra.common.service.ServiceException: system failure: ZimbraLdapContext ExceptionId:sc:1350338387072:736deff89f5ae539 Code:service.FAILURE
    2012-10-15 23:59:47,148 zmconfigd CRITICAL [20579-mc] getAllReverseProxyURLs <function garpu at 0x7>(None) 1 com.zimbra.common.service.ServiceException: system failure: ZimbraLdapContext ExceptionId:mc:1350338387086:736deff89f5ae539 Code:service.FAILURE
    2012-10-15 23:59:47,171 zmconfigd ERROR [20579-mc] Executed: <function garpb at 0xb> returned 1 (14 - 144) (0.01 sec)
    2012-10-15 23:59:47,173 zmconfigd CRITICAL [20579-mc] Skipping All Reverse Proxy Backends update.
    2012-10-15 23:59:47,197 zmconfigd CRITICAL [20579-mc] getAllReverseProxyBackends <function garpb at 0xb>(None) 1 com.zimbra.common.service.ServiceException: system failure: ZimbraLdapContext ExceptionId:mc:1350338387163:736deff89f5ae539 Code:service.FAILURE
    ...
    Ports are looking good (when zimbra is not active):
    Code:
    zimbra@mail:~$ netstat -an | grep LISTEN
    tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN     
    tcp        0      0 0.0.0.0:23              0.0.0.0:*               LISTEN     
    tcp6       0      0 :::22                   :::*                    LISTEN     
    unix  2      [ ACC ]     STREAM     LISTENING     2440     @/com/ubuntu/upstart

  2. #2
    mfehr is offline Senior Member
    Join Date
    Mar 2008
    Posts
    55
    Rep Power
    7

    Default

    Problem solved! The issue is related to certificates. This forum entry helped me to fix the issue: [SOLVED] SOLVED: Zimbra 6.0.1 stop working if SSL certificate is expired . In brief, a new certificate (in my case a self-signed one) has to be created:

    perform as user root

    Code:
    /opt/zimbra/bin/zmcertmgr createca -new
    /opt/zimbra/bin/zmcertmgr createcrt -new -days 365
    /opt/zimbra/bin/zmcertmgr deploycrt self
    /opt/zimbra/bin/zmcertmgr deployca
    /opt/zimbra/bin/zmcertmgr viewdeployedcrt
    /opt/zimbra/java/bin/keytool -import -alias root -keystore /opt/zimbra/java/jre/lib/security/cacerts -storepass changeit -file /opt/zimbra/conf/ca/ca.pem
    Now zimbra starts as expected and the test migration is complete.

  3. #3
    v_augusto is offline New Member
    Join Date
    Jan 2008
    Location
    Lima Peru
    Posts
    4
    Rep Power
    7

    Default

    Thank you Eaperezh, it works perfectly. Well done...!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 04-10-2011, 09:14 AM
  2. Replies: 1
    Last Post: 02-24-2011, 09:07 AM
  3. Replies: 0
    Last Post: 11-18-2010, 06:22 AM
  4. Replies: 0
    Last Post: 02-25-2010, 06:16 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •