Results 1 to 6 of 6

Thread: LDAP stops listening. (post 7-> 8 upgrade)

  1. #1
    cpm
    cpm is offline Senior Member
    Join Date
    Oct 2005
    Posts
    60
    Rep Power
    9

    Default LDAP stops listening. (post 7-> 8 upgrade)

    Using commercial certificate.

    LDAP starts up just fine, things work as expected, then I start getting errors:

    Message: system failure: unable to lookup account via query: (&(zimbraId=c5ef2156-eee3-486e-99fa-f4f99e521708)(objectClass=zimbraAccount)) message: LDAP error: - unable to get connection: An error occurred while attempting to connect to server webmail.eruditium.org:389: java.io.IOException: An error occurred while attempting to establish a connection to server webmail.eruditium.org:389: java.net.ConnectException: Connection refused Error code: service.FAILURE Method: [unknown] Details:soap:Receiver

    Logs show lots and lots of these:


    Oct 5 15:30:45 webmail postfix/trivial-rewrite[5844]: warning: proxy:ldap:/opt/zimbra/conf/ldap-vad.cf: table lookup problem
    Oct 5 15:30:50 webmail postfix/proxymap[5808]: error: dict_ldap_connect: Unable to set STARTTLS: -1: Can't contact LDAP server


    restarting zimbra fixes this for a little while

    but eventually, it starts failing again.

    netstat shows the port available

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,579
    Rep Power
    57

    Default

    How much RAM is on this server? Is it a VM?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    cpm
    cpm is offline Senior Member
    Join Date
    Oct 2005
    Posts
    60
    Rep Power
    9

    Default

    Quote Originally Posted by phoenix View Post
    How much RAM is on this server? Is it a VM?
    Hey Bill;

    Yes, It's a VM,
    2 gigs of memory, and all of a dozen users, any 2 of which might use it at the same time.

    FWIW, I used to see something like this every few months under 7.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,579
    Rep Power
    57

    Default

    Quote Originally Posted by cpm View Post
    Yes, It's a VM,
    Which hypervisor?

    Quote Originally Posted by cpm View Post
    2 gigs of memory,
    Real RAM or burst?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    cpm
    cpm is offline Senior Member
    Join Date
    Oct 2005
    Posts
    60
    Rep Power
    9

    Default

    At this stage, I'm going to blame ldap.

    I've upgraded to openldap 2.4.33, and I'll know by tomorrow if that's what was the issue.

    Bill:

    Xen
    and 'real' (FSVO 'real'). as in dedicated.

  6. #6
    cpm
    cpm is offline Senior Member
    Join Date
    Oct 2005
    Posts
    60
    Rep Power
    9

    Default

    upgrading ldap 2.4.33 did not fix anything.

    It was oom that was killing ldap.

    adding more swap seems to have stabilized it. Been up for days now, with no further issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ldap sync broken in post-6.0.5 upgrade
    By gnyce in forum Administrators
    Replies: 1
    Last Post: 02-22-2010, 02:35 PM
  2. LDAP Stops after full backup
    By fultonj in forum Administrators
    Replies: 6
    Last Post: 04-07-2009, 05:15 PM
  3. Logger stops by itself after 5.0.15 upgrade
    By nufan in forum Installation
    Replies: 19
    Last Post: 03-28-2009, 03:20 PM
  4. LDAP not listening?
    By dkensiski in forum Administrators
    Replies: 1
    Last Post: 11-21-2006, 12:27 PM
  5. LDAP Replication Stops
    By rsharpe in forum Administrators
    Replies: 1
    Last Post: 05-03-2006, 09:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •