Results 1 to 3 of 3

Thread: DNS problem on Migration (Centos 7 to 8)

  1. #1
    cyber7 is offline Special Member
    Join Date
    May 2010
    Location
    Cape Town; South Africa
    Posts
    102
    Rep Power
    5

    Angry DNS problem on Migration (Centos 7 to 8)

    Good day everybody.
    I am trying to migrate Zimbra 7.13 to Zimbra 8 on CentOS and I have the following problem, causing me absolute nightmares:

    1. Creating a second server CentOS 6.3 (Final) and starting the Split DNS on it, causes my mailq on my main server to defer all my mail.
    2. Stopping the NEW SERVER's network does not improve the scenario.
    3. The MAIN SERVER keeps on reporting on my DIG COMMAND: "connection timed out; no servers could be reached".
    4. The mail-logs reports: Host or domain name not found. Name service error for name=<MY HOST> type=A not found, try again and,
    5. delivery temporarily suspended: Host or domain name not found. Name service error for name=<ISP HOST> type=MX: Host not found, try again

    My question is this:
    1. How do I duplicate my "SplitDNS" environment so that I can install ZIMBRA 7.13 on a new CentOS 6.3 Server?
    2. AND HOW DO I FIX THE MAIL NOT FLOWING? It takes for ever to deliver mail once I get into this DNS Problem...

    Kind regards
    Aubrey Kloppers
    ps - It does not help reading the WIKI, there is nothing that I have not tried...
    Code:
    Never trust a fart...
    Release 8.0.0_GA_5434.RHEL6_64_20120907144743 CentOS6_64 NETWORK edition.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

    Default

    You can't have two mail servers running with the same domain names and expect mail to flow into both of them, think about it. It would also depend on which instructions your following to move from one server to another. As a general comment with the limited information you've given you would want to use a Split Domain to have both servers running at the same time.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    cyber7 is offline Special Member
    Join Date
    May 2010
    Location
    Cape Town; South Africa
    Posts
    102
    Rep Power
    5

    Default

    Hi Bill
    (Long time no write!)
    Yes, the SLIT DNS is running on both the servers. Both servers have been configured EXACTLY the same.

    Comparing the two servers:
    1. /etc/hosts the same (but for the local mail server ip numbers)
    2. /etc/resolv.conf the same
    3. /etc/named.conf the same (except for the "listen on" internal IP numbers)
    4. /etc/named/* files the same (except for the ip numbers in the various config files)

    Notes:
    Both the servers can reach the Internet
    Both Server's MX DIG shows the correct info for the servers.

    What I attempt doing:
    1. Get both the server on 7.1.3 (ORIGINAL on CentOS5.n, NEW on CentOS 6.4).
    2. rsync the /opt/zimbra from ORIGINAL to NEW.
    3. Once everything is sync'ed, take down the ORIGINAL and bring up the NEW. (after copying the /etc/hosts and /etc/named/ and /etc/named.conf files)
    4. Upgrade the NEW to Zimbra 8.

    I hope you understand
    Kind regards
    Aubrey Kloppers
    Bible Society of SA
    Cape Town
    South Africa
    Code:
    Never trust a fart...
    Release 8.0.0_GA_5434.RHEL6_64_20120907144743 CentOS6_64 NETWORK edition.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 03-27-2012, 11:05 AM
  2. ZCS FOSS 5 Migration to CentOS 5.6
    By r8escjohn in forum Administrators
    Replies: 12
    Last Post: 08-01-2011, 09:03 PM
  3. ZCS FOSS 5 Migration to CentOS 5.6
    By r8escjohn in forum Migration
    Replies: 2
    Last Post: 07-19-2011, 02:24 PM
  4. Migration from Mac OS X to Centos - LDAP Problem
    By harreaic in forum Migration
    Replies: 2
    Last Post: 11-04-2010, 05:08 AM
  5. Migration problem from FC3 to Centos 4.3
    By kibo in forum Migration
    Replies: 5
    Last Post: 01-02-2007, 07:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •