Results 1 to 4 of 4

Thread: Updating ZCS 7 from Debian 5 to ZCS 8 on Ubuntu 12.04

  1. #1
    jMCg's Avatar
    jMCg is offline New Member
    Join Date
    Jun 2009
    Rep Power

    Question Updating ZCS 7 from Debian 5 to ZCS 8 on Ubuntu 12.04

    Hey folks,

    my current installation of ZCS OSE is version 7.0.0, running on Debian 5/64bit.
    I hesitated migrating to 7.2 because it didn't support my current target platform Ubuntu 12.04. Ubuntu 10.04 is not installable on my servers.

    Now the time has come that I actually <strong>have to</strong> do it.

    From what I gather, the sanest way would be to try again to install an Ubuntu 10.04 system as intemediary, and update the old server to 7.2, then follow these instructions: Moving ZCS to New Server - Zimbra :: Wiki

    Does someone know a saner way?
    Do I have to update to 7.2 first? Or can I upgrade from 7.0 to 8 directly?

  2. #2
    Crayz9000 is offline Senior Member
    Join Date
    Feb 2012
    Las Vegas
    Rep Power


    I have a Debian 6 server and as of ZCS 7, I was able to use the Ubuntu 10.04 LTS packages with only a minor change to the dpkg version. I also tried the Debian 5 package for ZCS7 and it worked as well.

    I suspect that, as long as you downgrade the dpkg version in Debian 6, you should be able to use the ZCS8 Ubuntu 10.04 LTS package just fine. That would make the upgrade process easier, since all you would have to do then would be to shutdown ZCS7 and disable the startup script, upgrade Debian, and then install the ZCS8 update using the 10.04 package.

    I plan on making the change as well, but I had figured on giving the ZCS8 OSE release a couple weeks before I make the jump just in case any major issues pop up in that timeframe.
    Release 8.0.2.GA.5569.UBUNTU10.64 DEBIAN6_64 FOSS edition

  3. #3
    ianw1974 is offline Active Member
    Join Date
    Oct 2009
    Rep Power


    I have done this today for upgrading from Debian 5 to Ubuntu 12 directly. Here is how I did it.

    1. Create server with Ubuntu 12. Install Zimbra 8 like this:

    ./ -s
    this will install Zimbra 8 without configuration. Make sure that zimbra and postfix UID/GID's are the same as Debian server.

    2. Rename on Ubuntu /opt/zimbra to /opt/zimbra.old (or delete if you wish).

    3. Stop Zimbra on Debian 5 and tar /opt/zimbra:

    cd /opt
    tar cvjpf zimbra-7.2.1.tar.bz2 zimbra
    and then copy the tar file to the Ubuntu server in directory /opt. Alternatively rsync to the other server if you wish.

    4. Unpack the tar:

    cd /opt
    tar xvjpf zimbra-7.2.1.tar.bz2
    you will now have /opt/zimbra from Debian unpacked.

    5. Upgrade to v8 by running:

    this time without the -s switch. It will then upgrade from 7.2.1 to 8.0.0. The package list will show that debs for Zimbra 8 installed, but this is OK. Here is my full log:

    root@mail:~/zcs-8.0.0_GA_5434.UBUNTU12_64.20120907144631# ./
    Operations logged to /tmp/install.log.1192
    Checking for existing installation...
        zimbra-ldap...FOUND zimbra-ldap-8.0.0.GA.5434.UBUNTU12.64
        zimbra-logger...FOUND zimbra-logger-8.0.0.GA.5434.UBUNTU12.64
        zimbra-mta...FOUND zimbra-mta-8.0.0.GA.5434.UBUNTU12.64
        zimbra-snmp...FOUND zimbra-snmp-8.0.0.GA.5434.UBUNTU12.64
        zimbra-store...FOUND zimbra-store-8.0.0.GA.5434.UBUNTU12.64
        zimbra-apache...FOUND zimbra-apache-8.0.0.GA.5434.UBUNTU12.64
        zimbra-spell...FOUND zimbra-spell-8.0.0.GA.5434.UBUNTU12.64
        zimbra-convertd...NOT FOUND
        zimbra-memcached...FOUND zimbra-memcached-8.0.0.GA.5434.UBUNTU12.64
        zimbra-proxy...NOT FOUND
        zimbra-archiving...NOT FOUND
        zimbra-cluster...NOT FOUND
        zimbra-core...FOUND zimbra-core-8.0.0.GA.5434.UBUNTU12.64
    ZCS upgrade from 8.0.0 to 8.0.0 will be performed.
    Saving existing configuration file to /opt/zimbra/.saveconfig
    Do you agree with the terms of the software license agreement? [N] y
    Checking for prerequisites...
         FOUND: NPTL
         FOUND: netcat-openbsd-1.89-4ubuntu1
         FOUND: sudo-1.8.3p1-1ubuntu3.3
         FOUND: libidn11-1.23-2
         FOUND: libpcre3-8.12-4
         FOUND: libgmp3c2-2:4.3.2+dfsg-2ubuntu1
         FOUND: libexpat1-2.0.1-7.2ubuntu1.1
         FOUND: libstdc++6-4.6.3-1ubuntu5
         FOUND: libperl5.14-5.14.2-6ubuntu2.1
    Checking for suggested prerequisites...
         FOUND: perl-5.14.2
         FOUND: sysstat
         FOUND: sqlite3
    Prerequisite check complete.
    Checking current number of databases...
    Do you want to verify message store database integrity? [Y] n
    Checking for installable packages
    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell
    Found zimbra-memcached
    Found zimbra-proxy
    The Zimbra Collaboration Server appears already to be installed.
    It can be upgraded with no effect on existing accounts,
    or the current installation can be completely removed prior
    to installation for a clean install.
    Do you wish to upgrade? [Y]
    Select the packages to install
        Upgrading zimbra-core
        Upgrading zimbra-ldap
        Upgrading zimbra-logger
        Upgrading zimbra-mta
        Upgrading zimbra-snmp
        Upgrading zimbra-store
        Upgrading zimbra-apache
        Upgrading zimbra-spell
        Upgrading zimbra-memcached
    Install zimbra-proxy [N]
    Checking required space for zimbra-core
    Checking space for zimbra-store
    The system will be modified.  Continue? [N] y
    Shutting down zimbra mail
    Backing up the ldap database...done.
    Removing existing packages
    Removing deployed webapp directories
    Installing packages
    Setting defaults from saved config in /opt/zimbra/.saveconfig/
    Restoring existing configuration file from /opt/zimbra/.saveconfig/localconfig.xml...done
    Operations logged to /tmp/zmsetup.09262012-104522.log
    Upgrading from 7.2.1_GA_2790 to 8.0.0_GA_5434
    Stopping zimbra services...done.
    Starting mysql...done.
    This appears to be 7.2.1_GA
    Upgrading ldap data...done.
    Upgrading LDAP configuration database...done.
    Loading database...done.
    Checking ldap status...not running.
    Running zmldapapplyldif...done.
    Checking ldap status...not running.
    Starting ldap...done.
    Checking ldap status...already running.
    Redolog version update required.
    Wed Sep 26 10:45:59 2012: Verified redolog version 1.31.
    Wed Sep 26 10:45:59 2012: Updating Redolog schema version from 1.31 to 1.42.
    Redolog version update finished.
    Schema upgrade required from version 65 to 91.
    Running /opt/zimbra/libexec/scripts/
    Wed Sep 26 10:46:02 2012: Verified schema version 65.
    Wed Sep 26 10:46:02 2012: Adding device information columns to ZIMBRA.MOBILE_DEVICES table...
    Wed Sep 26 10:46:03 2012: Adding ZIMBRA.PENDING_ACL_PUSH table...
    Wed Sep 26 10:46:04 2012: Adding TAG table...
    Wed Sep 26 10:46:06 2012: Adding TAGGED_ITEM table...
    Wed Sep 26 10:46:08 2012: Adding version and last_purge_at columns to ZIMBRA.MAILBOX table...
    Wed Sep 26 10:46:08 2012: Adding/Modifying columns in mail_item, mail_item_dumpster, revision, revision_dumpster tables...
    Wed Sep 26 10:46:17 2012: Dropping IM tables...
    Wed Sep 26 10:46:18 2012: Verified schema version 65.
    Wed Sep 26 10:46:18 2012: Updating DB schema version from 65 to 90.
    Running /opt/zimbra/libexec/scripts/
    Wed Sep 26 10:46:21 2012: Verified schema version 90.
    Wed Sep 26 10:46:24 2012: Verified schema version 90.
    Wed Sep 26 10:46:24 2012: Updating DB schema version from 90 to 91.
    Stopping mysql...done.
    Updating from 8.0.0_BETA1
    Adding dynamic group configuration
    Stopping ldap...done.
    Checking ldap status...not running.
    Running zmldapapplyldif...done.
    Checking ldap status...not running.
    Starting ldap...done.
    Stopping ldap...done.
    Checking ldap status...not running.
    Running zmldapapplyldif...done.
    Checking ldap status...not running.
    Starting ldap...done.
    Updating from 8.0.0_BETA2
    Starting mysql...done.
    Stopping mysql...done.
    Updating from 8.0.0_BETA3
    Updating from 8.0.0_BETA4
    Stopping ldap...done.
    Checking ldap status...not running.
    Running zmldapapplyldif...done.
    Checking ldap status...not running.
    Starting ldap...done.
    Stopping ldap...done.
    Checking ldap status...not running.
    Running zmldapapplyldif...done.
    Checking ldap status...not running.
    Starting ldap...done.
    Stopping ldap...done.
    Checking ldap status...not running.
    Running zmldapapplyldif...done.
    Checking ldap status...not running.
    Starting ldap...done.
    Stopping ldap...done.
    Checking ldap status...not running.
    Running zmldapapplyldif...done.
    Checking ldap status...not running.
    Starting ldap...done.
    Updating from 8.0.0_BETA5
    Updating from 8.0.0_GA
    Updating global config and COS's with attributes introduced after 7.2.1_GA...done.
    Stopping ldap...done.
    Upgrade complete.
    Running zmldapapplyldif...done.
    Checking ldap status....not running.
    Starting ldap...done.
    Setting defaults...done.
    Setting defaults from existing config...done.
    Checking for port conflicts
    Setting defaults from ldap...done.
    Saving config in /opt/zimbra/config.11423...done.
    Operations logged to /tmp/zmsetup.09262012-104522.log
    Setting local config values...done.
    Initializing core config...Setting up CA...done.
    Deploying CA to /opt/zimbra/conf/ca ...done.
    Warning: No valid SSL certificates were found.
    New self-signed certificates will be generated and installed.
    Creating new zimbra-sore SSL certificate...done.
    Creating new zimbra-ldap SSL certificate...done.
    Creating new zimbra-mta SSL certificate...done.
    Installing mailboxd SSL certificates...done.
    Installing MTA SSL certificates...done.
    Installing LDAP SSL certificate...done.
    Stopping ldap...done.
    Running zmldapapplyldif...done.
    Checking ldap status....not running.
    Starting ldap...done.
    Setting replication password...done.
    Setting Postfix password...done.
    Setting amavis password...done.
    Setting nginx password...done.
    Creating server entry for mail.mydomain...already exists.
    Setting Zimbra IP Mode...done.
    Saving CA in ldap ...done.
    Saving SSL Certificate in ldap ...done.
    Setting spell check URL...done.
    Setting service ports on mail.mydomain...done.
    Adding mail.mydomain to zimbraMailHostPool in default COS...done.
    Setting Keyboard Shortcut Preferences...done.
    Setting zimbraFeatureTasksEnabled=TRUE...done.
    Setting zimbraFeatureBriefcasesEnabled=TRUE...done.
    Setting MTA auth host...done.
    Setting TimeZone Preference...done.
    Initializing mta config...done.
    Setting services on mail.mydomain...done.
    Creating user spamx123456...already exists.
    Creating user nospamx123456...already exists.
    Creating user virus-quarantinex123456...already exists.
    Setting spam training and Anti-virus quarantine accounts...done.
    Configuring SNMP...done.
    Setting up syslog.conf...done.
    Starting servers...done.
    Checking for deprecated zimlets...done.
    Checking for network zimlets in LDAP...done.
    Removing network zimlets...
    Finished removing network zimlets.
    Installing common zimlets...
    Finished installing common zimlets.
    Getting list of all zimlets...done.
    Updating non-standard zimlets...
    Finished updating non-standard zimlets.
    Restarting mailboxd...done.
    Skipping creation of default domain GAL sync account - existing install detected.
    You have the option of notifying Zimbra of your installation.
    This helps us to track the uptake of the Zimbra Collaboration Server.
    The only information that will be transmitted is:
            The VERSION of zcs installed (8.0.0_GA_5434_UBUNTU12_64)
            The ADMIN EMAIL ADDRESS created ()
    Notify Zimbra of your installation? [Yes] no
    Notification skipped
    Setting up zimbra crontab...done.
    Moving /tmp/zmsetup.09262012-104522.log to /opt/zimbra/log
    Configuration complete - press return to exit
    and my Zimbra is working fine

    Maybe /opt/zimbra/libexec/zmfixperms might be required, but I didn't do it. And nothing is shouting that something is wrong. Have fun! Maybe it won't work for you, but it worked for me. So I'm not to blame if something goes wrong. Make sure you have a backup.

  4. #4
    jMCg's Avatar
    jMCg is offline New Member
    Join Date
    Jun 2009
    Rep Power


    So I'm done with this update, and I'd like to document it here before it moves out of my memory:

    What we did was fairly straight-forward:

    We set up a server with Ubuntu 10.04 and installed zimbra 7 for that, downloaded from archives: Open Source Edition Downloads: Enterprise Messaging and Collaboration Software by Zimbra

    Next, we stopped zimbra on that server and rsynced /opt/zimbra from production to this test server.

    We then ran an update from zimbra 7 to zimbra 8.

    After that, we did a do-release-upgrade.
    Rebooting in to the "new" OS left us "of course", with a broken zimbra installation, but that's nothing that another run couldn't fix:

    We re-installed Zimbra 8, for Ubuntu 12 this time.

    In our "special" setup, we ran into two more bugs: one was This zmstats-ldap bug:
    This was caused due to the fact that we have TLS enabled for everything.

    The other was that sldapd wouldn't start, because of our sysctl settings:
    # disable OOM killer and memory overcommit
    vm.overcommit_memory = 2
    vm.overcommit_ratio = 100
    In order to fix this, because we really don't like the OOM killer, we had to reduce slapd's memory allocation, which by default is very high in Zimbra:
    zmlocalconfig -e ldap_db_maxsize=104857600
    zmlocalconfig -e ldap_accesslog_maxsize=104857600
    Sets the accesslog and the main DB's max size to 100 MiB, respectively, which, in our case was more than enough.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Debian & Ubuntu EOL...
    By pbrunnen in forum Administrators
    Replies: 0
    Last Post: 06-29-2011, 02:45 PM
  2. Replies: 4
    Last Post: 01-18-2011, 02:36 PM
  3. Moving from Ubuntu 6.06 to Debian 4
    By azeem in forum Migration
    Replies: 0
    Last Post: 09-12-2008, 10:36 AM
  4. Migration from Debian to Ubuntu
    By mave28 in forum Migration
    Replies: 3
    Last Post: 05-25-2007, 06:44 AM
  5. Replies: 2
    Last Post: 03-15-2006, 09:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts