Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 8.0.0 Main.cf not persistent after postfix reload

  1. #1
    rcjokibbe is offline Junior Member
    Join Date
    Sep 2011
    Location
    San Gabriel, CA
    Posts
    9
    Rep Power
    3

    Default 8.0.0 Main.cf not persistent after postfix reload

    I used the Outgoing SMTP Authentication wiki to configure my 7.1 Zimbra to use smtp.yahoo.com, and it would continue to work after restarts. I have since upgraded to 8.0.0 and I followed the same wiki, because the changes are not cross upgrade persistent, but now the changes won't stay after doing the postfix reload step.

    Should I be configuring this a different way?

  2. #2
    thopu is offline Junior Member
    Join Date
    Aug 2012
    Location
    Germany
    Posts
    9
    Rep Power
    2

    Default

    Instead of using the postconf -e commands (for Zimbra will overwwrite the postfix main.cf at start), change the zmconfigd.cf as follows:
    zmlocalconfig -e postconf_smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password
    zmlocalconfig -e postconf_smtp_sasl_auth_enable=yes
    zmlocalconfig -e postconf_smtp_cname_overrides_servername=no
    zmlocalconfig -e postconf_smtp_use_tls=yes
    zmlocalconfig -e postfix_smtp_sasl_security_options=noanonymous // Depending on your requirement

    Quote Originally Posted by rcjokibbe View Post
    I used the Outgoing SMTP Authentication wiki to configure my 7.1 Zimbra to use smtp.yahoo.com, and it would continue to work after restarts. I have since upgraded to 8.0.0 and I followed the same wiki, because the changes are not cross upgrade persistent, but now the changes won't stay after doing the postfix reload step.

    Should I be configuring this a different way?

  3. #3
    rcjokibbe is offline Junior Member
    Join Date
    Sep 2011
    Location
    San Gabriel, CA
    Posts
    9
    Rep Power
    3

    Default

    Thank you for your help. It appears that the zmlocalconfig -e postconf_smtp_sasl_auth_enable=yes does not edit the main.cf file. That line continues to have a value of no. I have to enter postconf -e smtp_sasl_auth_enable=yes to change it.

  4. #4
    thopu is offline Junior Member
    Join Date
    Aug 2012
    Location
    Germany
    Posts
    9
    Rep Power
    2

    Default

    Indeed, this command won't edit the main.cf of Postfix, but instead the zmconfigd.cf of Zimbra. And there are some rewrite rules, which overwrites the Postfix main.cf at each mta reload.
    You can edit the zmconfigd.cf manually. Look for the "SECTION mta DEPENDS amavis", there are several POSTCONF rules. Find the corresponding entries, as I wrote above, and change them for your need. Maybe I had a slight mistake with the zmlocalconfig commands, but edit manually should do the trick.

    Edit says:
    Of course, my fault:
    zmlocalconfig -e postfix_smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password
    zmlocalconfig -e postfix_smtp_sasl_auth_enable=yes
    zmlocalconfig -e postfix_smtp_cname_overrides_servername=no
    zmlocalconfig -e postfix_smtp_use_tls=yes
    zmlocalconfig -e postfix_smtp_sasl_security_options=noanonymous // Depending on your requirement

    The keys have a preceding postfix_ not a preceding postconf_ if you you use the zmlocalconfig.
    Last edited by thopu; 09-18-2012 at 12:09 AM.

  5. #5
    rcjokibbe is offline Junior Member
    Join Date
    Sep 2011
    Location
    San Gabriel, CA
    Posts
    9
    Rep Power
    3

    Default

    Happy day. Using postfix in the command made it persistent. I had read the first part of your reply, to edit the zmconfigd.cf file directly, but I didn't undertand that files layout and where to put the values (I didn't see values for other entries either), so I read the rest of your post and glad to see it was a typo with the zmlocalconfig commands. Thank you for your help.

  6. #6
    thopu is offline Junior Member
    Join Date
    Aug 2012
    Location
    Germany
    Posts
    9
    Rep Power
    2

    Default

    Your welcome. After all, it was my fault in the first place, why you had to take another run.

  7. #7
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,195
    Rep Power
    9

    Default

    Never modify zmconfigd.cf
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  8. #8
    chtse5310 is offline Junior Member
    Join Date
    Jun 2012
    Posts
    6
    Rep Power
    2

    Default

    Quote Originally Posted by quanah View Post
    Never modify zmconfigd.cf
    Can you elaborate on how to solve the problem of main.cf changes not persistent after postfix reload without modifying zmconfigd.cf? We need to change main.cf in order to enable smtp_sasl_auth_enable and other related parameters so that a relay host requiring authentication can be configured with postconf -e command. We can configure SMTP relay host authentication with the postconf -e command in version before 8.0.0GA but lose the ability to do that after upgrading to 8.0.0.GA.

  9. #9
    Wasowski is offline Senior Member
    Join Date
    Oct 2011
    Posts
    54
    Rep Power
    3

    Default

    Quote Originally Posted by rcjokibbe View Post
    Happy day. Using postfix in the command made it persistent. I had read the first part of your reply, to edit the zmconfigd.cf file directly, but I didn't undertand that files layout and where to put the values (I didn't see values for other entries either), so I read the rest of your post and glad to see it was a typo with the zmlocalconfig commands. Thank you for your help.
    Did it solved your problem ?

  10. #10
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,195
    Rep Power
    9

    Default

    You would set the related zmlocalconfig value, that way it persists across upgrades.

    zimbra@zre-ldap002:~$ zmlocalconfig | grep smtp_sasl_auth_enable
    postfix_smtp_sasl_auth_enable = no
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Entry to make persistent in main.cf
    By blason in forum Administrators
    Replies: 0
    Last Post: 12-22-2011, 11:56 AM
  2. Postfix main.cf error
    By hmsdh in forum Administrators
    Replies: 1
    Last Post: 04-06-2011, 05:59 AM
  3. [SOLVED] Postfix main.cf overwrite
    By InfoAddict in forum Administrators
    Replies: 2
    Last Post: 05-01-2008, 05:05 PM
  4. postfix reload error
    By yysiow in forum Administrators
    Replies: 2
    Last Post: 06-15-2007, 11:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •