Results 1 to 6 of 6

Thread: Undeliverable Mail -- Weird

  1. #1
    jim.thornton is offline Loyal Member
    Join Date
    May 2010
    Posts
    95
    Rep Power
    5

    Default Undeliverable Mail -- Weird

    Okay this is weird. I have been running Zimbra on a server at my house which is connected to the internet via DSL 6mps/800kps. My connection is always pretty good at my house. I have had no problems with this.

    About a week ago my remote server went down which contained a bunch of websites for family/friends which resulted in emails being down for 3 days due to the malfunction.

    As a result I transferred all of their email addresses to my box and updated the DNS on my remote server to point the MX records and mail.domain.com A records to my home server (static IP).

    Everything was working but then 3 days ago my father was getting hundreds and hundreds of Mail Delivery Failed messages. I thought at first someone might have hacked his password because he always does easy ones. Then I changed the password to a randomly generated one with 8 characters, upper case, lower case and numbers. That didn't change anything. Then I read some posts about adding some RBL's so I did that and that seems to have filtered them down to about 20 or so per day, but he shouldn't be getting any because he is not sending any out.

    I scanned his computer for viruses and there were 4 viruses (all in the java cache). Those were deleted.

    I'm not sure what is going on.

    My sister contacted me today and my mother tried to send her an email this morning (both on the zimbra server but different domains) and the message was returned back. They are using their ISP SMTP server so that makes sense why it didn't just go to my sisters inbox. This is the message that I got back from her:

    Code:
    The following message to <email address> was undeliverable.
    The reason for the problem:
    5.1.2 - Bad destination host 'DNS Hard Error looking up quickmortgageapprovals.ca (MX):  NXDomain'
    I did a search for this error message and found on Google that someone said it is caused by no A record being present. I logged into my remote server (DNS Management) and noticed that all the records seem to be correct. I then logged into my Zimbra box via Webmin and it seems that my server is setup correctly (it doesn't list this particular domain though, only my main mail server).

    Can someone please help me debug this issue?
    Release 7.1.2_GA_3268.UBUNTU10_64 UBUNTU10_64 FOSS edition.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,483
    Rep Power
    56

    Default

    If that domain name is correct (or have you changed it) then it doesn't have any A record, however you really should check it with some DNS check site.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    jim.thornton is offline Loyal Member
    Join Date
    May 2010
    Posts
    95
    Rep Power
    5

    Default

    Wow, I didn't even think of this... It appears my sister let her domain expire. Thanks for the help. I have gotten her to renew her domain.

    As for the other Undeliverable problem with my father, any suggestions from anyone?
    Release 7.1.2_GA_3268.UBUNTU10_64 UBUNTU10_64 FOSS edition.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,483
    Rep Power
    56

    Default

    Quote Originally Posted by jim.thornton View Post
    As for the other Undeliverable problem with my father, any suggestions from anyone?
    You need to post some log file information and the headers from these emails. Do you have any idea if they're locally generated (is there any bot or virus on the LAN or his computer) or are they being submitted remotely to your server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    jim.thornton is offline Loyal Member
    Join Date
    May 2010
    Posts
    95
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    You need to post some log file information and the headers from these emails. Do you have any idea if they're locally generated (is there any bot or virus on the LAN or his computer) or are they being submitted remotely to your server?
    How can I check to see if there is any bot on the LAN? I don't think so though because his email address is the only one affected out of about 8 on the same LAN. Also, which LOG file should I post?
    Release 7.1.2_GA_3268.UBUNTU10_64 UBUNTU10_64 FOSS edition.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,483
    Rep Power
    56

    Default

    Windows or Linux? You'll need to check the machines individually, some methods here:

    +windows +"check for a bot" - Yahoo! Search Results
    +linux +"check for a bot" - Yahoo! Search Results
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Undeliverable Mail MTA Blocked
    By borngunners in forum Administrators
    Replies: 1
    Last Post: 11-13-2009, 03:50 PM
  2. Undeliverable mail - Note: Soap Fault
    By newbie79 in forum Administrators
    Replies: 2
    Last Post: 09-09-2009, 09:43 AM
  3. undeliverable mail with attach : no original mail ?
    By sperkins in forum Administrators
    Replies: 0
    Last Post: 04-01-2009, 08:29 AM
  4. Mail Undeliverable to some Hosts
    By emmaylots in forum Administrators
    Replies: 2
    Last Post: 07-25-2008, 05:55 AM
  5. configuring undeliverable mail settings
    By emmaylots in forum Administrators
    Replies: 3
    Last Post: 05-26-2008, 03:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •