Results 1 to 6 of 6

Thread: can't send mails to internet with same domain-name

  1. #1
    waintdeir is offline New Member
    Join Date
    Sep 2012
    Posts
    4
    Rep Power
    2

    Question can't send mails to internet with same domain-name

    hi,

    i have a problem configuring the zimbra-server to send emails from our local server to the internet with the same domain (for example @company.com)

    example:

    i can send and recieve email between our local accounts and any external provider (user1@company.com <---> userX@hotmail.com for example)
    i can receive emails from external over the internet in the same domain (userExternal@company.com ---> CompanyMailProvider ---> [fetchmail to internal Server] ---> userInternal@company.com)
    i can send email between 2 local accounts (user1@company.com <----> user2@company.com)

    what i can't is to send mails from internal accounts to external accounts in the same domain via Internet ( userInternal@company.com --X--> CompanyMailProvider ---> userExternal@company.com)

    what do i need to configure that our server only handles all our internal emails locally?? and sends all other email (even with same domain) to our CompanyMailProvire (here: 1und1.de)??

    greetings, waintdeir

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Split Domain is what you're looking for, search the wiki and the forums for details.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    waintdeir is offline New Member
    Join Date
    Sep 2012
    Posts
    4
    Rep Power
    2

    Default

    thanks,

    but when i read about this "tutorial", how does the zimbra-server know which mails are local and which mails have to be sent over internet?

    EDIT: our scenario is "configuring Zimbra as the secondary system"

    EDIT2: or is Zimbra first trying to send local, and if this fails, trying to send via internet?

    EDIT3: what do i need to change/setup/configure on our Zimbra-server that i enable the split-domain-settings on a runnning system? we are online since 5 days and all emails with the same domain are not going out of our company...they get rejected... is there a setting in the admin console that i can change to enable this?
    Last edited by waintdeir; 09-14-2012 at 12:01 AM.

  4. #4
    waintdeir is offline New Member
    Join Date
    Sep 2012
    Posts
    4
    Rep Power
    2

    Default

    now i want to configure my server as secondary system.

    i have to enter this as told in the tutorial:

    $ zmprov md mydomain.at zimbraMailCatchAllAddress @mydomain.at
    $ zmprov md mydomain.at zimbraMailCatchAllForwardingAddress @mydomain.at
    $ zmprov md mydomain.at zimbraMailTransport smtp.onlineprovider.de

    am i right about "smtp.onlineprovider.de" ???

    and if i wanna go back, where are theese settings saved, that i can undo this changes????

  5. #5
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    zimbraMailTransport should be in the form of protocol:hostort with ort being optional and defaulting to :25 if not specified. For your example smtp:smtp.onlineprovider.de:25

    You can set these attributes to null to undo changes.
    zmprov md mydomain.at zimbraMailCatchAllAddress ''
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #6
    waintdeir is offline New Member
    Join Date
    Sep 2012
    Posts
    4
    Rep Power
    2

    Default

    thank you, everything is working now.

    Just for everybody else having the same problems:

    it was correct to cunfigure our system as a secondary one.
    we also had to configure TLS-Authenification (enable SMTP authentification) (Infos: Outgoing SMTP Authentication - Zimbra :: Wiki) and do some additional settings (Infos: Postfix) like my workmate found out.

    Problem solved.


    Regards

    waintdeir

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mails Not able to send some Domain
    By selva80 in forum Administrators
    Replies: 0
    Last Post: 08-07-2012, 01:26 AM
  2. Replies: 4
    Last Post: 05-02-2012, 07:17 AM
  3. Replies: 1
    Last Post: 10-15-2010, 03:01 AM
  4. Replies: 5
    Last Post: 08-16-2010, 05:33 AM
  5. Not able to send mails to external domain
    By chandu in forum Administrators
    Replies: 19
    Last Post: 09-07-2009, 12:33 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •