Results 1 to 7 of 7

Thread: Zimbra user backup failure

  1. #1
    sztupi is offline New Member
    Join Date
    Aug 2012
    Posts
    4
    Rep Power
    3

    Default Zimbra user backup failure

    Hi All !

    I installed a Zimbra server (on ubuntu 10.06 64 bit) -zcs-7.2.0_GA_2669.UBUNTU10_64.20120410002303-.

    It is working well. I can send/receive emails, work the web inteface good etc....

    But when I want backup/restore zimbrausers I am getting the following error when trying to run zmprov commands:

    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)

    The DNS, MX records is ok , because the server is working well. I think..
    I use a another DNS server, not the SplitDns.

    Can someone direct me to the problem and its resolution?


    Thank's

    Sztupi

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    I'll move this to the correct forum as it's not a problem about Installing Zimbra (which is where you've posted).

    Quote Originally Posted by sztupi View Post
    But when I want backup/restore zimbrausers I am getting the following error when trying to run zmprov commands:

    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    Why have you titled this thread "....user backup failure"? The OSS version doesn't have a backup function and as far as I can see it's a 'connection refused' problem running zmprov, did you look at some of the other forum threads on this topic? You should also check that all the services are running and if there's any errors in the log files.


    Quote Originally Posted by sztupi View Post
    The DNS, MX records is ok , because the server is working well. I think..
    I use a another DNS server, not the SplitDns.
    If you're behind a NAT router then you'll have a Split DNS whether the DNS server is on your Zimbra server or on another server. I'd suggest, just for confirmation, you post the output of all the commands from the 'Verify....' section of the Split DNS wiki article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    sztupi is offline New Member
    Join Date
    Aug 2012
    Posts
    4
    Rep Power
    3

    Default

    "Why have you titled this thread "....user backup failure""
    Sorry !
    "You should also check that all the services are running and if there's any errors in the log files."
    Every service is running :
    zmcontrol status
    Host mail.delmagyar.hu
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running
    zmconfigd Running

    Logs doesn't have errors

    zmlocalconfig |grep zmprov
    zimbra_zmprov_default_soap_server = mail.delmagyar.hu
    zimbra_zmprov_default_to_ldap = false


    " you post the output of all the commands from the 'Verify....' section of the Split DNS wiki article. "

    root@mail:~# dig mail.delmagyar.hu mx

    ; <<>> DiG 9.7.0-P1 <<>> mail.delmagyar.hu mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33069
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mail.delmagyar.hu. IN MX

    ;; AUTHORITY SECTION:
    delmagyar.hu. 43200 IN SOA pipin.delmagyar.hu. hostmaster.pipin.delmagyar.hu. 2012081401 3600 900 1209600 43200

    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.223#53(192.168.1.223)
    ;; WHEN: Fri Aug 24 11:48:48 2012
    ;; MSG SIZE rcvd: 88

    root@mail:~# dig mail.delmagyar.hu any

    ; <<>> DiG 9.7.0-P1 <<>> mail.delmagyar.hu any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34891
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;mail.delmagyar.hu. IN ANY

    ;; ANSWER SECTION:
    mail.delmagyar.hu. 259200 IN A 192.168.1.57

    ;; AUTHORITY SECTION:
    delmagyar.hu. 259200 IN NS pipin.delmagyar.hu.

    ;; ADDITIONAL SECTION:
    pipin.delmagyar.hu. 259200 IN A 192.168.1.223

    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.223#53(192.168.1.223)
    ;; WHEN: Fri Aug 24 11:48:53 2012
    ;; MSG SIZE rcvd: 87

    root@mail:~# hostname
    mail.delmagyar.hu

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    You haven't provided output from all of the commands, you're missing the resolv.conf and the hosts file - please provide it all it is actually useful. According to the information you have provided, there's no MX record for your server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    sztupi is offline New Member
    Join Date
    Aug 2012
    Posts
    4
    Rep Power
    3

    Default

    Code:
    root@mail:/etc# cat resolv.conf 
    search delmagyar.hu
    nameserver 192.168.1.223
    Code:
    root@mail:/etc# cat hosts
    127.0.0.1	localhost
    192.168.1.57	mail.delmagyar.hu	mail
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Your hosts file is incorrect, read the Split DNS article (or one of the many forum threads on this topic) for details of what's needed and fix your MX record.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    sztupi is offline New Member
    Join Date
    Aug 2012
    Posts
    4
    Rep Power
    3

    Default

    " there's no MX record for your server."
    I repaird it:

    ; <<>> DiG 9.7.0-P1 <<>> mail.delmagyar.hu mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50274
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;mail.delmagyar.hu. IN MX

    ;; ANSWER SECTION:
    mail.delmagyar.hu. 259200 IN MX 10 mail.delmagyar.hu.

    ;; AUTHORITY SECTION:
    mail.delmagyar.hu. 259200 IN NS pipin.mail.delmagyar.hu.

    ;; ADDITIONAL SECTION:
    mail.delmagyar.hu. 259200 IN A 192.168.1.223
    pipin.mail.delmagyar.hu. 259200 IN A 192.168.1.223

    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.223#53(192.168.1.223)
    ;; WHEN: Fri Aug 24 12:18:39 2012
    ;; MSG SIZE rcvd: 103

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra User Mailbox-Backup
    By kitcza in forum Administrators
    Replies: 5
    Last Post: 05-11-2011, 03:55 PM
  2. Risks of Hot backup and/or power failure in OSE
    By regan.wallace in forum Administrators
    Replies: 7
    Last Post: 02-19-2011, 05:38 AM
  3. Risks of Hot backup and/or power failure in OSE
    By regan.wallace in forum Installation
    Replies: 0
    Last Post: 02-17-2011, 07:08 AM
  4. FTP backup as zimbra user
    By rickvv in forum Administrators
    Replies: 0
    Last Post: 05-18-2010, 03:12 PM
  5. zimbra backup failure
    By chenthil in forum Administrators
    Replies: 3
    Last Post: 01-12-2007, 06:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •