Results 1 to 4 of 4

Thread: Missing audit.log file

  1. #1
    cjking is offline New Member
    Join Date
    Aug 2012
    Posts
    3
    Rep Power
    3

    Default Missing audit.log file

    Hi,
    I have Zimbra 7.2.0 running on Ubuntu 10.04.
    There is no /opt/zimbra/log/audit.log or mailbox.log file on my Zimbra installation. According to zmcontrol status, everything is running:
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    memcached Running
    mta Running
    snmp Running
    spell Running
    stats Running
    zmconfigd Running

    Can anyone offer any assistance with this?

    Thanks,
    Chris.

  2. #2
    cjking is offline New Member
    Join Date
    Aug 2012
    Posts
    3
    Rep Power
    3

    Default

    Still haven't solved this, but looking in zmmailboxd.out:

    log4j:WARN Failed to set property [rollingPolicy] to value "org.apache.log4j.rolling.TimeBasedRollingPoli cy".
    log4j:WARN Please set a rolling policy for the RollingFileAppender named 'MILTER'
    log4j:WARN Failed to set property [rollingPolicy] to value "org.apache.log4j.rolling.TimeBasedRollingPoli cy".
    log4j:WARN Please set a rolling policy for the RollingFileAppender named 'AUDIT'
    log4j:ERROR No output stream or file set for the appender named [LOGFILE].
    Total time for which application threads were stopped: 0.0002960 seconds
    4.015: [GC 4.015: [ParNew: 490752K->22361K(552064K), 0.0681330 secs] 490752K->22361K(2392192K), 0.0681870 secs] [Times: user=0.12 sys=0.00, real=0.07 secs]
    Total time for which application threads were stopped: 0.0691700 seconds
    Total time for which application threads were stopped: 0.0005250 seconds
    Total time for which application threads were stopped: 0.0000720 seconds
    Total time for which application threads were stopped: 0.0052590 seconds
    log4j:ERROR No output stream or file set for the appender named [AUDIT].

  3. #3
    cjking is offline New Member
    Join Date
    Aug 2012
    Posts
    3
    Rep Power
    3

    Default

    I figured it out - I'll leave this here incase anyone else runs into the same problem.
    There were leftover versions of lib4j libraries after an upgrade. I used find -name '*lib4j*' in /opt/zimbra to locate them.
    /opt/zimbra/lib/jars/log4j-1.2.15.jar
    /opt/zimbra/lib/jars/slf4j-log4j12-1.5.8.jar
    /opt/zimbra/jetty-6.1.22.z6/lib/log4j-1.2.15.jar

    After deleting those files and running zmmailboxdctl restart my audit.log and mailbox.log are back in action!

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by cjking View Post
    I figured it out - I'll leave this here incase anyone else runs into the same problem.
    Thanks for posting your solution, can you file a bug report and include what version was upgraded?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Missing useful File Management Tools
    By bhwong in forum Developers
    Replies: 2
    Last Post: 04-14-2010, 08:18 AM
  2. Missing useful File Management Tools
    By bhwong in forum Administrators
    Replies: 2
    Last Post: 04-14-2010, 08:18 AM
  3. Missing file zcs-5.0.6_GA_2314.UBUNTU8.diff
    By Neoryder in forum Developers
    Replies: 0
    Last Post: 07-20-2009, 04:55 PM
  4. zdesktop 0.53: missing file on import address book
    By hcimadomo in forum General Questions
    Replies: 1
    Last Post: 09-13-2007, 07:37 PM
  5. Missing blobs - from id to file location?
    By stateless in forum Administrators
    Replies: 1
    Last Post: 04-23-2007, 06:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •