Results 1 to 6 of 6

Thread: Gal sync test failed

  1. #1
    abhimanyu is offline Starter Member
    Join Date
    Jul 2012
    Posts
    1
    Rep Power
    3

    Post Gal sync test failed

    I am using zimbra 8.0 beta version , want to evaluate GAL functionality but on configuring it throws error.


    soap:Receiver
    system failure: LDAPSDKUsageException(message='A null object was provided where a non-null object is required (non-null index 0). Thread stack trace: getStackTrace(Thread.java:1567) / ensureNotNull(Validator.java:60) / encodeValue(Filter.java:3829) / encodeValue(UBIDLdapFilterFactory.java:258) / expandKey(GalUtil.java:109) / expandFilter(GalUtil.java:43) / expandFilter(GalUtil.java:28) / searchLdapGal(LdapGalSearch.java:76) / checkGalConfig(LdapProvisioning.java:4756) / handle(CheckGalConfig.java:60) / dispatchRequest(SoapEngine.java:422) / dispatch(SoapEngine.java:285) / dispatch(SoapEngine.java:158) / doWork(SoapServlet.java:290) / doPost(SoapServlet.java:206) / service(HttpServlet.java:727) / service(ZimbraServlet.java:208) / service(HttpServlet.java:820) / handle(ServletHolder.java:565) / doFilter(ServletHandler.java:1361) / doFilter(SetHeaderFilter.java:57) / doFilter(ServletHandler.java:1332) / doFilter(UserAgentFilter.java:77) / doFilter(GzipFilter.java:181) / doFilter(ServletHandler.java:1332) / doFilterChain(DoSFilter.java:464) / doFilter(DoSFilter.java:327) / doFilter(ServletHandler.java:1332) / doHandle(ServletHandler.java:477) / handle(ScopedHandler.java:119) / handle(SecurityHandler.java:524) / doHandle(SessionHandler.java:227) / doHandle(ContextHandler.java:1031) / doScope(ServletHandler.java:406) / doScope(SessionHandler.java:186) / doScope(ContextHandler.java:965) / handle(ScopedHandler.java:117) / handle(ContextHandlerCollection.java:250) / handle(HandlerCollection.java:149) / handle(HandlerWrapper.java:111) / handle(RewriteHandler.java:312) / handle(DebugHandler.java:77) / handle(HandlerWrapper.java:111) / handle(Server.java:349) / handleRequest(AbstractHttpConnection.java:452) / content(AbstractHttpConnection.java:894) / content(AbstractHttpConnection.java:948) / parseNext(HttpParser.java:857) / parseAvailable(HttpParser.java:235) / handle(AsyncHttpConnection.java:77) / handle(SslConnection.java:191) / handle(SelectChannelEndPoint.java:609) / run(SelectChannelEndPoint.java:45) / runJob(QueuedThreadPool.java:599) / run(QueuedThreadPool.java:534) / run(Thread.java:722)')



    Can anyone comment on this .

  2. #2
    pup_seba is offline Special Member
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    3

    Default Same error

    Hi,

    I'm having the exact same error. Also, the links in the UI of the Zimbra Administration Console for the migration wizards are not working properly.

    Did you find the solution for this Sync. problem?

    Thanks!
    Sebastián G.

  3. #3
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Quote Originally Posted by pup_seba View Post
    I'm having the exact same error
    What are the exact steps to reproduce this behaviour?


    Quote Originally Posted by pup_seba View Post
    Also, the links in the UI of the Zimbra Administration Console for the migration wizards are not working properly.
    They all work for me so what,exactly, does "not working properly" mean? Start a new thread on this topic.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    pup_seba is offline Special Member
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    3

    Default

    Hi Bill,

    Quote Originally Posted by phoenix View Post
    What are the exact steps to reproduce this behaviour?

    That particular error happened while trying to test the sincronization while configuring GAL Sync in the domain. This is not showing since I upgraded to version 8 GA. Now, even when GAL sync tests are "ok", I just can't see the info in the GAL while trying to look for it. No error displayed, only no information showing.

    I have two domains.
    1) essi.lab - Exists only in Zimbra LDAP
    2) sebas.lab - Is the Active Directory LDAP

    If I log in with an essi.lab account (zimbra LDAP), I can only see contacts from essi.lab
    If I log in with a sebas.lab account (AD LDAP), I can only see the accounts for sebas.lab that I manually created in my Zimbra server. The info from the LDAP like "Address", "phone number", etc is not updated.

    Update Interval is set to 1 minuto for internal/external LDAPs.

    Screenshot from 2012-09-17 13:00:25.jpg

    Screenshot from 2012-09-17 13:02:13.png

    Screenshot from 2012-09-17 13:03:45.png

    Screenshot from 2012-09-17 13:04:35.png

    Screenshot from 2012-09-17 13:44:31.png


    They all work for me so what,exactly, does "not working properly" mean? Start a new thread on this topic.
    They work now for me too, only after upgrading to 8 GA from Beta. Most of the links were "broken" and the tools were missing to migrate from Exchange.


    Thanks!

  5. #5
    pup_seba is offline Special Member
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    3

    Default

    cat /opt/zimbra/log/mailbox.log |grep gal shows the following

    2012-09-17 13:59:01,034 INFO [ScheduledTask-5] [name=galsync@sebas.lab;mid=7;ds=zimbra;] datasource - Requested import.
    2012-09-17 13:59:01,034 INFO [ScheduledTask-5] [name=galsync@sebas.lab;mid=7;ds=zimbra;] datasource - Importing data for data source 'zimbra'
    2012-09-17 13:59:01,037 WARN [ScheduledTask-5] [name=galsync@sebas.lab;mid=7;ds=zimbra;] ldap - unknown GAL op
    2012-09-17 13:59:01,048 INFO [ScheduledTask-5] [name=galsync@sebas.lab;mid=7;ds=zimbra;] datasource - Import completed for data source 'zimbra'
    2012-09-17 13:59:02,862 INFO [ScheduledTask-8] [name=galsync@essi.lab;mid=1;ds=InternalGAL;] datasource - Requested import.
    2012-09-17 13:59:02,863 INFO [ScheduledTask-8] [name=galsync@essi.lab;mid=1;ds=InternalGAL;] datasource - Importing data for data source 'InternalGAL'
    2012-09-17 13:59:02,868 WARN [ScheduledTask-8] [name=galsync@essi.lab;mid=1;ds=InternalGAL;] ldap - unknown GAL op
    2012-09-17 13:59:02,878 INFO [ScheduledTask-8] [name=galsync@essi.lab;mid=1;ds=InternalGAL;] datasource - Import completed for data source 'InternalGAL'

  6. #6
    adamhatak is offline Active Member
    Join Date
    Jan 2011
    Location
    Poland
    Posts
    27
    Rep Power
    4

    Default

    Hi,

    I have same issue (ldap - unknown GAL op) with internal GAL (zimbra) after upgrading to Zimbra 8.0.2 FOSS - did you found any solution for that?

    Regards,

    Adam.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 09-16-2008, 04:20 PM
  2. Replies: 5
    Last Post: 05-22-2008, 08:13 AM
  3. GAL search Test Failed
    By snixon in forum Installation
    Replies: 4
    Last Post: 03-31-2008, 03:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •