Results 1 to 4 of 4

Thread: Certificate Issue

  1. #1
    glennbtn is offline Loyal Member
    Join Date
    Dec 2009
    Location
    Worthing. UK
    Posts
    97
    Rep Power
    5

    Default Certificate Issue

    Hi All

    I decied to buy a certificate for my Zimbra 7.2.0. Went through the gui and created the csr. Bought the certificate and got 4 files
    AddTrustExternalCARoot.crt
    UTNAddTrustServerCA.crt
    OptimumSSLCA.crt
    mail_mydomain_co_uk.crt

    I uploaded the cert and the rootca but get the following error

    Message: invalid request: missing required attribute: server Error code: service.INVALID_REQUEST Method: [unknown] Details:soap:Sender

    Can anyone advise

    Thanks

  2. #2
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,373
    Rep Power
    10

    Default

    If you combine the root cert and the two CA certs in the correct order to preserve the chain of trust, then in the Admin Console you need only provide your combined "root" cert and the server cert.

    To put all the certs except your server cert together into one:

    Code:
          cat AddTrustExternalCARoot.crt OptimumSSLCA.crt UTNAddTrustServer_CA.crt >> commercial_ca.crt
    Please try and keep us posted!
    Mark

  3. #3
    glennbtn is offline Loyal Member
    Join Date
    Dec 2009
    Location
    Worthing. UK
    Posts
    97
    Rep Power
    5

    Default

    Well that's just fantastic. Would never have worked that out. Thought you just had to upload the certificates like you would in exchange.

    Thanks very much

    Glenn

  4. #4
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,373
    Rep Power
    10

    Default

    Quote Originally Posted by glennbtn View Post
    Well that's just fantastic. Would never have worked that out. Thought you just had to upload the certificates like you would in exchange.

    Thanks very much

    Glenn
    You are welcome; glad it worked. To be fair, you could indeed have uploaded each of the certs individually, but they would have had to be in the exact proper order to preserve the chain of trust. There are several previous posts and a few wiki articles that used the "cat" method I gave you to work around previous shortcomings in earlier versions of the Admin Console.

    All the best,
    Mark

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Issue creating Self-Signed Certificate
    By jtran in forum Administrators
    Replies: 7
    Last Post: 04-22-2013, 11:38 PM
  2. Zimbra SSL Certificate Issue
    By kumabhi in forum Administrators
    Replies: 6
    Last Post: 11-22-2010, 11:51 AM
  3. Zimbra SSL Certificate Issue
    By kumabhi in forum Users
    Replies: 1
    Last Post: 10-15-2010, 06:00 AM
  4. Certificate installation Wizard issue
    By lpe397 in forum Installation
    Replies: 3
    Last Post: 06-13-2010, 07:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •