Hi Forums Crowd,

We've got a weird situation happening with some messages bouncing back on the way out the door:

Code:
This is the Postfix program at host mail.tombridge.net. [our server]


I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.


For further assistance, please send mail to <postmaster>


If you do so, please include this problem report. You can
delete your own text from the attached returned message.


   The Postfix program


<[ mailto:rmooney@kensingtoncaterers.com ]rmooney@kensingtoncaterers.com>: host kensingtoncaterers.com[72.29.83.49]
* * said: 550-Verification failed for <[ mailto:vargo@us-irelandalliance.org ]vargo@us-irelandalliance.org>
* * 550-unrouteable mail domain "us-irelandalliance.org" 550 Sender verify
* * failed (in reply to RCPT TO command)
Reporting-MTA: dns; mail.tombridge.net
X-Postfix-Queue-ID: 0B41E107923
X-Postfix-Sender: rfc822; [ mailto:vargo@us-irelandalliance.org ]vargo@us-irelandalliance.org
Arrival-Date: Mon,* 4 Dec 2006 17:29:06 -0500 (EST)


Final-Recipient: rfc822; [ mailto:rmooney@kensingtoncaterers.com ]rmooney@kensingtoncaterers.com
Action: failed
Status: 5.0.0
Diagnostic-Code: X-Postfix; host kensingtoncaterers.com[72.29.83.49] said:
* * 550-Verification failed for <[ mailto:vargo@us-irelandalliance.org ]vargo@us-irelandalliance.org> 550-unrouteable
* * mail domain "us-irelandalliance.org" 550 Sender verify failed (in reply to
* * RCPT TO command)
I'm fairly sure our DNS is proper:

Code:
tom-bridges-computer:~ tom$ dig us-irelandalliance.org mx

; <<>> DiG 9.3.2 <<>> us-irelandalliance.org mx
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26929
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;us-irelandalliance.org.                IN      MX

;; ANSWER SECTION:
us-irelandalliance.org. 2725    IN      MX      20 206.27.17.67.

;; AUTHORITY SECTION:
us-irelandalliance.org. 2725    IN      NS      ns4.secureserver.net.
us-irelandalliance.org. 2725    IN      NS      ns3.secureserver.net.

;; ADDITIONAL SECTION:
ns3.secureserver.net.   42063   IN      A       64.202.165.10
ns4.secureserver.net.   2946    IN      A       68.178.211.105

;; Query time: 95 msec
;; SERVER: 64.69.73.4#53(64.69.73.4)
;; WHEN: Mon Dec  4 17:48:20 2006
;; MSG SIZE  rcvd: 152
Is this a Reverse DNS issue? Or is this something in Zimbra that's not working properly?