Results 1 to 5 of 5

Thread: Webmail errors - Some basic actions do not work, crash with send report error

  1. #1
    pmabox is offline Junior Member
    Join Date
    Jun 2012
    Posts
    6
    Rep Power
    3

    Exclamation Webmail errors - Some basic actions do not work, crash with send report error

    We are testing zimbra for the first time, 7.02 community version in ubuntu 10.04 64x.
    Unfortunately basic actions like sending emails or sharing folder crash the web client and send report error appears.
    The most important basic action crashing is Send Email

    The user after writing the email presses the send button and:
    Zimbra
    An unknown error (mail.TRY_AGAIN) has occurred.

    Code:
    method:	[unknown]
    msg:	try again: Unable to connect to the MTA
    code:	mail.TRY_AGAIN
    detail:	soap:Receiver
    trace:	btpool0-205://mail.replaced.com:8089/service/soap/SendMsgRequest:1340978905569:becb208cbf13dd0e
    request:	
    Body: {
      SendMsgRequest: {
        _jsns: "urn:zimbraMail",
        m: {
          e: [
            0: {
              a: "webmaster@replaced.com",
              add: "1",
              t: "t"
             },
            1: {
              a: "info@replaced.com",
              p: "Info replaced",
              t: "f"
             }
           ],
          idnt: "b776f19a-d380-4010-a65e-522da6c76105",
          mp: [
            0: {
              content: {
                _content: "teste"
               },
              ct: "text/plain"
             }
           ],
          su: {
            _content: "teste"
           }
         },
        suid: 1340978882928
       }
     },
    Header: {
      context: {
        _jsns: "urn:zimbra",
        account: {
          _content: "info@replaced.com",
          by: "name"
         },
        authToken: "(removed)",
        session: {
          _content: 1731,
          id: 1731
         },
        userAgent: {
          name: "ZimbraWebClient - GC18 (Linux)",
          version: "7.2.0_GA_2669"
         }
       }
     }
    Anyone with these issues.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,482
    Rep Power
    56

    Default

    Quote Originally Posted by pmabox View Post
    We are testing zimbra for the first time, 7.02 community version in ubuntu 10.04 64x.
    Unfortunately basic actions like sending emails or sharing folder crash the web client and send report error appears.
    The most important basic action crashing is Send Email
    There's no problem with sending email or the Web UI and the likelihood is that you don't have enough RAM on your server, search the forums for further details.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    pmabox is offline Junior Member
    Join Date
    Jun 2012
    Posts
    6
    Rep Power
    3

    Default

    Thanks Bill,

    Was reading 5 or 10 posts about this soap:receiver error yesterday (seems abundant), but did not find anything about ram, and I thought that for testing I had it covered:
    Evaluation and Testing
    • Intel/AMD 32-bit or 64-bit CPU 1.5 GHz
    • 1 GB RAM

    This server is old with 1,5gb of ram and starting to use swap
    Would get a new one if 12.04 was supported

    free -m
    total used free shared buffers cached
    Mem: 1438 1301 136 0 8 119
    -/+ buffers/cache: 1173 264
    Swap: 4211 652 3559

    Please mark as solved.

  4. #4
    pmabox is offline Junior Member
    Join Date
    Jun 2012
    Posts
    6
    Rep Power
    3

    Default

    Upgraded memory to 3gb and still having the same error:
    tested the webclient in different browsers and operating systems, same error.
    will dig into the logs to tonight and try to catch more details about the error.

    method: [unknown]
    msg: try again: Unable to connect to the MTA
    code: mail.TRY_AGAIN
    detail: soap:Receiver
    trace: btpool0-11://mail.replaced.com:9443/service/soap/SendMsgRequest:1341320487619:c88a2665004cc800
    request:
    Body: {
    SendMsgRequest: {
    _jsns: "urn:zimbraMail",
    m: {
    e: [
    0: {
    a: "info@replaced.com",
    add: "1",
    t: "t"
    },
    1: {
    a: "webmaster@replaced.com",
    p: "Webmaster",
    t: "f"
    }
    ],
    idnt: "763c919a-ba4e-49b6-9bd5-792893bb166e",
    mp: [
    0: {
    content: {
    _content: "teste"
    },
    ct: "text/plain"
    }
    ],
    su: {
    _content: "teste"
    }
    },
    suid: 1341320483650
    }
    },
    Header: {
    context: {
    _jsns: "urn:zimbra",
    account: {
    _content: "webmaster@replaced.com",
    by: "name"
    },
    authToken: "(removed)",
    notify: {
    seq: 3
    },
    session: {
    _content: 12,
    id: 12
    },
    userAgent: {
    name: "ZimbraWebClient - GC20 (Win)",
    version: "7.2.0_GA_2669"
    }
    }
    }

  5. #5
    pmabox is offline Junior Member
    Join Date
    Jun 2012
    Posts
    6
    Rep Power
    3

    Default

    Checking the zimbra logs... mailbox.log:
    Code:mail.TRY_AGAIN
    at com.zimbra.cs.mailbox.MailServiceException.TRY_AGA IN(MailServiceException.java:479)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:628)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:425)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:385)
    at com.zimbra.cs.service.mail.SendMsg.doSendMessage(S endMsg.java:193)
    at com.zimbra.cs.service.mail.SendMsg.handle(SendMsg. java:154)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:412)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:287)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:158)
    at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:303)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:217)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:725)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:206)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:814)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:511)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1166)
    at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(Set HeaderFilter.java:79)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1157)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1157)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:388)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:218)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:182)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:765)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:422)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:230)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:230)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.DebugHandler.handle(Debu gHandler.java:77)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.Server.handle(Server.java:326)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:585)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:988)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:756)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:218)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:415)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:429)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:451)
    Caused by: java.net.ConnectException: Connection refused
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl .java:351)
    at java.net.PlainSocketImpl.connectToAddress(PlainSoc ketImpl.java:213)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.j ava:200)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.j ava:366)
    at java.net.Socket.connect(Socket.java:529)
    at com.zimbra.cs.mailclient.MailConnection.newSocket( MailConnection.java:419)
    at com.zimbra.cs.mailclient.MailConnection.connect(Ma ilConnection.java:74)
    at com.zimbra.cs.mailclient.smtp.SmtpTransport.protoc olConnect(SmtpTransport.java:181)
    at javax.mail.Service.connect(Service.java:295)
    at javax.mail.Service.connect(Service.java:176)
    at javax.mail.Service.connect(Service.java:125)
    at com.zimbra.cs.mailbox.MailSender.sendMessageToHost (MailSender.java:898)
    at com.zimbra.cs.mailbox.MailSender.sendMessage(MailS ender.java:831)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:565)
    ... 39 more
    Seems to be an issue with the line I marked bold. Same error occurs repeatedly when the web-client tries to autos-save the message.
    Any ideas Bill? or anyone else?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Webmail crash
    By kane1388 in forum General Questions
    Replies: 0
    Last Post: 09-29-2009, 07:40 AM
  2. Webmail crash
    By kane1388 in forum Error Reports
    Replies: 0
    Last Post: 09-29-2009, 07:40 AM
  3. Webmail error when send email
    By imerius in forum Users
    Replies: 5
    Last Post: 07-07-2009, 08:38 AM
  4. Webmail error when send email
    By imerius in forum Installation
    Replies: 0
    Last Post: 07-06-2009, 11:58 AM
  5. Webmail in format BASIC does not start!
    By olibite in forum Administrators
    Replies: 2
    Last Post: 09-04-2007, 07:06 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •