Results 1 to 7 of 7

Thread: Zimlet-network Cluster

  1. #1
    jose.portillo is offline Intermediate Member
    Join Date
    Dec 2011
    Posts
    22
    Rep Power
    3

    Unhappy Zimlet-network Cluster

    Hello greetings to all.

    I write because my support portal is not available for several days is failing and the zimbra support is unresponsive.

    Recently, I made a serious mistake, I had to make my whole installation from scratch and do a restoration of all my mailboxes, but at the end, I realized that my zimbra looked like an Open Source version.

    I realized I had to install some Zimlets despleguar e-network located at: / opt / zimbra / Zimlets-network / com_zimbra_cluster.zip.

    After making this deployment began my problems. One is, I can not access the server status window is shown completely empty and this is the message I get.

    ComedicaGetClusterStatusRequest.png



    still can not find someone with this problem, but I hope I can help, by the time I tried to make a undeploy but this is the message I have.

    zmzimletctl undeploy com_zimbra_cluster.zip
    [] INFO: Undeploying on mail.zimbrangt.net
    [] INFO: Undeploy initiated. (check the servers mailbox.log for the status)

    tail -f /opt/zimbra/log/mailbox.log

    2012-06-13 13:55:05,288 INFO [btpool0-7://localhost:7071/service/admin/soap/AuthRequest] [ip=127.0.0.1;ua=zmzimletctl/7.2.0_GA_2669;] soap - AuthRequest
    2012-06-13 13:55:05,374 INFO [btpool0-7://localhost:7071/service/admin/soap/GetAllServersRequest] [name=zimbra;ip=127.0.0.1;ua=zmzimletctl/7.2.0_GA_2669;] soap - GetAllServersRequest
    2012-06-13 13:55:06,121 INFO [btpool0-7://172.16.16.84:7071/service/admin/soap/NoOpRequest] [name=admin@zimbrangt.net;mid=2;ip=172.16.16.80;ua= ZimbraWebClient - IE7 (Win);] soap - NoOpRequest
    2012-06-13 13:55:06,660 INFO [btpool0-7://mail.zimbrangt.net:7071/service/admin/soap/AuthRequest] [ip=172.16.16.84;ua=zmzimletctl/7.2.0_GA_2669;] soap - AuthRequest
    2012-06-13 13:55:06,731 INFO [btpool0-7://mail.zimbrangt.net:7071/service/admin/soap/UndeployZimletRequest] [name=zimbra;ip=172.16.16.84;ua=zmzimletctl/7.2.0_GA_2669;] soap - UndeployZimletRequest
    2012-06-13 13:55:06,798 INFO [Thread-258] [] zimlet - Uninstalling Zimlet com_zimbra_cluster.zip from LDAP.
    2012-06-13 13:55:06,848 INFO [Thread-258] [] zimlet - Removing Zimlet com_zimbra_cluster.zip from COS default
    2012-06-13 13:55:06,947 WARN [Thread-258] [] zimlet - Error deactiving Zimlet com_zimbra_cluster.zip in LDAP.
    com.zimbra.cs.account.AccountServiceException: no such zimlet: com_zimbra_cluster.zip
    ExceptionId:Thread-258:1339617306947:b6910379cc24f3ad
    Code:account.NO_SUCH_ZIMLET
    at com.zimbra.cs.account.AccountServiceException.NO_S UCH_ZIMLET(AccountServiceException.java:231)
    at com.zimbra.cs.zimlet.ZimletUtil.getZimletConfig(Zi mletUtil.java:271)
    at com.zimbra.cs.zimlet.ZimletUtil.deactivateZimlet(Z imletUtil.java:803)
    at com.zimbra.cs.zimlet.ZimletUtil.uninstallZimlet(Zi mletUtil.java:735)
    at com.zimbra.cs.service.admin.UndeployZimlet$Undeplo yThread.run(UndeployZimlet.java:43)
    at java.lang.Thread.run(Thread.java:662)
    2012-06-13 13:55:06,947 INFO [Thread-258] [] zimlet - Removing Zimlet com_zimbra_cluster.zip from COS demo
    2012-06-13 13:55:07,330 WARN [Thread-258] [] zimlet - Error deactiving Zimlet com_zimbra_cluster.zip in LDAP.
    com.zimbra.cs.account.AccountServiceException: no such zimlet: com_zimbra_cluster.zip
    ExceptionId:Thread-258:1339617307330:b6910379cc24f3ad
    Code:account.NO_SUCH_ZIMLET
    at com.zimbra.cs.account.AccountServiceException.NO_S UCH_ZIMLET(AccountServiceException.java:231)
    at com.zimbra.cs.zimlet.ZimletUtil.getZimletConfig(Zi mletUtil.java:271)
    at com.zimbra.cs.zimlet.ZimletUtil.deactivateZimlet(Z imletUtil.java:803)
    at com.zimbra.cs.zimlet.ZimletUtil.uninstallZimlet(Zi mletUtil.java:735)
    at com.zimbra.cs.service.admin.UndeployZimlet$Undeplo yThread.run(UndeployZimlet.java:43)
    at java.lang.Thread.run(Thread.java:662)
    2012-06-13 13:55:07,331 INFO [Thread-258] [] zimlet - Removing Zimlet com_zimbra_cluster.zip from COS gerentes
    2012-06-13 13:55:07,480 WARN [Thread-258] [] zimlet - Error deactiving Zimlet com_zimbra_cluster.zip in LDAP.
    com.zimbra.cs.account.AccountServiceException: no such zimlet: com_zimbra_cluster.zip
    ExceptionId:Thread-258:1339617307480:b6910379cc24f3ad
    Code:account.NO_SUCH_ZIMLET
    at com.zimbra.cs.account.AccountServiceException.NO_S UCH_ZIMLET(AccountServiceException.java:231)
    at com.zimbra.cs.zimlet.ZimletUtil.getZimletConfig(Zi mletUtil.java:271)
    at com.zimbra.cs.zimlet.ZimletUtil.deactivateZimlet(Z imletUtil.java:803)
    at com.zimbra.cs.zimlet.ZimletUtil.uninstallZimlet(Zi mletUtil.java:735)
    at com.zimbra.cs.service.admin.UndeployZimlet$Undeplo yThread.run(UndeployZimlet.java:43)
    at java.lang.Thread.run(Thread.java:662)

    Not to do.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by jose.portillo View Post
    I write because my support portal is not available for several days is failing and the zimbra support is unresponsive.
    What do you mean by the 'support portal is not available'?

    Quote Originally Posted by jose.portillo View Post
    Recently, I made a serious mistake, I had to make my whole installation from scratch and do a restoration of all my mailboxes, but at the end, I realized that my zimbra looked like an Open Source version.
    What 'mistake' did you make? Why did you have to install ZCS from scratch?

    Quote Originally Posted by jose.portillo View Post
    I realized I had to install some Zimlets despleguar e-network located at: / opt / zimbra / Zimlets-network / com_zimbra_cluster.zip.
    Is ZCS installed on a cluster?

    You should update your forum profile with the output of the following command (do not post the output in this thread):

    Code:
    zmcontrol -v
    You also need to give a description of your configuration (single server, multi-server, cluster etc) and what exactly caused this problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    jose.portillo is offline Intermediate Member
    Join Date
    Dec 2011
    Posts
    22
    Rep Power
    3

    Default

    Quote Originally Posted by phoenix View Post
    What do you mean by the 'support portal is not available'?
    Thanks for the prompt response.
    Ok I can I access my portal https://support.zimbra.com/.
    But inside I can not manage my cases, when I enter this section espesificamente my computer can spend a full week of this section and never show the target de manage the case, therefore I can not place cases.


    Quote Originally Posted by phoenix View Post
    What 'mistake' did you make? Why did you have to install ZCS from scratch?
    I had to install from scratch my ZCS because I did an upgrade from version 7.1.3 to version 7.2.

    But this failure and lost everything, so I have reinstall ZCS from scratch and then restore a backup, but I leave my Zimbra as an Open Source version so I had to deploy some Zimlets and deploy the zimlet cluster and I hurt my server .


    I Deploy a Zimlet that I should never have touched, I deploy opt / zimbra / Zimlets-network/com_zimbra_cluster.zip.

    But I not have a cluster, my server is unique.



    Quote Originally Posted by phoenix View Post
    Is ZCS installed on a cluster?
    I do not want a cluster, this is my error now understand that the server is waiting for a team to form the cluster but that can not be because I do not want to implement a cluster. I tried doing a Zimlet undeploy but can not be removed by the logs showed you above.


    Quote Originally Posted by phoenix View Post
    You should update your forum profile with the output of the following command (do not post the output in this thread):
    Sorry I meant not understend.
    sorry if I update this case the form incorrectly


    Code:
    zmcontrol -v
    zimbra@mail:~$ zmcontrol -v
    Release 7.2.0_GA_2669.UBUNTU10_64 UBUNTU10_64 NETWORK edition.


    Quote Originally Posted by phoenix View Post
    You also need to give a description of your configuration (single server, multi-server, cluster etc) and what exactly caused this problem.
    My server is a single, as I mentioned earlier I do not want a cluster
    I to remove it so I have to follow my ZCS server working as a single server.

    You think this can be resolved

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Are the Zimbra services running? What's the output of the following command (run as the Zimbra user):

    zmcontrol status
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    jose.portillo is offline Intermediate Member
    Join Date
    Dec 2011
    Posts
    22
    Rep Power
    3

    Default

    Yes, all my services are running, but some screens within the web administration can not see them well because I has some pictures of error.
    This is the output of zmcontrol status.

    zimbra@mail:~$ zmcontrol status
    Host xxx.xxxxxxx.xxx (sorry for not presenting this information).
    antispam--------------Running
    antivirus--------------Running
    ldap-------------------Running
    logger-----------------Running
    mailbox----------------Running
    mta-------------------Running
    snmp------------------Running
    spell-------------------Running
    stats------------------Running
    zmconfigd--------------Running
    zimbra@mail:~$
    Last edited by jose.portillo; 06-14-2012 at 08:55 AM.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Have you tried manually to undeploy the offending Zimlet(s) and restart the server? Does that improve the situation?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    jose.portillo is offline Intermediate Member
    Join Date
    Dec 2011
    Posts
    22
    Rep Power
    3

    Default

    Yes, I tried to manually perform the undeploy but it only initializes the process.
    This is the command I use.

    zimbra@mail:~/zimlets-network$ pwd
    /opt/zimbra/zimlets-network
    zimbra@mail:~/zimlets-network$ zmzimletctl undeploy com_zimbra_cluster.zip
    [] INFO: Undeploying on mail.zimbrangt.net
    [] INFO: Undeploy initiated. (check the servers mailbox.log for the status)
    zimbra@mail:~/zimlets-network$

    to check the Mailbox.log this is what I observe.

    2012-06-13 13:55:05,288 INFO [btpool0-7://localhost:7071/service/admin/soap/AuthRequest] [ip=127.0.0.1;ua=zmzimletctl/7.2.0_GA_2669;] soap - AuthRequest
    2012-06-13 13:55:05,374 INFO [btpool0-7://localhost:7071/service/admin/soap/GetAllServersRequest] [name=zimbra;ip=127.0.0.1;ua=zmzimletctl/7.2.0_GA_2669;] soap - GetAllServersRequest
    2012-06-13 13:55:06,121 INFO [btpool0-7://172.16.16.84:7071/service/admin/soap/NoOpRequest] [name=admin@zimbrangt.net;mid=2;ip=172.16.16.80;ua= ZimbraWebClient - IE7 (Win);] soap - NoOpRequest
    2012-06-13 13:55:06,660 INFO [btpool0-7://mail.zimbrangt.net:7071/service/admin/soap/AuthRequest] [ip=172.16.16.84;ua=zmzimletctl/7.2.0_GA_2669;] soap - AuthRequest
    2012-06-13 13:55:06,731 INFO [btpool0-7://mail.zimbrangt.net:7071/service/admin/soap/UndeployZimletRequest] [name=zimbra;ip=172.16.16.84;ua=zmzimletctl/7.2.0_GA_2669;] soap - UndeployZimletRequest
    2012-06-13 13:55:06,798 INFO [Thread-258] [] zimlet - Uninstalling Zimlet com_zimbra_cluster.zip from LDAP.
    2012-06-13 13:55:06,848 INFO [Thread-258] [] zimlet - Removing Zimlet com_zimbra_cluster.zip from COS default
    2012-06-13 13:55:06,947 WARN [Thread-258] [] zimlet - Error deactiving Zimlet com_zimbra_cluster.zip in LDAP.
    com.zimbra.cs.account.AccountServiceException: no such zimlet: com_zimbra_cluster.zip
    ExceptionId:Thread-258:1339617306947:b6910379cc24f3ad
    Code:account.NO_SUCH_ZIMLET
    at com.zimbra.cs.account.AccountServiceException.NO_S UCH_ZIMLET(AccountServiceException.java:231)
    at com.zimbra.cs.zimlet.ZimletUtil.getZimletConfig(Zi mletUtil.java:271)
    at com.zimbra.cs.zimlet.ZimletUtil.deactivateZimlet(Z imletUtil.java:803)
    at com.zimbra.cs.zimlet.ZimletUtil.uninstallZimlet(Zi mletUtil.java:735)
    at com.zimbra.cs.service.admin.UndeployZimlet$Undeplo yThread.run(UndeployZimlet.java:43)
    at java.lang.Thread.run(Thread.java:662)
    2012-06-13 13:55:06,947 INFO [Thread-258] [] zimlet - Removing Zimlet com_zimbra_cluster.zip from COS demo
    2012-06-13 13:55:07,330 WARN [Thread-258] [] zimlet - Error deactiving Zimlet com_zimbra_cluster.zip in LDAP.
    com.zimbra.cs.account.AccountServiceException: no such zimlet: com_zimbra_cluster.zip
    ExceptionId:Thread-258:1339617307330:b6910379cc24f3ad
    Code:account.NO_SUCH_ZIMLET
    at com.zimbra.cs.account.AccountServiceException.NO_S UCH_ZIMLET(AccountServiceException.java:231)
    at com.zimbra.cs.zimlet.ZimletUtil.getZimletConfig(Zi mletUtil.java:271)
    at com.zimbra.cs.zimlet.ZimletUtil.deactivateZimlet(Z imletUtil.java:803)
    at com.zimbra.cs.zimlet.ZimletUtil.uninstallZimlet(Zi mletUtil.java:735)
    at com.zimbra.cs.service.admin.UndeployZimlet$Undeplo yThread.run(UndeployZimlet.java:43)
    at java.lang.Thread.run(Thread.java:662)
    2012-06-13 13:55:07,331 INFO [Thread-258] [] zimlet - Removing Zimlet com_zimbra_cluster.zip from COS gerentes
    2012-06-13 13:55:07,480 WARN [Thread-258] [] zimlet - Error deactiving Zimlet com_zimbra_cluster.zip in LDAP.
    com.zimbra.cs.account.AccountServiceException: no such zimlet: com_zimbra_cluster.zip
    ExceptionId:Thread-258:1339617307480:b6910379cc24f3ad
    Code:account.NO_SUCH_ZIMLET
    at com.zimbra.cs.account.AccountServiceException.NO_S UCH_ZIMLET(AccountServiceException.java:231)
    at com.zimbra.cs.zimlet.ZimletUtil.getZimletConfig(Zi mletUtil.java:271)
    at com.zimbra.cs.zimlet.ZimletUtil.deactivateZimlet(Z imletUtil.java:803)
    at com.zimbra.cs.zimlet.ZimletUtil.uninstallZimlet(Zi mletUtil.java:735)
    at com.zimbra.cs.service.admin.UndeployZimlet$Undeplo yThread.run(UndeployZimlet.java:43)
    at java.lang.Thread.run(Thread.java:662)

    I have to have my healthy server for these reasons:
    1) Should I upgrade to version 7.2
    2) should I install digital certificates.
    3) verify that my connectors are properly work.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimlet-network Cluster
    By jose.portillo in forum Zimlets
    Replies: 0
    Last Post: 06-13-2012, 12:57 PM
  2. Replies: 6
    Last Post: 07-18-2010, 10:31 PM
  3. Replies: 6
    Last Post: 05-13-2010, 08:45 AM
  4. Replies: 0
    Last Post: 10-16-2008, 02:19 AM
  5. Cluster incorrectly upgraded with non-cluster install.sh
    By Rich Graves in forum Administrators
    Replies: 1
    Last Post: 07-13-2007, 03:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •