Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Unable to send email

  1. #1
    kevjersey147 is offline Banned
    Join Date
    Apr 2012
    Posts
    9
    Rep Power
    0

    Default Unable to send email

    Hi,

    I've just built a zimbra server on ubuntu 10.04, the installation was tricky but managed to get into the web interface.

    However when I try to send emails I get the following message;

    Code:
    system failure: Unable to send message
    
    trace:	com.zimbra.common.service.ServiceException: system failure: Unable to send message ExceptionId:btpool0-9://kevinsproject.sytes.net/service/soap/SendMsgRequest:1336492034621:8c96fab87af337ed Code:service.FAILURE at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:248) at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(MailSender.java:630) at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(MailSender.java:425) at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(MailSender.java:385) at com.zimbra.cs.service.mail.SendMsg.doSendMessage(SendMsg.java:193) at com.zimbra.cs.service.mail.SendMsg.handle(SendMsg.java:154) at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:412) at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:287) at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:158) at com.zimbra.soap.SoapServlet.doWork(SoapServlet.java:294) at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:215) at javax.servlet.http.HttpServlet.service(HttpServlet.java:725) at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:208) at javax.servlet.http.HttpServlet.service(HttpServlet.java:814) at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511) at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1166) at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(SetHeaderFilter.java:79) at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157) at org.mortbay.servlet.UserAgentFilter.doFilter(UserAgentFilter.java:81) at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter.java:132) at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157) at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:388) at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:218) at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182) at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:765) at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:422) at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230) at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114) at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152) at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle(RewriteHandler.java:230) at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152) at org.mortbay.jetty.handler.DebugHandler.handle(DebugHandler.java:77) at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152) at org.mortbay.jetty.Server.handle(Server.java:326) at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:543) at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:946) at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:756) at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:218) at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:405) at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:410) at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:451) Caused by: com.zimbra.cs.mailbox.MailSender$SafeMessagingException: Did not receive greeting from server; chained exception is: com.zimbra.cs.mailclient.MailException: Did not receive greeting from server at com.zimbra.cs.mailclient.smtp.SmtpTransport.protocolConnect(SmtpTransport.java:182) at javax.mail.Service.connect(Service.java:291) at javax.mail.Service.connect(Service.java:172) at javax.mail.Service.connect(Service.java:121) at com.zimbra.cs.mailbox.MailSender.sendMessageToHost(MailSender.java:898) at com.zimbra.cs.mailbox.MailSender.sendMessage(MailSender.java:831) at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(MailSender.java:565) ... 39 more
    request:	
    Body: {
      SendMsgRequest: {
        _jsns: "urn:zimbraMail",
        m: {
          e: [
            0: {
              a: "test@gmail.com",
              add: "1",
              t: "t"
             },
            1: {
              a: "admin@kevinsproject.sytes.net",
              t: "f"
             }
           ],
          idnt: "5e56d71a-59e1-4abb-b5e6-0ab4d70555b8",
          mp: [
            0: {
              content: {
                _content: "jfj"
               },
              ct: "text/plain"
             }
           ],
          su: {
            _content: "jfj"
           }
         },
        suid: 1336492035112
       }
     },
    Header: {
      context: {
        _jsns: "urn:zimbra",
        account: {
          _content: "admin@kevinsproject.sytes.net",
          by: "name"
         },
        authToken: "(removed)",
        session: {
          _content: 12,
          id: 12
         },
        userAgent: {
          name: "ZimbraWebClient - SAF3 (Win)",
          version: "7.1.2_GA_3268"
         }
       }
     }
    Any ideas?

    Thanks.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,439
    Rep Power
    56

    Default

    Quote Originally Posted by kevjersey147 View Post
    Any ideas?.
    Lots of ideas but there really isn't much information to gon in the above post. Are you behind a NAT router? Have you installed a Split DNS (you must if you're behind NAT)? Have you disabled AppArmor & the firewall? Why didn't you install the most recent release of Zimbra? What errors do you see in the log files when you try to send an email? So we don't cover the same ground, which of the threads and solutions that cover this topic in the forums have you tried and what were the results?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    kevjersey147 is offline Banned
    Join Date
    Apr 2012
    Posts
    9
    Rep Power
    0

    Default

    Yes i'm behind a NAT

    I install 7.0 ZCS open source edition

    I installed and configured bind using Elijah Paul's guide and the DNS split guide on the zimbra wiki site.

    Hostfile

    Code:
    127.0.0.1 localhost.localdomain localhost
    10.49.98.237  kevinsproject.sytes.net mail
    
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    db domainname.com file

    Code:
    ;
    ;       Addresses and other host information.
    ;
    @       IN      SOA     kevinsproject.sytes.net. admin.kevinsproject.sytes.net. (
                                   10118      ; Serial
                                   43200      ; Refresh
                                   3600       ; Retry
                                   3600000    ; Expire
                                   2592000 )  ; Minimum
    ;       Define the nameservers and the mail servers
            IN      NS      10.49.98.237
    kevinsproject.sytes.net.         IN      MX      10 kevinsproject.sytes.net.
    kevinsproject.sytes.net.    IN      A       10.49.98.237
    DB 10.49.98.237 file

    Code:
    $TTL 3D
    @               IN      SOA     kevinsproject.sytes.net. admin.kevinsproject.sytes.net. (
                                   1       ; Serial
                                   8H      ; Refresh
                                   2H      ; Retry
                                   4W      ; Expire
                                   1D)     ; Minimum TTL
                            NS      kevinsproject.sytes.net.
    00000000                       PTR     localhost.
    the log file reads;

    Thanks.
    Attached Files Attached Files

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,439
    Rep Power
    56

    Default

    Your hosts file is incorrect, the line containing your LAN IP is wrong - go to the Split DNS article and check the required format there. When you've made that change you can check your configuration by running all the commands in the 'Verify....' section of that article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    kevjersey147 is offline Banned
    Join Date
    Apr 2012
    Posts
    9
    Rep Power
    0

    Default

    thanks for reply,

    I made the change to the hosts file and used the verify commands, so the hostfile now reads

    Code:
    127.0.0.1 localhost.localdomain localhost
    10.49.98.237  mail.kevinsproject.sytes.net mail
    
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    But can still can not send emails?

    Thanks again.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,439
    Rep Power
    56

    Default

    Did you restart the server and what is the output of all those commands (just for verification)? You should "tail -f" the log file and then try sending an email to see what the error is that occurs at that point.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    kevjersey147 is offline Banned
    Join Date
    Apr 2012
    Posts
    9
    Rep Power
    0

    Default

    ye restarted server

    ok

    the log file (after trying to send an email)

    Code:
    May  8 18:10:30 kevinsproject zmmailboxdmgr[28636]: status requested
    May  8 18:10:30 kevinsproject zmmailboxdmgr[28636]: status OK
    May  8 18:10:34 kevinsproject postfix/smtpd[28737]: connect from kevinsproject.sytes.net[10.49.98.237]
    May  8 18:10:34 kevinsproject postfix/smtpd[28737]: fatal: non-null host address bits in "10.49.98.237/8", perhaps you should use "10.0.0.0/8" instead
    May  8 18:10:35 kevinsproject postfix/master[21226]: warning: process /opt/zimbra/postfix/libexec/smtpd pid 28737 exit status 1
    May  8 18:10:35 kevinsproject postfix/master[21226]: warning: /opt/zimbra/postfix/libexec/smtpd: bad command startup -- throttling
    May  8 18:10:47 kevinsproject zmmailboxdmgr[28825]: status requested
    May  8 18:10:47 kevinsproject zmmailboxdmgr[28825]: status OK
    May  8 18:10:47 kevinsproject zmmailboxdmgr[28833]: status requested
    May  8 18:10:47 kevinsproject zmmailboxdmgr[28833]: status OK
    dig kevinsproject.sytes.net mx

    Code:
    ; <<>> DiG 9.7.0-P1 <<>> kevinsproject.sytes.net mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9700
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 13, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;kevinsproject.sytes.net.    IN    MX
    
    ;; ANSWER SECTION:
    kevinsproject.sytes.net. 60    IN    MX    5 mail.kevinsproject.sytes.net.
    
    ;; AUTHORITY SECTION:
    .            78719    IN    NS    d.root-servers.net.
    .            78719    IN    NS    l.root-servers.net.
    .            78719    IN    NS    g.root-servers.net.
    .            78719    IN    NS    j.root-servers.net.
    .            78719    IN    NS    a.root-servers.net.
    .            78719    IN    NS    e.root-servers.net.
    .            78719    IN    NS    f.root-servers.net.
    .            78719    IN    NS    m.root-servers.net.
    .            78719    IN    NS    c.root-servers.net.
    .            78719    IN    NS    k.root-servers.net.
    .            78719    IN    NS    i.root-servers.net.
    .            78719    IN    NS    b.root-servers.net.
    .            78719    IN    NS    h.root-servers.net.
    
    ;; Query time: 115 msec
    ;; SERVER: 10.49.98.237#53(10.49.98.237)
    ;; WHEN: Tue May  8 18:13:13 2012
    ;; MSG SIZE  rcvd: 270
    dig kevinsproject.sytes.net any

    Code:
    ; <<>> DiG 9.7.0-P1 <<>> kevinsproject.sytes.net any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2934
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 13, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;kevinsproject.sytes.net.    IN    ANY
    
    ;; ANSWER SECTION:
    kevinsproject.sytes.net. 25    IN    MX    5 mail.kevinsproject.sytes.net.
    
    ;; AUTHORITY SECTION:
    .            78684    IN    NS    h.root-servers.net.
    .            78684    IN    NS    e.root-servers.net.
    .            78684    IN    NS    j.root-servers.net.
    .            78684    IN    NS    d.root-servers.net.
    .            78684    IN    NS    a.root-servers.net.
    .            78684    IN    NS    g.root-servers.net.
    .            78684    IN    NS    b.root-servers.net.
    .            78684    IN    NS    f.root-servers.net.
    .            78684    IN    NS    i.root-servers.net.
    .            78684    IN    NS    c.root-servers.net.
    .            78684    IN    NS    l.root-servers.net.
    .            78684    IN    NS    k.root-servers.net.
    .            78684    IN    NS    m.root-servers.net.
    
    ;; Query time: 16 msec
    ;; SERVER: 10.49.98.237#53(10.49.98.237)
    ;; WHEN: Tue May  8 18:13:48 2012
    ;; MSG SIZE  rcvd: 270
    Cheers.
    Last edited by kevjersey147; 05-08-2012 at 11:21 AM.

  8. #8
    kevjersey147 is offline Banned
    Join Date
    Apr 2012
    Posts
    9
    Rep Power
    0

    Default

    something else I found,

    I get the following error msg (img below) when checking the mx record in the admin console.

    Not sure what could be causing this.

    I am using no-ip.com for the free sub domain and just added an mx record to that domain. I also made the A record to point the domain name to the servers static IP address - Is this correct?

    Thanks.

    PS. A new development: When I add mail. to the hosts file, so instead of kevinsproject.sytes.net its mail.kevinsproject.sytes.net the service cannot restart and I get the following error slapd failed to start. However, when I remove the mail. the service starts fine??
    Attached Images Attached Images
    Last edited by kevjersey147; 05-08-2012 at 03:22 PM.

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,439
    Rep Power
    56

    Default

    Did you also modify your bind configuration after changing the hosts file? I guess not as the output from the dig commands above show no A record for your server. Take a look at the Examples & Variations (just the first example) on this page for an example of the required configuration.

    BTW, what is the entry in your 'mynetworks' (have you made any changes to it)? Check the configuration in this article: http://wiki.zimbra.com/wiki/ZimbraMtaMyNetworks
    Last edited by phoenix; 05-09-2012 at 12:18 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    kevjersey147 is offline Banned
    Join Date
    Apr 2012
    Posts
    9
    Rep Power
    0

    Default

    hi, thanks for reply

    I changed the bind configs, they now read;

    db kevinsproject.sytes.net

    Code:
    ;
    ;       Addresses and other host information.
    ;
    @       IN      SOA     mail.kevinsproject.sytes.net. admin.kevinsproject.sytes.net. (
                                   101026      ; Serial
                                   43200      ; Refresh
                                   3600       ; Retry
                                   3600000    ; Expire
                                   2592000 )  ; Minimum
    ;       Define the nameservers and the mail servers
    
    @                                      IN      NS      mail
    kevinsproject.sytes.net.        IN      MX      10 mail.kevinsproject.sytes.net.
    mail                                   IN      A       10.49.98.237
                                            IN      A       10.49.98.237
    db 10.49.98.237

    Code:
    $TTL 3D
    @               IN      SOA     mail.kevinsproject.sytes.net. admin.kevinsproject.sytes.net. (
                                   1       ; Serial
                                   8H      ; Refresh
                                   2H      ; Retry
                                   4W      ; Expire
                                   1D)     ; Minimum TTL
    
                                NS      mail.kevinsproject.sytes.net.
    00000000                       PTR     localhost
    and also the postconf mynetworks output

    Code:
    sudo: unable to resolve host mail.kevinsproject.sytes.net
    mynetworks = 127.0.0.0/8 10.49.98.237/8
    thanks.

    PS. After those changes zimbra can now start again.
    Last edited by kevjersey147; 05-09-2012 at 02:59 AM.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Unable to send email
    By carnold in forum Administrators
    Replies: 5
    Last Post: 10-31-2007, 11:32 AM
  2. Remote IMAP clients unable to send email
    By AlanWilliamson in forum Administrators
    Replies: 6
    Last Post: 09-05-2007, 05:50 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 03:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •