Results 1 to 7 of 7

Thread: Switching main domain and domain alias

  1. #1
    mludwig is offline Senior Member
    Join Date
    Mar 2008
    Posts
    52
    Rep Power
    7

    Default Switching main domain and domain alias

    Hi,

    I really don't know if this has been asked ever before.
    Please forgive me, if so.

    We do have a simple problem which hopefully can easily be solved:

    - Existing, great working zimbra installation (7.1.3_GA_3346.FOSS which will be upgraded hopefully this night or the next)
    - main domain "domain-notgood.de"
    - alias domain "domain-verygood.de"

    This works perfectly as we can receive our mails at domain-notgood.de and also at domain-verygood.de.

    Now this is the question:

    How can we switch these two domains, so that domain-verygood.de will become the main domain and that we are sending from this domain also?
    And that the old domain domain-notgood.de will be the alias domain in future?

    I really really hope that we can do that!

    So long, best regards,
    Michael

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by mludwig View Post
    What the heck is that? Spam on Zimbra forums??
    In future it would help if you reported it, hit the button on the post that has a red circle with an exclamation mark.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    mludwig is offline Senior Member
    Join Date
    Mar 2008
    Posts
    52
    Rep Power
    7

    Default

    Hi phoenix, I'm really sorry that I dismissed that. Next time I will do so of course. ;-)

  4. #4
    mludwig is offline Senior Member
    Join Date
    Mar 2008
    Posts
    52
    Rep Power
    7

    Default

    Hi vavai,

    thank you for your answer. That really sounds great!
    So let me ask further questions before proceeding with your given tips. ;-)

    What is the best way of creating a backup in FOSS edition? Is it enough to simply create a snapshot via vSphere Client?
    Or is there a better way of doing this?

    Has anybody done this ever before?
    Were there problems running the zmprov command?
    Where do you think could be a problem when doing so?

    Now that I know that there is a zimbra command for this purpose I'm indeed hopeful that this problem can also be solved like many other problems before.

    This shows us again what a great piece of software Zimbra is. ;-)

    Michael

  5. #5
    mludwig is offline Senior Member
    Join Date
    Mar 2008
    Posts
    52
    Rep Power
    7

    Default

    Does someone have any answers to my questions in the last posting?

  6. #6
    LowPass is offline Active Member
    Join Date
    May 2012
    Posts
    38
    Rep Power
    2

    Default

    Hi!

    I did the same change a couple of days ago, worked like a charm.
    There is no problems in renaming a domain as vavai suggest, the command is pretty straight forward and zmprov is a reliable tool.

    About backup of FOSS edition, this is one of the few cases when a simple snapshot is enough, as the change is made istantly and if you see any problems you can revert back pretty fast.
    For additional safety you could temporarily block all traffic for the mail and UI ports using iptables (restart the mailboxd service afterwards to drop active connections), so that while you make this change mail is bounced and in case you need to revert you will loose no data.

    Sehen sie,
    Mike
    Last edited by LowPass; 05-18-2012 at 08:37 AM.

  7. #7
    mludwig is offline Senior Member
    Join Date
    Mar 2008
    Posts
    52
    Rep Power
    7

    Default

    This really worked great. The zmprov command took only a second or two and the whole magic was done.
    Afterwards I edited every account so that it now sends out email with the new domain instead of the old one.

    Thank you all very very much for your tips!

    Michael

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Domain Alias Error
    By babyporch in forum Administrators
    Replies: 3
    Last Post: 04-06-2011, 03:05 AM
  2. Replies: 7
    Last Post: 04-27-2009, 02:49 AM
  3. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  4. [SOLVED] Remove main domain!
    By zibra in forum Administrators
    Replies: 11
    Last Post: 09-27-2007, 08:50 AM
  5. Domain Alias / User Alias problem after upgrading.
    By Bingo in forum Administrators
    Replies: 1
    Last Post: 04-20-2007, 03:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •