Results 1 to 7 of 7

Thread: Set proxy timeout

  1. #1
    sae65 is offline Active Member
    Join Date
    Mar 2009
    Posts
    46
    Rep Power
    6

    Default Set proxy timeout

    Test environment - Zimbra Network 7.2.0

    Getting Gateway 504 errors.

    Trying to modify the proxy_read_timeout and the proxy_send_timeout which are showing 0 in nginx.conf.web Where does one change the variables
    of web.upstream.read.timeout and web.upstream.send.timeout

    # Set proxy timeout
    proxy_read_timeout ${web.upstream.read.timeout};
    proxy_send_timeout ${web.upstream.send.timeout};

    found in the nginx.conf.web.template?

    I modified them manually by removing the ${} part and putting an actual number it its place. Still would really like to know where the "web.upstream.read/send.timeout" variable pulls its data.
    Last edited by sae65; 05-04-2012 at 07:54 PM. Reason: additional data

  2. #2
    bseclier is offline Junior Member
    Join Date
    Jun 2010
    Location
    Nancy (France)
    Posts
    7
    Rep Power
    5

    Default

    Hi,
    these values are in zimbra configuration. You can see them with this command (with zimbra user) :
    zmprov gacf |grep -i timeout

    Exact values are :
    zimbraReverseProxyUpstreamReadTimeout: 60s
    zimbraReverseProxyUpstreamSendTimeout: 60s

  3. #3
    sae65 is offline Active Member
    Join Date
    Mar 2009
    Posts
    46
    Rep Power
    6

    Default

    Thank you for the response. Those two variables do not appear in my zimbra configuration. I even had deleted my proxy server and reinstalled it and still they do not appear. Going to try to manually force those two settings and see what happens.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Quote Originally Posted by sae65 View Post
    Those two variables do not appear in my zimbra configuration.
    You need to upgrade to a more recent version of ZCS.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    sae65 is offline Active Member
    Join Date
    Mar 2009
    Posts
    46
    Rep Power
    6

    Default

    My test system is at 7.2.0 version of ZCS. Those variables do not appear..

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Quote Originally Posted by sae65 View Post
    My test system is at 7.2.0 version of ZCS. Those variables do not appear..
    Perhaps it would be an idea if you give a description of what your configuration actually is. FWIW, those settings appear on my 7.2 server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    sae65 is offline Active Member
    Join Date
    Mar 2009
    Posts
    46
    Rep Power
    6

    Default

    $ zmprov gacf |grep -i timeout

    zimbraDataSourceConnectTimeout: 30
    zimbraDataSourceReadTimeout: 60
    zimbraMemcachedClientTimeoutMillis: 10000
    zimbraReverseProxyCacheFetchTimeout: 3s
    zimbraReverseProxyConnectTimeout: 120000ms
    zimbraReverseProxyInactivityTimeout: 1h
    zimbraReverseProxyRouteLookupTimeout: 15s
    zimbraReverseProxyRouteLookupTimeoutCache: 60s
    zimbraSmtpTimeout: 60

    Misc data: My 7.2.0 imapproxy worked just fine until I had to rename my test server. That is when I noticed that the fields I mentioned in my first post were set to 0. That did not seem correct and I started looking around for where those fields were populated. Sadly I can not say with any authority what the nginx.conf.web looked like before I performed the name change for that server and zimbra services. I was just disappointed when I removed my imapproxy server and reinstalled it that it still was not working. As mentioned in the first posting I did get it to work by modifying the template to reflect a timeout # for those two variables.
    Last edited by sae65; 05-07-2012 at 07:50 AM. Reason: additional info

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Crashes every day
    By feiticeir0 in forum Administrators
    Replies: 10
    Last Post: 10-13-2011, 06:53 AM
  2. nginx proxy timeout errors
    By MobiusNZ in forum Administrators
    Replies: 0
    Last Post: 06-08-2011, 03:08 PM
  3. Session timeout / zimbra proxy / iphone
    By NOZIL in forum Zimbra Mobile
    Replies: 2
    Last Post: 12-07-2010, 09:14 AM
  4. Update Received Date in Folder-Listing
    By Oswald-Kolle in forum Installation
    Replies: 25
    Last Post: 08-21-2007, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •