Results 1 to 6 of 6

Thread: Re-create / repair an entire user account...

  1. #1
    ducommun is offline Active Member
    Join Date
    Jul 2010
    Posts
    38
    Rep Power
    4

    Default Re-create / repair an entire user account...

    Hello all,
    i have some problem with just one user on my zimbra 7 server (latest release aivailable)

    When i search a mail, scroll in the list and click on a mail, it scroll to top of window and the selected mail will not be displayed.

    I does'nt find any solution for this.

    My idea, export entire user data (mail, calendar, contact, briefcase, etc...) and re-import all data in a new fresh user.

    But, how can i make this??...

    Many thanks for your help and best regards.

  2. #2
    justdave is offline Trained Alumni
    Join Date
    Nov 2008
    Location
    Grand Rapids, MI
    Posts
    123
    Rep Power
    6

    Default

    You might try reindexing the user's mailbox. Sometimes strange behavior like this can be caused by a corrupted index. When viewing the user's account in the admin interface there should be a button to Reindex the account in the toolbar at the top of the tab.

  3. #3
    ducommun is offline Active Member
    Join Date
    Jul 2010
    Posts
    38
    Rep Power
    4

    Default

    Thanks, i have already reindex the mailbox, already empty all cache, on client and server side.

    No procedure to export/import an account?

    Many thanks for your help.

  4. #4
    chauvetp is offline Elite Member
    Join Date
    Apr 2008
    Location
    New Paltz, NY
    Posts
    284
    Rep Power
    7

    Default

    If the mail is still readable from an export, you can go into the account and export its mail/contacts/calendars as a .tgz file within Preferences->Import/Export.

    It would be easy enough to test re-importing it into a test account to see if the mail/contacts/calendars are readable.

    This wouldn't preserve user settings, signatures, etc but would keep the data.
    ---
    Paul Chauvet
    State University of New York at New Paltz

  5. #5
    LHammonds's Avatar
    LHammonds is offline Special Member
    Join Date
    Sep 2011
    Location
    Texas
    Posts
    150
    Rep Power
    3

    Default

    Quote Originally Posted by ducommun View Post
    Hello all,
    My idea, export entire user data (mail, calendar, contact, briefcase, etc...) and re-import all data in a new fresh user.

    But, how can i make this??...
    If you want to go this route, I recommend restoring the backup to a temporary account just to make sure the problem does not follow with the backup as well as to make sure you got everything in the backup.

    I have Zimbra installed on an Ubuntu server, this is the command I use to backup an individual mailbox (Mailbox Acct = lhammonds):

    Code:
    /opt/zimbra/bin/zmmailbox -z -m lhammonds getRestURL "//?fmt=tgz" > /tmp/lhammonds.tgz
    Next, create a test account called "testrestore" and restore the archive by running this command:

    Code:
    /opt/zimbra/bin/zmmailbox -z -m testrestore postRestURL "//?fmt=tgz&resolve=reset" /tmp/lhammonds.tgz
    If all looks good, delete the original mailbox account (lhammonds in this example) and re-create the account. Now restore the data to the account:

    Code:
    /opt/zimbra/bin/zmmailbox -z -m lhammonds postRestURL "//?fmt=tgz&resolve=reset" /tmp/lhammonds.tgz
    Type su - zimbra -c "zmcontrol -v" to get your version and copy that into your profile (more info here)

  6. #6
    ducommun is offline Active Member
    Join Date
    Jul 2010
    Posts
    38
    Rep Power
    4

    Default

    Quote Originally Posted by ducommun View Post
    When i search a mail, scroll in the list and click on a mail, it scroll to top of window and the selected mail will not be displayed.

    I does'nt find any solution for this.
    OK, i have find why the user interface was degraded...

    It's really a bug? It's really simple to reproduce this on other installation.

    If the "keybord shortcut" was disable for a user, the ui has this bug.
    If the "keybord shortcut" was enable, no bug...

    Mmm, ca you reproduce this on your installation?

    Many thanks for your help!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] database integrity check shows errors
    By alto in forum Administrators
    Replies: 6
    Last Post: 09-10-2011, 06:16 AM
  2. Database integrity check
    By mludwig in forum Administrators
    Replies: 4
    Last Post: 08-15-2011, 02:56 AM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. Network edition - strange behavior
    By goetzi in forum Installation
    Replies: 6
    Last Post: 11-16-2005, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •