Results 1 to 4 of 4

Thread: block a user from sending emails to other domain

  1. #1
    malayo is offline Special Member
    Join Date
    Apr 2011
    Posts
    117
    Rep Power
    3

    Default block a user from sending emails to other domain

    from article https://wiki.zimbra.com/index.php?ti...ertain_domains

    I tried to block user postmaster@mydomain.com from sending outside of mydomain.com since I saw on MailScanner's server that it sending spams to yahoo.com domain.

    in /opt/zimbra/conf/tpmail_senders, I put (before ran postmap)
    Code:
    postmaster.mydomain.com restrict_tpmail
    and only allow it to send to allstaff distribution list in /opt/zimbra/conf/tpmail_recipients
    Code:
    allstaff.mydomain.com OK
    but after I reload postfix as zimbra user on all zimbra MTAs
    Code:
    postfix reload
    I can still send to gmail (a domain other than mydomain.com).

    What/which step that I would have missed?

  2. #2
    dream_liner2k2 is offline Active Member
    Join Date
    Feb 2012
    Location
    India
    Posts
    35
    Rep Power
    3

  3. #3
    malayo is offline Special Member
    Join Date
    Apr 2011
    Posts
    117
    Rep Power
    3

    Default

    Thanks. That did the trick but how do I revert from wiki link I gave on 1st post, it cannot simply be reverted by deleting configurations done and .db files. I had to redo postmap then only below error would dissappear

    Code:
    Apr 25 15:46:58 mta1 postfix/smtpd[12350]: fatal: open database /opt/zimbra/conf/tpmail_recipients.db: No such file or directory
    Settings pointing to this file has been removed. Does postfix cache it somewhere? I also had tried restarting zimbra services.
    Last edited by malayo; 04-25-2012 at 01:55 AM.

  4. #4
    dream_liner2k2 is offline Active Member
    Join Date
    Feb 2012
    Location
    India
    Posts
    35
    Rep Power
    3

    Default

    Hi Malayo,

    I tried to the first article and it didnt work out fr me too.

    But,Before making the changes to the cf files and creating the files as suggest, i had copied the files into the same files with .bak.full_date_stamp, so that I can aalways copy them back.

    If u had undone everything,
    1. postmax as suggested in the articile i posted, plus
    2. postfix reload
    3. zmmtactl stop & zmmtactl start

    should suffice.

    R/Venu

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 04-27-2009, 02:49 AM
  2. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  3. Zimbra server stopped sending emails
    By netwerkdude in forum Installation
    Replies: 20
    Last Post: 04-23-2007, 11:05 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. Network edition - strange behavior
    By goetzi in forum Installation
    Replies: 6
    Last Post: 11-16-2005, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •