Results 1 to 4 of 4

Thread: IMAP server abruptly closing connection

  1. #1
    Aragon is offline Starter Member
    Join Date
    Apr 2012
    Location
    Cape Town, South Africa
    Posts
    1
    Rep Power
    3

    Default IMAP server abruptly closing connection

    Hi,

    For some of our user accounts, the IMAP server on our ZCS installation abruptly closes the connection to the client. Please see the IMAP debug log below:

    Code:
    2012-04-24 15:32:54,785 DEBUG [ImapServer-1] [name=ashley@example.com;ip=192.168.20.20;] imap - opening folder: Sent
    2012-04-24 15:32:54,788 DEBUG [ImapServer-1] [name=ashley@example.com;ip=192.168.20.20;] imap -   ** iterating (collapseExpunged)
    2012-04-24 15:32:54,789 DEBUG [ImapServer-1] [name=ashley@example.com;ip=192.168.20.20;] imap - copying message data from existing session: Sent
    2012-04-24 15:32:54,789 DEBUG [ImapServer-1] [name=ashley@example.com;ip=192.168.20.20;] imap - paging session during close: Sent
    2012-04-24 15:32:54,789 DEBUG [ImapServer-1] [name=ashley@example.com;ip=192.168.20.20;] imap -   ** iterating (collapseExpunged)
    2012-04-24 15:32:54,790 DEBUG [ImapServer-1] [name=ashley@example.com;ip=192.168.20.20;] imap - added [com.zimbra.cs.imap.ImapMessage@103, com.zimbra.cs.imap.ImapMessage@104, com.zimbra.cs.imap.ImapMessage@105, com.zimbra.cs.imap.ImapMessage@106, com.zimbra.cs.imap.ImapMessage@107, com.zimbra.cs.imap.ImapMessage@108, com.zimbra.cs.imap.ImapMessage@154, com.zimbra.cs.imap.ImapMessage@155, com.zimbra.cs.imap.ImapMessage@157, com.zimbra.cs.imap.ImapMessage@158, com.zimbra.cs.imap.ImapMessage@159, com.zimbra.cs.imap.ImapMessage@15a]
    2012-04-24 15:32:54,790 INFO  [ImapServer-1] [name=ashley@example.com;ip=192.168.20.20;] imap - selected folder Sent
    2012-04-24 15:32:54,831 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 1 FETCH (UID 259 FLAGS (\Seen))
    2012-04-24 15:32:54,832 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 2 FETCH (UID 260 FLAGS (\Seen))
    2012-04-24 15:32:54,832 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 3 FETCH (UID 261 FLAGS (\Seen))
    2012-04-24 15:32:54,833 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 4 FETCH (UID 262 FLAGS (\Seen))
    2012-04-24 15:32:54,833 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 5 FETCH (UID 263 FLAGS (\Seen))
    2012-04-24 15:32:54,834 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 6 FETCH (UID 264 FLAGS (\Seen))
    2012-04-24 15:32:54,834 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 7 FETCH (UID 340 FLAGS (\Seen))
    2012-04-24 15:32:54,834 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 8 FETCH (UID 341 FLAGS (\Seen))
    2012-04-24 15:32:54,835 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 9 FETCH (UID 343 FLAGS (\Seen))
    2012-04-24 15:32:54,835 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 10 FETCH (UID 344 FLAGS (\Seen))
    2012-04-24 15:32:54,836 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 11 FETCH (UID 345 FLAGS (\Seen))
    2012-04-24 15:32:54,836 DEBUG [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap -   S: * 12 FETCH (UID 346 FLAGS (\Seen))
    2012-04-24 15:32:56,501 INFO  [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap - S: Message-ID: BAD parse error: command not implemented
    2012-04-24 15:32:56,502 INFO  [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap - S: Date: BAD parse error: command not implemented
    2012-04-24 15:32:56,502 INFO  [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap - S: From: BAD parse error: command not implemented
    2012-04-24 15:32:56,502 INFO  [ImapServer-1] [name=ashley@example.com;mid=46;ip=192.168.20.20;] imap - S: User-Agent: BAD parse error: command not implemented
    2012-04-24 15:32:56,503 INFO  [ImapServer-1] [] imap - dropping connection for user ashley@example.com (server-initiated)
    2012-04-24 15:32:56,503 INFO  [ImapServer-1] [] ProtocolHandler - Handler exiting normally
    (real email domain name replaced with example.com)

    The same error is occurring with multiple accounts.

    Any idea how to fix this, and prevent it from happening in future?

  2. #2
    s.vasilyev is offline Active Member
    Join Date
    Dec 2009
    Location
    Russia, Moscow
    Posts
    27
    Rep Power
    5

    Default

    got similar problem, any1 has answer or a tip?

  3. #3
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by s.vasilyev View Post
    got similar problem, any1 has answer or a tip?
    It might help if you gave details of which IMAP client you're using, also take a look at these threads: site:zimbra.com +"BAD parse error: command not implemented" - Yahoo! Search Results
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    s.vasilyev is offline Active Member
    Join Date
    Dec 2009
    Location
    Russia, Moscow
    Posts
    27
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    It might help if you gave details of which IMAP client you're using, also take a look at these threads: site:zimbra.com +"BAD parse error: command not implemented" - Yahoo! Search Results
    Thank you for you assistance:


    2012-05-16 15:56:14,834 INFO [ImapServer-19753] [name=USER@DOMAIN;mid=741;ip=IP_HERE;ua=Thunderbird/12.0.1;] mailop - Adding Message: id=108935, Message-ID=<4FB3A3B8.1030402@DOMAIN>, parentId=-1, folderId=6, folderName=Drafts.
    2012-05-16 15:56:15,119 INFO [ImapServer-19753] [] imap - dropping connection for user USER@DOMAIN (server-initiated)

    well this is it. We mostly use thunderbird different versions from 3 to 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Failed to bind to LDAP server
    By tezarin in forum Administrators
    Replies: 4
    Last Post: 01-23-2012, 09:26 AM
  2. LMTP server closing connection - system non-responsive
    By karol@uri.edu in forum Administrators
    Replies: 13
    Last Post: 10-11-2011, 06:19 AM
  3. IMAP Server Hangs
    By Greenview in forum Administrators
    Replies: 0
    Last Post: 07-26-2011, 09:51 AM
  4. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 04:32 PM
  5. A connector to an external IMAP Server
    By gba in forum Developers
    Replies: 1
    Last Post: 07-03-2006, 01:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •