Results 1 to 8 of 8

Thread: zmconfigd CRITICAL [11611-MainThread-2]

  1. #1
    fons is offline Member
    Join Date
    May 2011
    Location
    Amsterdam
    Posts
    11
    Rep Power
    4

    Question zmconfigd CRITICAL [11611-MainThread-2]

    Hello,

    our zimbra version is: Release 7.1.1_GA_3196.UBUNTU10_64 UBUNTU10_64 FOSS edition.

    after a renwal of the commercial certificates the zimbra.log is filled with errors.

    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/zmamavisdctl: (Cannot run program "/opt/zimbra/bin/zmamavisdctl" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)
    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/zmclamdctl: (Cannot run program "/opt/zimbra/bin/zmclamdctl" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)
    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/ldap: (Cannot run program "/opt/zimbra/bin/ldap" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)
    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/zmloggerctl: (Cannot run program "/opt/zimbra/bin/zmloggerctl" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)
    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/zmstorectl: (Cannot run program "/opt/zimbra/bin/zmstorectl" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)
    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/zmmailboxdctl: (Cannot run program "/opt/zimbra/bin/zmmailboxdctl" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)
    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/postfix: (Cannot run program "/opt/zimbra/bin/postfix" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)
    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/zmsaslauthdctl: (Cannot run program "/opt/zimbra/bin/zmsaslauthdctl" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)
    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/zmswatchctl: (Cannot run program "/opt/zimbra/bin/zmswatchctl" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)
    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/zmspellctl: (Cannot run program "/opt/zimbra/bin/zmspellctl" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)
    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/zmstatctl: (Cannot run program "/opt/zimbra/bin/zmstatctl" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)
    Apr 18 10:51:11 zmconfigd CRITICAL [11611-MainThread-2] Exception in bin/zmclamdctl: (Cannot run program "/opt/zimbra/bin/zmclamdctl" (in directory "/opt/zimbra/ssl/zimbra/commercial"): java.io.IOException: error=13, Permission denied)

    however: everything seems to work fine but the error worries me.
    can someone point out the meaning of this error and how to avoid it?

    regards, Fons

  2. #2
    lytledd is offline Elite Member
    Join Date
    Dec 2009
    Location
    Michigan
    Posts
    448
    Rep Power
    5

    Default

    Ben Franklin quote:

    "Those who would give up Essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety."

  3. #3
    fons is offline Member
    Join Date
    May 2011
    Location
    Amsterdam
    Posts
    11
    Rep Power
    4

    Default

    I tried the above solution.
    but when restarting zimbra I got:

    MTA stopped
    postfix is not running

    What to do

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by fons View Post
    I tried the above solution.
    but when restarting zimbra I got:

    MTA stopped
    postfix is not running

    What to do
    Look in the log files for any errors when you start Zimbra and search the forums for those errors.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    fons is offline Member
    Join Date
    May 2011
    Location
    Amsterdam
    Posts
    11
    Rep Power
    4

    Question

    this is what I got from the zimbra.log

    Apr 18 19:47:52 zmconfigd CRITICAL [31442-MainThread-17] Tracking service mta
    Apr 18 19:48:00 mail postfix/postqueue[13978]: fatal: Queue report unavailable - mail system is down
    Apr 18 19:48:04 mail zmmailboxdmgr[14266]: status requested
    Apr 18 19:48:04 mail zmmailboxdmgr[14266]: status OK
    Apr 18 19:48:30 mail postfix/postqueue[14423]: fatal: Queue report unavailable - mail system is down
    Apr 18 19:48:53 mail zmmailboxdmgr[14490]: status requested
    Apr 18 19:48:53 mail zmmailboxdmgr[14490]: status OK
    Apr 18 19:48:53 mail zmmailboxdmgr[14498]: status requested
    Apr 18 19:48:53 mail zmmailboxdmgr[14498]: status OK

    What to do

  6. #6
    fons is offline Member
    Join Date
    May 2011
    Location
    Amsterdam
    Posts
    11
    Rep Power
    4

    Question MTA stopped Postfix is not running

    Hello,

    after using zmfixperms I do have trouble (deep shit) with the MTA

    the status points out:

    root@mail:/home/fons# su - zimbra
    zimbra@mail:~$ zmcontrol status
    Host mail.debalie.nl
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Stopped
    postfix is not running
    snmp Running
    spell Running
    stats Running
    zmconfigd Running
    zimbra@mail:~$

    the zimbra.log is giving the following errors:

    Apr 18 19:47:52 zmconfigd CRITICAL [31442-MainThread-17] Tracking service mta
    Apr 18 19:48:00 mail postfix/postqueue[13978]: fatal: Queue report unavailable - mail system is down
    Apr 18 19:48:04 mail zmmailboxdmgr[14266]: status requested
    Apr 18 19:48:04 mail zmmailboxdmgr[14266]: status OK
    Apr 18 19:48:30 mail postfix/postqueue[14423]: fatal: Queue report unavailable - mail system is down
    Apr 18 19:48:53 mail zmmailboxdmgr[14490]: status requested
    Apr 18 19:48:53 mail zmmailboxdmgr[14490]: status OK
    Apr 18 19:48:53 mail zmmailboxdmgr[14498]: status requested
    Apr 18 19:48:53 mail zmmailboxdmgr[14498]: status OK

    I've tried several solutions posted on the forums but they did not solve my acute problem.

    can anyone help me on this

    regards, Fons

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Don't start a new thread when you've already got one running on your problem, I'll merge this post with your other thread.

    Quote Originally Posted by fons View Post
    I've tried several solutions posted on the forums but they did not solve my acute problem.
    Tell us what you've actually tried (and what the results were) so we don't go over the same steps again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    fons is offline Member
    Join Date
    May 2011
    Location
    Amsterdam
    Posts
    11
    Rep Power
    4

    Default

    the errors are fixed
    it happened to be a bug after using zmfixperms. see: https://bugzilla.zimbra.com/show_bug.cgi?id=57891
    zmfixperms sets master.lock and the prng_exch to root ownership where it should be owned by postfix
    after resetting the ownership we were able to start the MTA with: zmmtactl start

    regards Fons

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] zmconfigd not running
    By ben1967 in forum Administrators
    Replies: 49
    Last Post: 02-21-2013, 12:55 AM
  2. Possible corrupt LDAP
    By weezbunbun in forum Administrators
    Replies: 20
    Last Post: 02-12-2012, 08:34 AM
  3. Permission Denied error in logs
    By mutuku in forum Administrators
    Replies: 0
    Last Post: 02-01-2012, 02:24 PM
  4. zmconfigd logs - "criticals" shown
    By billinvegas in forum Administrators
    Replies: 5
    Last Post: 08-02-2011, 12:50 PM
  5. zmconfigd CRITICAL. Logger restarts periodically
    By brlo in forum Administrators
    Replies: 7
    Last Post: 07-20-2011, 07:44 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •