Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: Migrating mailboxes from existing zimbra 7.1.3 to live Zimbra 7.1.4

  1. #11
    muyepaa is offline Intermediate Member
    Join Date
    Apr 2012
    Posts
    17
    Rep Power
    3

    Default

    Federico.bertola,

    I installed ZeXtras, it has finished running. It has created many files within /opt/zimbra/backup/export/accounts.

    When I tried to list any file eg. #cat ff2883a5-1800-46d1-aa43-3e151fcacc74/account_info somewhere it says zimbraDataSourceLastError":"system failure: Unable to connect to IMAP server:

    See snippet below:

    [{"datasources":[{"objectClass":["zimbraDataSource","zimbraImapDataSource"],"zimbraDataSourceAuthorizationId":"xxx@yyyyy.zz", "zimbraDataSourceConnectionType":"ssl","zimbraData SourceAuthMechanism":"PLAIN","zimbraDataSourcePort ":"993","zimbraDataSourcePassword":"Aahz1PMN/Oh0+cGiAj5ELuEHsDDHu7A9KfZ5v1R7wF3D","zimbraDataSo urceImportOnly":"TRUE","zimbraDataSourceEnabled":" TRUE","zimbraDataSourceType":"imap","zimbraDataSou rceId":"009b0c16-bcce-45fe-986d-fec3f5429575","zimbraDataSourceHost":"10.137.2.7", "zimbraDataSourceFailingSince":"20120406052757Z"," zimbraCreateTimestamp":"20120406052634Z","zimbraDa taSourceUsername":"admin","zimbraDataSourceName":" __imap_import__","zimbraDataSourceFolderId":"1","z imbraDataSourceIsInternal":"TRUE","zimbraDataSourc eLastError":"system failure: Unable to connect to IMAP server: DataSource: { id=009b0c16-bcce-45fe-986d-fec3f5429575, type=imap, isEnabled=true, name=__imap_import__, host=10.137.2.7, port=993, connectionType=ssl, username=admin, folderId=1 }, No route to host"}],....


    I dont know if this how it supposed to work, should I proceed to the destination machined to run the import?

  2. #12
    muyepaa is offline Intermediate Member
    Join Date
    Apr 2012
    Posts
    17
    Rep Power
    3

    Default

    YES each of the servers are accessible via http. However on the old server I cannot get imapproxy to run. zmcontrol status show imapproxy Stopped, and zmnginxctl is not running. Port 993 is not listening

  3. #13
    justdave is offline Trained Alumni
    Join Date
    Nov 2008
    Location
    Grand Rapids, MI
    Posts
    123
    Rep Power
    6

    Default

    I really don't think ZeXtras is going to help here (though maybe it does and I'm misunderstanding how it works - I haven't used it before).

    The situation as I understood it is that he has one LDAP database and two separate and distinct MySQL databases, one of which matches LDAP and the other doesn't. He's trying to get the data out of the filestore and MySQL database of the one that doesn't match LDAP back into the one that does.

  4. #14
    muyepaa is offline Intermediate Member
    Join Date
    Apr 2012
    Posts
    17
    Rep Power
    3

    Default

    Am able to log in to each separate server. They are both authenticating to the same Ldap server. The accounts are exactly the same except that each server has its own mysql database, the contents of /opt/zimbra/store/0/ are not matching. Each server created its mailboxes from the same Ldap information. Each of the servers is accessible via http. However on the old server I cannot get imapproxy to run. zmcontrol status show imapproxy Stopped, and zmnginxctl is not running. Port 993 is not listening

    root@mailsrv:~# netstat -nltp shows, 993 cannot be used to connect
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:7780 0.0.0.0:* LISTEN 29691/httpd
    tcp 0 0 127.0.0.1:10663 0.0.0.0:* LISTEN 29161/zmlogger: zmr
    tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 29849/master
    tcp 0 0 127.0.0.1:7306 0.0.0.0:* LISTEN 28396/mysqld
    tcp 0 0 0.0.0.0:587 0.0.0.0:* LISTEN 29849/master
    tcp 0 0 0.0.0.0:11211 0.0.0.0:* LISTEN 29141/memcached
    tcp 0 0 0.0.0.0:465 0.0.0.0:* LISTEN 29849/master
    tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 5647/cupsd
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 29849/master
    tcp 0 0 0.0.0.0:3260 0.0.0.0:* LISTEN 5670/ietd
    tcp6 0 0 :::7072 :::* LISTEN 24740/java
    tcp6 0 0 :::7777 :::* LISTEN 24740/java
    tcp6 0 0 127.0.0.1:7171 :::* LISTEN 28549/java
    tcp6 0 0 :::5222 :::* LISTEN 24740/java
    tcp6 0 0 :::7110 :::* LISTEN 24740/java
    tcp6 0 0 :::5223 :::* LISTEN 24740/java
    tcp6 0 0 :::7335 :::* LISTEN 24740/java
    tcp6 0 0 :::7143 :::* LISTEN 24740/java
    tcp6 0 0 :::11211 :::* LISTEN 29141/memcached
    tcp6 0 0 :::80 :::* LISTEN 24740/java
    tcp6 0 0 :::7025 :::* LISTEN 24740/java
    tcp6 0 0 :::5269 :::* LISTEN 24740/java
    tcp6 0 0 :::22 :::* LISTEN 5584/sshd
    tcp6 0 0 :::3260 :::* LISTEN 5670/ietd
    tcp6 0 0 :::8735 :::* LISTEN 24740/java
    tcp6 0 0 :::10015 :::* LISTEN 24740/java
    tcp6 0 0 :::7071 :::* LISTEN 24740/java

  5. #15
    justdave is offline Trained Alumni
    Join Date
    Nov 2008
    Location
    Grand Rapids, MI
    Posts
    123
    Rep Power
    6

    Default

    So just to make sure I really did understand correctly what was happening... if you log into webmail on the old box, do you get the contents of those boxes from the new box displayed to you instead of the old information, or is it showing you the old info that you're trying to recover?

  6. #16
    muyepaa is offline Intermediate Member
    Join Date
    Apr 2012
    Posts
    17
    Rep Power
    3

    Default

    When I log into webmail on the old box, I get all the old emails,documents, briefcase, contacts etc. When I log into webmail on the new box, I get only the new emails, and new docs etc.

    Both machines are authenticating to the same ldap backend running on a separate machine, (I have four machines, one MTA, one LDAP, two maibox).
    The mailboxes have same hostname, but different Ip address.

  7. #17
    muyepaa is offline Intermediate Member
    Join Date
    Apr 2012
    Posts
    17
    Rep Power
    3

    Default

    To log in to old box, I use IP address, to log in to new box I use hostname

  8. #18
    Cine.ZxCommunity's Avatar
    Cine.ZxCommunity is offline Senior Member
    Join Date
    Jul 2011
    Posts
    55
    Rep Power
    3

    Default

    Quote Originally Posted by muyepaa View Post
    Federico.bertola,

    I installed ZeXtras, it has finished running. It has created many files within /opt/zimbra/backup/export/accounts.

    When I tried to list any file eg. #cat ff2883a5-1800-46d1-aa43-3e151fcacc74/account_info somewhere it says zimbraDataSourceLastError":"system failure: Unable to connect to IMAP server:

    See snippet below:

    [{"datasources":[{"objectClass":["zimbraDataSource","zimbraImapDataSource"],"zimbraDataSourceAuthorizationId":"xxx@yyyyy.zz", "zimbraDataSourceConnectionType":"ssl","zimbraData SourceAuthMechanism":"PLAIN","zimbraDataSourcePort ":"993","zimbraDataSourcePassword":"Aahz1PMN/Oh0+cGiAj5ELuEHsDDHu7A9KfZ5v1R7wF3D","zimbraDataSo urceImportOnly":"TRUE","zimbraDataSourceEnabled":" TRUE","zimbraDataSourceType":"imap","zimbraDataSou rceId":"009b0c16-bcce-45fe-986d-fec3f5429575","zimbraDataSourceHost":"10.137.2.7", "zimbraDataSourceFailingSince":"20120406052757Z"," zimbraCreateTimestamp":"20120406052634Z","zimbraDa taSourceUsername":"admin","zimbraDataSourceName":" __imap_import__","zimbraDataSourceFolderId":"1","z imbraDataSourceIsInternal":"TRUE","zimbraDataSourc eLastError":"system failure: Unable to connect to IMAP server: DataSource: { id=009b0c16-bcce-45fe-986d-fec3f5429575, type=imap, isEnabled=true, name=__imap_import__, host=10.137.2.7, port=993, connectionType=ssl, username=admin, folderId=1 }, No route to host"}],....


    I dont know if this how it supposed to work, should I proceed to the destination machined to run the import?
    Hello muyepaa!
    This is not an error per-se, it's an error information stored in the LDAP which probably refers to the datasources created in the new server - since the LDAP is the same, every change on an acount also affects the corresponding account on the other server.
    The situation is kinda messy, but since the relevant - for this particular case - store informations are contained in Zimbra's mysql database I'm almost positive that you'll be able to import your exported data on the new server as long as the export procedure completed correctly (check the proper notification email to see if items have been exported).

    Have a nice day,
    Cine
    Cine - Community Manager - ZeXtras
    www.zextras.com

  9. #19
    justdave is offline Trained Alumni
    Join Date
    Nov 2008
    Location
    Grand Rapids, MI
    Posts
    123
    Rep Power
    6

    Default

    OK, so by "using the same LDAP server" you only mean for authentication, and not Zimbra's internal LDAP? If you were using the same internal LDAP within Zimbra for both servers, then it would not be possible for you to see the old email via the web interface (even on the old server), unless.... both machines think they have the same hostname? Because the name of the server that the user's mailbox is stored on is included in their account record in LDAP, and the MySQL database it tries to connect to to get their message storage is the one on the machine named on their LDAP record.

  10. #20
    muyepaa is offline Intermediate Member
    Join Date
    Apr 2012
    Posts
    17
    Rep Power
    3

    Default

    I dont understand what you mean by zimbra internal ldap. What I have is a multi-server setup in which one machine was installed with the zimbra-ldap package only (this is what am referring to ldap), another machie installed with zimbra-store package, and another machine with MTA.

    Then the zimbra-store machine crashed with more than 250GB of emails. Since I could not repair in good time, I quickly installed a new zimbra-store package on a separate machine to keep email flowing for my users. I assigned the new zimbra-store machine the same original hostname and IP.
    When the crashed zimbra-store was recovered from backup, I gave it new IP to avoid conflict, keeping hostname and everything else unchanged as before. With this setup, am able to login via http to both machines, each one showing different emails, old email on the old server, new emails on the new server. The only problem in the old machine is the imap and nginx are not running.

Page 2 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Old Backup stay in TO_DELETE status and no clearing..
    By bartounet in forum Administrators
    Replies: 0
    Last Post: 10-05-2010, 07:40 AM
  2. admin consol blank after 5.0.3 upgarde
    By maumar in forum Administrators
    Replies: 6
    Last Post: 03-21-2008, 05:16 AM
  3. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 09:56 PM
  4. [SOLVED] Error Installing Zimbra on RHEL 5
    By harris7139 in forum Installation
    Replies: 10
    Last Post: 09-25-2007, 11:39 AM
  5. Replies: 16
    Last Post: 09-07-2006, 06:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •