Results 1 to 2 of 2

Thread: mail filter trigger notification

  1. #1
    sluggo is offline Intermediate Member
    Join Date
    Mar 2012
    Posts
    17
    Rep Power
    3

    Default mail filter trigger notification

    Hi there,

    A quick comment about what a blast I've had building this system and then migrating this client to it over the last week or so.

    I'm running 7.1.4_GA ( need I say Network Edition?), and I set up SMS notification with my cell phone, and what I'd like to do is trigger notifications via email filters, so I know right away when something broke. I've poked around a bit but haven't figured out an easy way to do this. The email warnings and alarms are all in place, and I'm hoping there is a creative way of making this happen. I could have a rule that sends a new message, but how to get it to notify?

    Other than that, I've been able to do pretty much everything I've wanted to up to now.

    Thanks in advance for any suggestions or comments

    Mike

  2. #2
    santosh_rao99 is offline Zimbra Employee
    Join Date
    May 2008
    Posts
    3
    Rep Power
    7

    Default

    Hello Mike,
    The server side implimentation exists however the front end controls for this feature is yet to come. Here is how you use the new actions :

    To notify "test1@domain.com" if the subject contains "test123"

    zmprov -z ma test@domain.com zimbraMailSieveScript
    'require ["fileinto",
    "reject", "tag", "flag", "reply"];
    if anyof (header :contains "subject" "test123") {
    notify "test1@domain.com" "${SUBJECT}" "Hello ${FROM} recieved a message
    from ${TO}\n";
    stop;
    }'

    To "reply" to sender if the subject contains "test123"

    zmprov -z ma test@domain.com zimbraMailSieveScript 'require ["fileinto",
    "reject", "tag", "flag", "reply"];
    if anyof (header :contains "subject" "test123") {
    reply "Hello there, ${TO}\nThank you for your message about ${SUBJECT}\nHere is
    the old body\:\n${BODY}";
    stop;
    }'

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 04-10-2011, 09:14 AM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. Problem with Postfix and MTA
    By ZMilton in forum Administrators
    Replies: 16
    Last Post: 04-16-2008, 06:47 AM
  4. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  5. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •