Results 1 to 7 of 7

Thread: Error found in maillog

  1. #1
    Solt is offline Active Member
    Join Date
    Jun 2011
    Posts
    32
    Rep Power
    4

    Default Error found in maillog

    Hi all,

    I have the same problem in this thread below.
    [SOLVED] ERROR LOG: Name or service not known

    Error message
    Feb 26 05:34:25 ms1 postfix/smtpd[762]: warning: 190.192.19.131: hostname 131-19-192-190.cab.prima.net.ar verification failed: Name or service not known
    Feb 26 05:34:25 ms1 postfix/smtpd[762]: connect from unknown[190.192.19.131]
    Also, there is some message like "connect from Anonymous TLS connection xxxx" and sending email out, and I believe it's the reason why our server always got blocked in some RBLs, any solution for this issue?

    Error Message
    Feb 26 05:26:51 ms1 postfix/smtpd[8275]: connect from unknown[186.43.73.202]
    Feb 26 05:26:52 ms1 postfix/smtpd[8275]: setting up TLS connection from unknown[186.43.73.202]
    Feb 26 05:26:52 ms1 postfix/smtpd[8275]: Anonymous TLS connection established from unknown[186.43.73.202]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Please let me know if you need further information for this, thank you.

    cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    #::1 localhost6.localdomain6 localhost6
    10.0.85.21 ms1.mydomain
    203.xxx.xx.209 ms1.mydomain.com
    cat /etc/resolv.conf
    ; generated by /sbin/dhclient-script
    search mydomain.local
    nameserver 10.0.85.11
    nameserver 203.xxx.xxx.xx
    nameserver 202.xxx.xxx.xx
    dig mydomain mx
    mydomain.local. 3600 IN SOA server.mydomain.local. hostmaster. 8538 900 600 86400 3600

    dig mydomain any
    mydomain.local. 600 IN A 10.0.85.13
    mydomain.local. 600 IN A 10.0.85.11
    mydomain.local. 600 IN A 10.0.85.23
    mydomain.local. 3600 IN NS server.mydomain.local.
    mydomain.local. 3600 IN SOA server.mydomain.local. hostmaster. 8538 900 600 86400 3600

    ;; ADDITIONAL SECTION:
    server.mydomain.local. 3600 IN A 10.0.85.11

    ;; Query time: 1 msec
    ;; SERVER: 10.0.85.11#53(10.0.85.11)
    ;; WHEN: Tue Feb 28 19:06:47 2012
    ;; MSG SIZE rcvd: 164
    Sorry, I am new to this zimbra and linus, thanks very much for your help.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    Your /etchosts & /etc/resolv.conf are both incorrect, go to the Split DNS and review the correct format and contents of those files (or search the forums for the myriad posts on this topic).

    BTW, the title of your post "error found in maillog" doesn't really give much of a description of the problem you've encountered. You should use a title that accurately describes the problem, not something general and vague.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Solt is offline Active Member
    Join Date
    Jun 2011
    Posts
    32
    Rep Power
    4

    Default

    Thanks Phoenix

    Since our mail server is designed for accessing from outside our company without VPN, so I think they (previous administrator) add this 2 lines on /etc/resolv.conf, or is it not necessary?

    nameserver 203.xxx.xxx.xx
    nameserver 202.xxx.xxx.xx

    For /etc/hosts, I have to put mail after the server name?

    127.0.0.1 localhost.localdomain localhost
    10.0.85.21 ms1.mydomain mail
    203.xxx.xx.209 ms1.mydomain.com mail

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    [QUOTE=Solt;237436]Since our mail server is designed for accessing from outside our company without VPN, so I think they (previous administrator) add this 2 lines on /etc/resolv.conf, or is it not necessary? [/No, they're not necessary.

    Quote Originally Posted by Solt View Post
    For /etc/hosts, I have to put mail after the server name?
    No, that's not correct - the hostname of your server isn't "mail" it's ms1 in your example. You also need to remove the last line in your example, you only need the lines for the loopback and the LAN IP.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Solt is offline Active Member
    Join Date
    Jun 2011
    Posts
    32
    Rep Power
    4

    Smile

    Got it and thank you very much, I will change it as below (After office hour), and will it solve the anonymous TLS and Name or service not known issue?

    cat /etc/hosts
    Code:
    127.0.0.1 localhost.localdomain localhost
    10.0.85.21 ms1.mydomain
    cat /etc/resolv.cf
    Code:
    search mydomain.local
    nameserver 10.0.85.11

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    Quote Originally Posted by Solt View Post
    Got it and thank you very much, I will change it as below (After office hour), and will it solve the anonymous TLS and Name or service not known issue?
    You've not got the hosts file quite correct.

    It should be in the following format:

    Code:
    127.0.0.1 localhost.localdomain localhost
    10.0.85.21 ms1.mydomain.com ms1
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Solt is offline Active Member
    Join Date
    Jun 2011
    Posts
    32
    Rep Power
    4

    Default



    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to keep maillog in zimbra
    By tutu4adrian in forum Administrators
    Replies: 1
    Last Post: 10-12-2006, 09:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •