Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 32 to 64 bit Upgrade issue - BES Searcher password

  1. #1
    Cryophallion is offline Senior Member
    Join Date
    Mar 2007
    Location
    New England
    Posts
    55
    Rep Power
    8

    Default 32 to 64 bit Upgrade issue - BES Searcher password

    I am trying to test out a move from Ubuntu 8.04 32 bit to 10.04 64 bit. Due to a hard drive failure, I am running the old version off a virtual machine while I do the tests, but I'd like to get up and running on the server ASAP.

    Version of zimbra is current version (7.1.4) on all versions.

    I followed the instructions on the wiki, but only afterwards realized that the mail port had been 81 on the old version, but set to 80 in the new version, which is why I assumed I got a zmmailboxdctl is not running error when I started up the new instance.

    I tried to us zmprov to fix this, but I got the following error:
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)


    I decided to do an "upgrade" to redo the settings, but now when it gets to that part, it gives me the asterisks next to the ldap bes searcher password saying it is unverified, and nothing I try works.

    Can anyone help get me over this hurdle to get back up and running?
    Last edited by Cryophallion; 02-06-2012 at 07:48 AM.

  2. #2
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,271
    Rep Power
    10

    Default

    Did you use the menu to set a password for it?
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  3. #3
    Cryophallion is offline Senior Member
    Join Date
    Mar 2007
    Location
    New England
    Posts
    55
    Rep Power
    8

    Default

    I tried, but it kept labeling it "unverified" I believe. I'm trying for a third time tomorrow. I think that that may be the only password that is not in my old xml settings, but it is still extremely frustrating.

  4. #4
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,271
    Rep Power
    10

    Default

    Ok, interesting. :/ Do you know what it is logging in the setup log in /tmp when you set a value for it? I thought this was fixed in 7.1.3 (bug#64401)
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  5. #5
    Cryophallion is offline Senior Member
    Join Date
    Mar 2007
    Location
    New England
    Posts
    55
    Rep Power
    8

    Default

    Below is the output. I DID fix the main issue mentioned above (certs issues), but I decided to test if this bug still exists.

    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_starttls_supported=1.
    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for zimbra_require_interprocess_security=1.
    Tue Feb 7 09:45:04 2012 Verified uid=zmamavis,cn=appaccts,cn=zimbra on mail.example.com.
    Tue Feb 7 09:45:04 2012 Checking ldap on mail.example.com:389
    Tue Feb 7 09:45:04 2012 Verified ldap running at ldap://mail.example.com:389
    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_url=ldap://mail.example.com:389.
    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_starttls_supported=1.
    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for zimbra_require_interprocess_security=1.
    Tue Feb 7 09:45:04 2012 Verified uid=zimbra,cn=admins,cn=zimbra on mail.example.com.
    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for zimbra_ldap_password=maxum1.
    Tue Feb 7 09:45:04 2012 Checking ldap on mail.example.com:389
    Tue Feb 7 09:45:04 2012 Unable to bind to ldap://mail.example.com:389 with user uid=zmbes-searcher,cn=appaccts,cn=zimbra:
    Tue Feb 7 09:45:04 2012 Couldn't bind to mail.example.com as uid=zmbes-searcher,cn=appaccts,cn=zimbra
    Tue Feb 7 09:45:04 2012 Checking ldap on mail.example.com:389
    Tue Feb 7 09:45:04 2012 Verified ldap running at ldap://mail.example.com:389
    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_url=ldap://mail.example.com:389.
    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_starttls_supported=1.
    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for zimbra_require_interprocess_security=1.
    Tue Feb 7 09:45:04 2012 Verified uid=zmpostfix,cn=appaccts,cn=zimbra on mail.example.com.
    Tue Feb 7 09:45:04 2012 Checking ldap on mail.example.com:389
    Tue Feb 7 09:45:04 2012 Verified ldap running at ldap://mail.example.com:389
    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_url=ldap://mail.example.com:389.
    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for ldap_starttls_supported=1.
    Tue Feb 7 09:45:04 2012 Skipping update of unchanged value for zimbra_require_interprocess_security=1.
    Tue Feb 7 09:45:04 2012 Verified uid=zmamavis,cn=appaccts,cn=zimbra on mail.example.com.
    Tue Feb 7 09:45:05 2012 checking isEnabled zimbra-ldap
    Tue Feb 7 09:45:05 2012 zimbra-ldap is enabled

  6. #6
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,271
    Rep Power
    10

    Default

    You can get around this for now by finding the following code block in zmsetup.pl:

    Code:
      # check zmbes searcher binding to the master
      if ($config{LDAPHOST} eq $config{HOSTNAME}) {
        if ($config{ldap_bes_searcher_password} eq "") {
          detail ("BES searcher configuration not complete\n");
          $failedcheck++;
        }
        my $binduser = "uid=zmbes-searcher,cn=appaccts,$config{ldap_dit_base_dn_config}";
        if (checkLdapBind($binduser,$config{ldap_bes_searcher_password})) {
          detail ("Couldn't bind to $config{LDAPHOST} as $binduser\n");
          $config{LDAPBESSEARCHSET} = "Not Verified";
          $failedcheck++;
        } else {
          detail ("Verified $binduser on $config{LDAPHOST}.\n");
          $config{LDAPBESSEARCHSET} = "set";
        }
      }
    Remove the if... through else ... lines, and the first } after the else line, that'll skip checking that it is valid, and let you proceed with the install.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  7. #7
    ekkas is offline Special Member
    Join Date
    Feb 2010
    Location
    South Africa
    Posts
    107
    Rep Power
    5

    Default

    Quote Originally Posted by quanah View Post
    You can get around this for now by finding the following code block in zmsetup.pl:
    I had same issue upgrading from 7.1.3 to 7.2.0
    Stopping installation when I got stuck, edited file mentioned above, then ran it seemed to complete install.


    Ekkas

  8. #8
    batfastad is offline Elite Member
    Join Date
    Aug 2007
    Location
    London, UK
    Posts
    296
    Rep Power
    7

    Default

    Just tried to upgrade from 7.2.0 to 7.2.3 and this problem nailed me for some reason.
    Hacking /opt/zimbra/libexec/zmsetup.pl as above has not worked!!!
    Last edited by batfastad; 03-24-2013 at 05:15 PM.
    My Zimbra Bugs Wishlist: 16411, 24567, 35676, 36430, 37770, 41872, 43733, 44384, 46383, 47759
    And a way to associate mailto: handlers with a Zimbra Prism webapp

  9. #9
    ae-dlund is offline Starter Member
    Join Date
    Apr 2011
    Posts
    1
    Rep Power
    4

    Default

    After coming upon this issue myself I worked with Zimbra support to resolve this.

    I noticed that this is the first thread that comes up in a google search regarding this issue so I'm putting the fix here for anyone that comes upon it.

    When you get to the point in the install where it says the BES Searcher is "Not Verified", open another terminal window and run this command as the zimbra user: zmldappasswd -b password

    Then go back to your install terminal screen and address the unconfigured BES searcher password (press enter to confirm the password it shows for BES Searcher).

    Press 'r' to return to the previous menu and configuration should be complete.

  10. #10
    MACscr is offline Special Member
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default

    Quote Originally Posted by ae-dlund View Post
    After coming upon this issue myself I worked with Zimbra support to resolve this.

    I noticed that this is the first thread that comes up in a google search regarding this issue so I'm putting the fix here for anyone that comes upon it.

    When you get to the point in the install where it says the BES Searcher is "Not Verified", open another terminal window and run this command as the zimbra user: zmldappasswd -b password

    Then go back to your install terminal screen and address the unconfigured BES searcher password (press enter to confirm the password it shows for BES Searcher).

    Press 'r' to return to the previous menu and configuration should be complete.
    why after all this time, does this bug still exist? Its extremely frustrating having to deal with it after each upgrade. Especially since i do not even use BES!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 05-11-2012, 02:16 PM
  2. Upgrade from 6.0.10 to 7 beta4
    By alex70 in forum Installation
    Replies: 14
    Last Post: 05-11-2012, 02:02 PM
  3. [SOLVED] Zimbra 7.0.1 Database Issue after upgrade
    By n.bochev in forum Administrators
    Replies: 3
    Last Post: 03-16-2011, 01:07 AM
  4. Replies: 6
    Last Post: 03-14-2011, 04:21 AM
  5. [SOLVED] New zcs 7 install : database errors founds
    By dkbk in forum Administrators
    Replies: 4
    Last Post: 03-01-2011, 06:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •