Results 1 to 1 of 1

Thread: No.Such.Blob in Mailbox Log

  1. #1
    carnold is offline Advanced Member
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default No.Such.Blob in Mailbox Log

    Release 7.1.3_GA_3346.SLES11_64_20110930001521 SLES11_64 FOSS edition.
    As the subject says. Here is a snipit from the mailbox log:
    Code:
    2012-01-05 09:54:09,893 WARN  [ImapSSLServer-717] [name=jamato@domainnc.com;mid=30;ip=99.43.176.114;] imap - ignoring error during UID FETCH: 
    com.zimbra.cs.mailbox.MailServiceException: No such blob: mailbox=30, item=8620, change=96503
    ExceptionId:ImapSSLServer-717:1325775249893:11f3532ca095ef5e
    Code:mail.NO_SUCH_BLOB
    	at com.zimbra.cs.mailbox.MailServiceException.NO_SUCH_BLOB(MailServiceException.java:269)
    	at com.zimbra.cs.mailbox.MailItem.getBlob(MailItem.java:971)
    	at com.zimbra.cs.mailbox.MessageCache.fetchFromStore(MessageCache.java:224)
    	at com.zimbra.cs.mailbox.MessageCache.getMimeMessage(MessageCache.java:160)
    	at com.zimbra.cs.mailbox.Message.getMimeMessage(Message.java:427)
    	at com.zimbra.cs.imap.ImapMessage.getMimeMessage(ImapMessage.java:225)
    	at com.zimbra.cs.imap.ImapHandler.fetch(ImapHandler.java:3359)
    	at com.zimbra.cs.imap.ImapHandler.doFETCH(ImapHandler.java:3179)
    	at com.zimbra.cs.imap.ImapHandler.executeRequest(ImapHandler.java:425)
    	at com.zimbra.cs.imap.TcpImapHandler.processCommand(TcpImapHandler.java:111)
    	at com.zimbra.cs.tcpserver.ProtocolHandler.processConnection(ProtocolHandler.java:199)
    	at com.zimbra.cs.tcpserver.ProtocolHandler.run(ProtocolHandler.java:140)
    	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
    	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
    	at java.lang.Thread.run(Thread.java:662)
    2012-01-05 09:54:51,927 INFO  [ImapSSLServer-716] [name=jamato@domainnc.com;ip=99.43.176.114;] imap - dropping connection for user jamato@domainnc.com (LOGOUT)
    I also can not check my email from my iphone. I can login using the web interface and mail is being sent and received. These may not be related.
    I ahve followed this:
    http://wiki.zimbra.com/index.php?tit...s-No-Such-Blob
    and the perms fix just keeps finding perms problems (the same ones):
    Code:
    /opt/zimbra/libexec/zmfixperms --verbose --extended
    Fixing ownership and permissions on /opt/zimbra/conf                  
    Fixing permissions on /opt/zimbra/conf/spamassassin                   
    Fixing ownership and permissions on /opt/zimbra/conf/ldap-scm.cf      
    Fixing ownership and permissions on /opt/zimbra/conf/ldap-transport.cf
    Fixing ownership and permissions on /opt/zimbra/conf/ldap-vad.cf      
    Fixing ownership and permissions on /opt/zimbra/conf/ldap-vam.cf      
    Fixing ownership and permissions on /opt/zimbra/conf/ldap-vmd.cf      
    Fixing ownership and permissions on /opt/zimbra/conf/ldap-vmm.cf      
    Fixing permissions and ownership on /opt/zimbra/conf/1smtpd.key       
    Fixing permissions and ownership on /opt/zimbra/conf/nginx.key        
    Fixing permissions and ownership on /opt/zimbra/conf/slapd.key        
    Fixing permissions and ownership on /opt/zimbra/conf/smtpd.key        
    Fixing ownership and permissions on /var/log/zimbra.log               
    Fixing ownership and permissions on /opt/zimbra/amavisd               
    Fixing ownership and permissions on /opt/zimbra/aspell                
    Fixing ownership and permissions on /opt/zimbra/bdb                   
    Fixing ownership and permissions on /opt/zimbra/cbpolicyd             
    Fixing ownership and permissions on /opt/zimbra/clamav                
    Fixing ownership and permissions on /opt/zimbra/curl                  
    Fixing ownership and permissions on /opt/zimbra/cyrus-sasl            
    Fixing ownership and permissions on /opt/zimbra/altermime             
    Fixing ownership and permissions on /opt/zimbra/dspam                 
    Fixing ownership and permissions on /opt/zimbra/heimdal
    Fixing ownership and permissions on /opt/zimbra/httpd
    Fixing ownership and permissions on /opt/zimbra/libtool
    Fixing ownership and permissions on /opt/zimbra/mysql
    Fixing ownership and permissions on /opt/zimbra/net-snmp
    Fixing ownership and permissions on /opt/zimbra/openldap
    Fixing ownership and permissions on /opt/zimbra/openssl
    Fixing ownership and permissions on /opt/zimbra/rsync
    Fixing ownership and permissions on /opt/zimbra/snmp
    Fixing ownership and permissions on /opt/zimbra/tcmalloc
    Fixing ownership and permissions on /opt/zimbra/zimbramon/bin
    Fixing ownership and permissions on /opt/zimbra/zimbramon/crontabs
    Fixing ownership and permissions on /opt/zimbra/zimbramon/rrdtool
    Fixing ownership and permissions on /opt/zimbra/zimbramon/pylibs
    Fixing ownership and permissions on /opt/zimbra/jdk1.6.0_26
    Fixing ownership and permissions on /opt/zimbra/lib
    Fixing ownership and permissions on /opt/zimbra/db
    Fixing ownership and permissions on /opt/zimbra/mta
    Fixing ownership and permissions on /opt/zimbra/cyrus-sasl
    Fixing ownership and permissions on /opt/zimbra/data/amavisd
    Fixing ownership and permissions on /opt/zimbra/jetty
    Fixing ownership and permissions on /opt/zimbra/ssl
    Fixing ownership and permissions on /opt/zimbra/openldap
    Fixing ownership and permissions on /opt/zimbra/snmp/var
    Fixing ownership and permissions on /opt/zimbra/logger/db
    Fixing ownership and permissions on /opt/zimbra/clamav/db
    Fixing ownership and permissions on /opt/zimbra/zmstat
    Fixing ownership and permissions on /opt/zimbra/zimbramon/lib
    Fixing ownership and permissions on /opt/zimbra/postfix
    Fixing ownership and permissions on /opt/zimbra/data/postfix
    Fixing ownership of /opt/zimbra/index
    Fixing ownership of /opt/zimbra/backup
    Fixing ownership of /opt/zimbra/redolog
    Fixing ownership of /opt/zimbra/store
    Should zimbra be shut down first, then run fix perms?
    I shut down zimbra and ran the fix perms command as root and it continues to find the same problems over and over, never fixing them (or fixing them and something changes them back).
    Last edited by carnold; 01-05-2012 at 10:05 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The installer was interrupted...
    By spiderbo in forum Zimbra Connector for Outlook
    Replies: 9
    Last Post: 05-23-2013, 06:33 AM
  2. Errors installing Outlook Connector
    By Tim G in forum Zimbra Connector for Outlook
    Replies: 57
    Last Post: 05-05-2011, 02:27 PM
  3. Replies: 7
    Last Post: 02-27-2008, 05:17 PM
  4. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 06:53 PM
  5. Error Installing Outlook Connector
    By DanO in forum Zimbra Connector for Outlook
    Replies: 17
    Last Post: 08-28-2007, 09:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •