Results 1 to 8 of 8

Thread: Latest sa and sa-update

  1. #1
    nirg is offline Member
    Join Date
    Nov 2005
    Posts
    11
    Rep Power
    9

    Default Latest sa and sa-update

    Hi,

    I would like to update the SpamAssassin install in Zimbra (4.0.2).
    From what I can tell, my current version is 3.0.1, while there is a much newer version (3.1.7) released - more importantly the newer releases include the sa-update tool, which updates sa rules from specific channels.

    That sounds good especially b/c the RulesDuJour tool can't be found anywhere (the site hosting it seems to be down). Anyhow - would someone more skilled care to comment about how to do this without breaking anything ? it doesn't seem to be as simple as other components (i.e clamav just link to a newer version).

    Any comments are much appreciated..
    nirg

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    The easiest thing to would be to upgrade to the latest release of Zimbra, that has a more recent version of SP available.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    rhostager is offline Senior Member
    Join Date
    Nov 2005
    Posts
    61
    Rep Power
    9

    Default

    Do you mean Zimbra 4.03 or the beta 4.5?

    I am trying to deal with issues of authenticated clients using thunderbird or outlook getting RCVD_IN_NJABL_DUL=1.946, RCVD_IN_SORBS_DUL=2.046, SPF_FAIL=2.5

    This problem is covered here . It looks like Postfix 2.3.0 or greater and SA 3.1.4 or greater allow you to deal with this. The sa-update feature also looks nice.

    Also, how do you tell what version of SpamAssassin Zimbra is using?

    - Rob
    Last edited by rhostager; 11-12-2006 at 05:02 PM.

  4. #4
    nirg is offline Member
    Join Date
    Nov 2005
    Posts
    11
    Rep Power
    9

    Default

    just type

    spamassassin -V

  5. #5
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    zimbra doesnt come with the SA binaries unfortunately.

  6. #6
    nirg is offline Member
    Join Date
    Nov 2005
    Posts
    11
    Rep Power
    9

    Default

    Well - this last post turned my attention to the fact that spamassassin is not packaged with zimbra.. so far so good..

    My current install is spamassassin-3.0.1 - before I go ahead and break my running system , does anyone know which is the highest version supported by Zimbra 4.0.2 ? Is it sa-3.0.6 or is it 3.1.7 ?

    Or does it have no impact at all ? and given that the upgrade can be done, do I just overwrite the sa configuration in the zimbra /conf/spamassassin dir ?

    Can anyone shed some light ?
    nirg

    p.s. congrats on the WSJ mention - the users will just come flocking now

  7. #7
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    uh no no, zimbra does come with most of SA. it's mostly written in perl and the perl libs are in /opt/zimbra/lib, but the binaries like spamassassin, saupdate etc aren't included. you can't easily replace the existing version as it's not in the normal place.

  8. #8
    nirg is offline Member
    Join Date
    Nov 2005
    Posts
    11
    Rep Power
    9

    Default

    Hi,

    For everyone who's been looking for the rules du jour script - the site that hosted the script and wiki is down, but you can get the script at:
    http://sandgnat.com/rdj/rules_du_jour

    And there's a nice wiki available at:
    http://www.5dollarwhitebox.org/wiki/..._Configuration

    I'm planning to integrate this with my 4.0.3 install and will post details - if anyone has any tips, they are more than welcome

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •