Results 1 to 5 of 5

Thread: http 500 (Internal Server Error) codes in access_log

  1. #1
    mattg1 is offline Active Member
    Join Date
    Jun 2009
    Posts
    31
    Rep Power
    6

    Default http 500 (Internal Server Error) codes in access_log

    Each day we see several thousand http error codes in Zimbra's access_log for various types of soap POST requests. E.g.
    Code:
    "POST /service/soap/SyncRequest HTTP/1.1" 500 3474
    "POST /Microsoft-Server-ActiveSync?User=example.net%5Cuserid&Cmd=Sync&DeviceId=67766482845485360595252954519&DeviceType=Android HTTP/1.1" 500 1421
    "POST /service/soap/SyncGalRequest HTTP/1.1" 500 3386
    500 is an http code for "Internal Server Error", so I'm wondering what kind of error Zimbra is experiencing when it logs these entries. Seems to occur for ZCO, Apple, Android, etc. sync clients. Also the Zimbra web client.

    Thanks...

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,581
    Rep Power
    57

    Default

    Quote Originally Posted by mattg1 View Post
    Each day we see several thousand http error codes in Zimbra's access_log for various types of soap POST requests.
    Has this just started happening or has it been happening for a while? Can you tie this to any specific event such as an upgrade etc.?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    mattg1 is offline Active Member
    Join Date
    Jun 2009
    Posts
    31
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Has this just started happening or has it been happening for a while? Can you tie this to any specific event such as an upgrade etc.?
    Not really. Looking at the 30 days of logs currently available, the numbers of occurrences were comparable before and after our upgrade from ZCS 6.0.14 to 7.1.3 (which occurred 2011-10-22) :
    Code:
    # for FILE in access_log.2011-*; do echo -n "$FILE  ";  grep "HTTP/1\.1\" 500 " $FILE | wc -l; done
    access_log.2011-10-17  5166
    access_log.2011-10-18  6116
    access_log.2011-10-19  7254
    access_log.2011-10-20  5290
    access_log.2011-10-21  5724
    access_log.2011-10-22  1830
    access_log.2011-10-23  2020
    access_log.2011-10-24  6964
    access_log.2011-10-25  5732
    access_log.2011-10-26  8111
    access_log.2011-10-27  7988
    access_log.2011-10-28  7353
    access_log.2011-10-29  3306
    access_log.2011-10-30  2420
    access_log.2011-10-31  7082
    access_log.2011-11-01  8725
    access_log.2011-11-02  10466
    access_log.2011-11-03  9584
    access_log.2011-11-04  7922
    access_log.2011-11-05  3428
    access_log.2011-11-06  6854
    access_log.2011-11-07  9973
    access_log.2011-11-08  3118
    access_log.2011-11-09  9550
    access_log.2011-11-10  7771
    access_log.2011-11-11  1684
    access_log.2011-11-12  1237
    access_log.2011-11-13  1289
    access_log.2011-11-14  8668
    access_log.2011-11-15  9073
    access_log.2011-11-16  6057
    access_log.2011-11-17  1827
    This is on a beefy server with 1300 users.
    Last edited by mattg1; 11-17-2011 at 09:13 AM. Reason: apostrophe

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,581
    Rep Power
    57

    Default

    Is this a multi-domain server or single domain? Is the public service hostname set for this server? Any proxy installed? Is it a single server or multi-server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    mattg1 is offline Active Member
    Join Date
    Jun 2009
    Posts
    31
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Is this a multi-domain server or single domain? Is the public service hostname set for this server? Any proxy installed? Is it a single server or multi-server?
    No proxying. Single server, single domain (with 4 domain aliases). The public service hostname is not set.

    This domain also has 2 virtual host names configured which correspond to alternate DNS names for the server which people might use to access ZCS services.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to: cold standby server (no cluster)
    By fisch09 in forum Installation
    Replies: 50
    Last Post: 02-18-2014, 10:51 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. Please help
    By scott_summers in forum Administrators
    Replies: 0
    Last Post: 09-26-2007, 11:11 PM
  4. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  5. Internal Only email server
    By AstainHellbring in forum Administrators
    Replies: 2
    Last Post: 01-05-2006, 04:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •