Results 1 to 4 of 4

Thread: Problem restoring from Backup

  1. #1
    StuMac is offline Member
    Join Date
    May 2008
    Location
    Scotland
    Posts
    11
    Rep Power
    7

    Default Problem restoring from Backup

    Hi All,

    I'm running Zimbra 4.5.10 on Centos 5
    Today my mailserver named mailserver1 died. I have a backup of the entire /opt/zimbra folder on an external hdd.

    I copied this folder to my backup mailserver - mailserver2 which is identical to mailserver1 (apart from ip address and host name) which already had the same version of zimbra installed. I ran zmfixperms -extended -verbose on the folder that was copied over.

    I also changed (in centos) the ip address to that of mailserver1 and the hostname from mailserver2 to mailserver1.

    When I start Zimbra (zmcontrol start)
    Everything seems to start ok. however zmcontrol status says

    Host mailserver1.mydomain.local
    ldap Running
    logger Stopped
    logmysql.server is not running
    mailbox Stopped
    mysql.server is not running
    tomcat is not running
    mta Running
    snmp Running
    spell Running
    stats Stopped

    Can someone point me in the right direction?

    Many Thanks

    Stu
    Stu.
    -- Every solution creates another problem!

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    What errors do you see in the log files when you start Zimbra?

    I guess I'd have to add, that's a very old version of Zimbra and you really should consider upgrading.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    StuMac is offline Member
    Join Date
    May 2008
    Location
    Scotland
    Posts
    11
    Rep Power
    7

    Default

    Hi Bill,

    Thanks for getting back to me.
    Here's what I'm seeing in the mailbox.log:
    011-11-17 14:06:03,299 INFO [main] [] soap - Servlet SoapServlet starting up
    2011-11-17 14:06:03,371 INFO [main] [] soap - Adding service AccountService to SoapServlet
    2011-11-17 14:06:03,432 INFO [main] [] soap - Adding service MailService to SoapServlet
    2011-11-17 14:06:03,519 INFO [main] [] soap - Adding service IMService to SoapServlet
    2011-11-17 14:06:03,524 INFO [main] [] misc - version=4.5.10_GA_1575.RHEL5 release=20071117121632 builddate=20071117-1218 buildhost=build10.re.zimbra.com
    2011-11-17 14:06:03,534 INFO [main] [] misc - LANG environment is set to: en_US.UTF-8
    2011-11-17 14:06:03,574 INFO [main] [] DbPool - Setting mysql connector property: maxActive=12
    2011-11-17 14:06:08,061 FATAL [main] [] system - Config initialization failed
    com.zimbra.common.service.ServiceException: system failure: getting database connection
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:165)
    at com.zimbra.cs.db.DbPool.getConnection(DbPool.java: 279)
    at com.zimbra.cs.util.Config.init(Config.java:60)
    at com.zimbra.cs.util.Config.initConfig(Config.java:8 7)
    at com.zimbra.cs.util.Config.getString(Config.java:99 )
    at com.zimbra.cs.db.Versions.checkDBVersion(Versions. java:75)
    at com.zimbra.cs.db.Versions.checkVersions(Versions.j ava:71)
    at com.zimbra.cs.util.Zimbra.startup(Zimbra.java:86)
    at com.zimbra.soap.SoapServlet.init(SoapServlet.java: 106)
    at javax.servlet.GenericServlet.init(GenericServlet.j ava:211)
    at org.apache.catalina.core.StandardWrapper.loadServl et(StandardWrapper.java:1105)
    at org.apache.catalina.core.StandardWrapper.load(Stan dardWrapper.java:932)
    at org.apache.catalina.core.StandardContext.loadOnSta rtup(StandardContext.java:3915)
    at org.apache.catalina.core.StandardContext.start(Sta ndardContext.java:4176)
    at org.apache.catalina.core.ContainerBase.addChildInt ernal(ContainerBase.java:759)
    at org.apache.catalina.core.ContainerBase.addChild(Co ntainerBase.java:739)
    at org.apache.catalina.core.StandardHost.addChild(Sta ndardHost.java:524)
    at org.apache.catalina.startup.HostConfig.deployDirec tory(HostConfig.java:910)
    at org.apache.catalina.startup.HostConfig.deployDirec tories(HostConfig.java:873)
    at org.apache.catalina.startup.HostConfig.deployApps( HostConfig.java:474)
    at org.apache.catalina.startup.HostConfig.start(HostC onfig.java:1118)
    at org.apache.catalina.startup.HostConfig.lifecycleEv ent(HostConfig.java:310)
    at org.apache.catalina.util.LifecycleSupport.fireLife cycleEvent(LifecycleSupport.java:119)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1020)
    at org.apache.catalina.core.StandardHost.start(Standa rdHost.java:718)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1012)
    at org.apache.catalina.core.StandardEngine.start(Stan dardEngine.java:442)
    at org.apache.catalina.core.StandardService.start(Sta ndardService.java:450)
    at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
    at org.apache.catalina.startup.Catalina.start(Catalin a.java:551)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:275)
    at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:406)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at com.zimbra.cs.launcher.TomcatLauncher.start(Tomcat Launcher.java:42)
    at com.zimbra.cs.launcher.TomcatLauncher.main(TomcatL auncher.java:64)
    Caused by: com.mysql.jdbc.exceptions.MySQLNonTransientConnect ionException: Server connection failure during transaction. Due to underlying exception: 'java.net.SocketException: java.net.ConnectException: Connection refused'.

    ** BEGIN NESTED EXCEPTION **
    I'm guessing this is because MySql isn't running?

    I don't have much experience with Zimbra as it has been running faultlessly since it was installed and probably still would be if the hardware hadn't failed.

    Can you give me some further guidance,
    Many Thanks

    Stu.
    Stu.
    -- Every solution creates another problem!

  4. #4
    StuMac is offline Member
    Join Date
    May 2008
    Location
    Scotland
    Posts
    11
    Rep Power
    7

    Default

    Solved it. The localhost entry was missing in the hosts file.
    Stu.
    -- Every solution creates another problem!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 39
    Last Post: 09-04-2012, 11:18 PM
  2. Zimbra Crashes every day
    By feiticeir0 in forum Administrators
    Replies: 10
    Last Post: 10-13-2011, 06:53 AM
  3. Problem with backup, sometimes
    By manowar in forum Administrators
    Replies: 0
    Last Post: 01-11-2008, 05:22 AM
  4. Replies: 0
    Last Post: 04-26-2007, 11:53 AM
  5. NE Full backup problem
    By Matt in forum Administrators
    Replies: 4
    Last Post: 11-24-2006, 03:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •