Results 1 to 3 of 3

Thread: Zimbra, Xen5.6SP2, Netapp - Best way to backup

  1. #1
    leog21 is offline Special Member
    Join Date
    Sep 2007
    Posts
    123
    Rep Power
    7

    Default Zimbra, Xen5.6SP2, Netapp - Best way to backup

    Hi,

    We have Zimbra NE on Xen5.6SP2 (upgrading to 6 soon) hosted on a Netapp LUN over Fiber Channel. We already have NE backups but I'd like to use the snapshot features of the SAN. In order to have clean snapshots, zimbra mysql must be paused or stopped.

    Currently I'm doing this with a script, where it does a simple zmcontrol stop, ssh into netapp, runs a snapshot command, zmcontrol start, but I'm wondering if anybody else is doing it in a different way?


    Thanks,
    Leo

  2. #2
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,366
    Rep Power
    10

    Default

    Lots of flame wars on SAN-level snapshots versus XenServer snapshots...

    In our experience, XenServer snapshots use more storage space (and take longer to create, unless your XenCenter machine is on the same bandwidth network as your SAN) but are more readily accessible when things go wrong.

    Since SAN prices have come way down over the past few years, we allocate near 100% of the SAN's storage as SRs to compensate somewhat and do snapshots only in XenServer.

    If however, the client is doing SAN replication over a WAN, then we also include some SAN-level snapshots.

    Still, disk is disk, and disk is ignorant of data stored in RAM, so unless you flush everything in RAM to disk and stop changes from being made, your snapshots may/will not be internally logically consistent and therefore not restorable. The safest way to quiesce a Zimbra system is, unfortunately, "zmcontrol stop".

    Your other option is to forget about snapshots and instead take NE Incremental backups several times throughout the day. Really, the tricky bit to backing up a live system is having MySQL and the contents of the mailstore in the backup in alignment.

    Hope that helps,
    Mark

  3. #3
    leog21 is offline Special Member
    Join Date
    Sep 2007
    Posts
    123
    Rep Power
    7

    Default

    Thank you for your reply Mark.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  2. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  3. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 03:30 PM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •