Results 1 to 9 of 9

Thread: Migration from ZCS 5.0.18(32) to ZCS 7.1.2(64)

  1. #1
    marlonrstk is offline Banned
    Join Date
    Dec 2010
    Posts
    7
    Rep Power
    0

    Default Migration from ZCS 5.0.18(32) to ZCS 7.1.2(64)

    Hello,

    I have a centos 32 bits server with zcs 5.0.18 that is working very fine and i want to migrate to last version
    of zimbra, because my version is very old and is still 32 bits.

    I already tested but without sucessfull and I want to know if I am in the right way or not.

    In my first tests i installed the zcs 5.0.18 (32) and migrate until 5.0.26_GA_3365(32) that worked, but when i try
    to migrate to 6.0.0_GA_1802 i received a error.

    I was Reading at zimbra Documentations i noticed that have there is problems between LDAP 5X.X and 6.X.X but i want to know what i can do to do this migration


    Thanks for while.
    Marlon Brandão Coutinho

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,474
    Rep Power
    56

    Default

    This question has been answered many times in the forum. Go to the wiki (link at the top of this page) and search fro the article on moving a Zimbra server from 32bit to 64bit then follow the instructions in that article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    marlonrstk is offline Banned
    Join Date
    Dec 2010
    Posts
    7
    Rep Power
    0

    Default

    Hello Bill,
    I am searching a answer for this question in forum and wiki, and i found some
    articles and i am trying to do this migration.

    Today i am in 5.0.18(32) what way do you recomend to me do this migration, first migrate to
    5.0.18(64) or migrate to releases more recents and after migrate to a 64 bits
    version?

    Regards

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,474
    Rep Power
    56

    Default

    My choice would be to upgrade your current version to the most recent one, check the release notes for details of the upgrade path. Make sure you take a full backup of your /top/zimbra directory structure (there are wiki articles and forum threads on backup procedures) then do the move to a new server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    marlonrstk is offline Banned
    Join Date
    Dec 2010
    Posts
    7
    Rep Power
    0

    Default

    Y was doing this on my virtual Box.
    I upgraded my version from 5.0.18 to 5.26(32), but when i tried tu upgrade to 6.0.0 my server does not work more.
    There is some tip to upgrade to 6.0.0 ?

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,474
    Rep Power
    56

    Default

    Quote Originally Posted by marlonrstk View Post
    I upgraded my version from 5.0.18 to 5.26(32), but when i tried tu upgrade to 6.0.0 my server does not work more.
    I've no idea what you mean by 'does not work', you need to look in the log files to see what the problem is.

    Quote Originally Posted by marlonrstk View Post
    There is some tip to upgrade to 6.0.0 ?
    No, nothing different that normal but do make sure you're read the release notes (read them ind etail) for each version you upgrade to.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    marlonrstk is offline Banned
    Join Date
    Dec 2010
    Posts
    7
    Rep Power
    0

    Default

    I will do this upgrade from 5.0.18 to 5.0.26 again
    and when i do the upgrade to 6.0.0 I post here the errors on log.

    Thanks for while.

  8. #8
    marlonrstk is offline Banned
    Join Date
    Dec 2010
    Posts
    7
    Rep Power
    0

    Default

    Hello Bill

    I got migrate from 5.0.18/32 to 7.1.3/64.

    I read the release notes of all releases to do this tests and it worked.

    Here is my way.
    All steps i do in my VM to test.

    1) First of all i prepared a new server with dns, sendmail stopped e all packages needed.


    2)I installed a new server with centos 5.7/32 bits and zimbra 5.0.18(same version of my hot server).
    cmd = ./install.sh --platform-override -s

    3) remove the folder /opt/zimbra
    cmd = rm -rf /opt/zimbra

    4) rsync /opt/zimbra between server whith rsync
    cmd= rsync .......

    5) reinstall zimbra again with the same version
    cmd = ./install.sh --platform-override

    6) From here i installed the versions in a sequence that follow
    5.0.18 to 5.0.19
    5.0.19 to 6.0.2
    6.0.2 to 6.0.14

    cmd = ./install.sh --platform-override



    7) when i finished the version 6.0.14 I Installed the ZExtra_migration_tool_1.0._1 and did a Backup of my server
    with this tool.

    8) I Installed a new Server with centos 5.7/64b and Zimbra 7.1.3/64b with zextra_suite_1.0.1.

    9) at Zimbra admin page i restore the files that zextra_migration_1_0_1 generated.

    10) finished.

    Some considerations about this path?

    This week i called to my support to ask for this procedures to migrate, and they coments that this way i can
    not
    back to a previous release if some problems happen.

    There is a option to export all Mailbox/Agenda/Documents/Files/Tasks/Contacts and import at previous release?

    There is a option to migrate without do this sequence of instalations?


    Thanks for the help.

    Marlon

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,474
    Rep Power
    56

    Default

    Quote Originally Posted by marlonrstk View Post
    This week i called to my support to ask for this procedures to migrate, and they coments that this way i can
    not
    back to a previous release if some problems happen.
    That's why you should take a full backup before any upgrade, you can then do a 'disaster recovery' if you encounter any problems (most unlikely) - there are details on backup/restore procedures in the forums and the wiki.

    Quote Originally Posted by marlonrstk View Post
    There is a option to migrate without do this sequence of instalations?
    Did you read the Release Notes for the current version of ZCS? I'll quote from the relevant page (it happens to be page 11):

    Upgrade Process

    To upgrade from 5.0.x or 6.0.x to 7.1.x, download the latest 7.1.x and run the upgrade
    Why do you need to do any intermediary steps?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Migration ZCS 6 to ZCS 7 And Exchange 2007 to ZCS7
    By diablo62 in forum Administrators
    Replies: 6
    Last Post: 09-07-2011, 07:06 AM
  2. Server Migration -- ZCS to ZCS with no/minimal downtime
    By jwestta in forum Administrators
    Replies: 6
    Last Post: 07-11-2011, 05:00 PM
  3. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 04:52 AM
  4. ZCS Migration wizard for exchange freezes
    By freebsdboy in forum Migration
    Replies: 1
    Last Post: 03-14-2008, 02:50 PM
  5. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 03:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •