Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Recovery Account without backup

  1. #11
    king0770's Avatar
    king0770 is offline Zimbra Employee
    Join Date
    Sep 2007
    Posts
    186
    Rep Power
    7

    Default

    You might be inclined to find out if mboxgroup49 is corrupted.

    See if you can export the mysql DB

    source ~/bin/zmshutil; zmsetvars

    ~/mysql/bin/mysqldump mboxgroup49 -S $mysql_socket -u root --password=$mysql_root_password >> /tmp/mboxgroup49.sql
    Also find out if any other account is living on mboxgroup49.
    mysql -e "select comment from zimbra.mailbox where group_id='49'"

  2. #12
    isacap18 is offline Active Member
    Join Date
    Jan 2008
    Posts
    29
    Rep Power
    7

    Default

    I got this error:
    $ /opt/zimbra/mysql/bin/mysqldump mboxgroup49 -S $mysql_socket -u root --password=$mysql_root_password >> /tmp/mboxgroup49.sql
    mysqldump: Got error: 2002: Can't connect to local MySQL server through socket '-u' (2) when trying to connect

  3. #13
    king0770's Avatar
    king0770 is offline Zimbra Employee
    Join Date
    Sep 2007
    Posts
    186
    Rep Power
    7

    Default

    Quote Originally Posted by isacap18 View Post
    I got this error:

    Did you run this command first as the zimbra user?

    source ~/bin/zmshutil; zmsetvars
    And then...

    /opt/zimbra/mysql/bin/mysqldump mboxgroup49 -S $mysql_socket -u root --password=$mysql_root_password >> /tmp/mboxgroup49.sql

  4. #14
    isacap18 is offline Active Member
    Join Date
    Jan 2008
    Posts
    29
    Rep Power
    7

    Default

    Yes,but with zmsetvars display an error
    # /opt/zimbra/bin/zmshutil; zmsetvars -bash: zmsetvars: command not found

  5. #15
    king0770's Avatar
    king0770 is offline Zimbra Employee
    Join Date
    Sep 2007
    Posts
    186
    Rep Power
    7

    Default

    Quote Originally Posted by isacap18 View Post
    Yes,but with zmsetvars display an error
    No no, you need to actually use the source command.

    As the zimbra user, copy this line verbatim:

    source ~/bin/zmshutil; zmsetvars
    Then you should be able to use the mysqldump commands.

  6. #16
    isacap18 is offline Active Member
    Join Date
    Jan 2008
    Posts
    29
    Rep Power
    7

    Default

    Sorry, My mistake
    In this moment is running I will let you know if it finish

  7. #17
    isacap18 is offline Active Member
    Join Date
    Jan 2008
    Posts
    29
    Rep Power
    7

    Default

    It display this error:
    $ ~/mysql/bin/mysqldump mboxgroup49 -S $mysql_socket -u root --password=$mysql_root_password >> /tmp/mboxgroup49.sql
    mysqldump: Error 2013: Lost connection to MySQL server during query when dumping table `mail_item` at row: 285786

  8. #18
    king0770's Avatar
    king0770 is offline Zimbra Employee
    Join Date
    Sep 2007
    Posts
    186
    Rep Power
    7

    Default

    Looks like mboxgroup49 is corrupted.

    If you are using the NE version, you should be able to restore the account using a prefix:

    zmrestore -pre restored_ -ca -a user001@domain.com
    Might be worthwhile to find out any other accounts living on mboxgroup49 as well.

  9. #19
    isacap18 is offline Active Member
    Join Date
    Jan 2008
    Posts
    29
    Rep Power
    7

    Default

    I tried restored but It couldn't restored from command line neither admin console

    Error occurred: no such account: Account ID for user@domain.com not found in backup

  10. #20
    king0770's Avatar
    king0770 is offline Zimbra Employee
    Join Date
    Sep 2007
    Posts
    186
    Rep Power
    7

    Default

    The account I used, user001@domain.com, was really just an example. You need to find out what accounts are living on mboxgroup49, and restore them.

    mysql -e "select comment from zimbra.mailbox where group_id='49'"

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 23
    Last Post: 01-24-2013, 03:44 PM
  2. [SOLVED] Backup Account Question
    By mtorres in forum Administrators
    Replies: 4
    Last Post: 04-03-2011, 01:54 PM
  3. Restore single account failed from full backup
    By fmodola in forum Administrators
    Replies: 4
    Last Post: 06-20-2007, 05:27 AM
  4. Replies: 0
    Last Post: 04-26-2007, 11:53 AM
  5. Backup Mail and User Account
    By mcmick in forum Administrators
    Replies: 2
    Last Post: 11-08-2006, 02:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •