Results 1 to 9 of 9

Thread: Postfix won't start after upgrade to 7.1.3

  1. #1
    DougR is offline Member
    Join Date
    Oct 2010
    Posts
    14
    Rep Power
    4

    Default [SOLVED] Postfix won't start after upgrade to 7.1.3

    After upgrading from 7.1.2 to 7.1.3 I get the error:

    Code:
    Starting mta...Failed.
    postalias: fatal: bad string length 0 < 1: inet_protocols = 
    postfix failed to start
    I've attempted to edit /opt/zimbra/postfix/conf/main.cf to add "all" after inet_protocols but every time I restart the server it removes my edits.

    Any help would be appreciated!

    Thanks,
    Doug

    Edit: I've also tried adding "ipv4" after inet_protocols = but that was overwritten as well.
    Last edited by DougR; 10-10-2011 at 04:06 PM.

  2. #2
    DougR is offline Member
    Join Date
    Oct 2010
    Posts
    14
    Rep Power
    4

    Default

    I submitted a ticket to support and they fixed the issue for me. Here was their response.

    Doug,

    For reasons unknown, looks like you were missing the zimbraIPMode setting. I managed the set zimbraIPMode to ipv4 for the global and server settings.

    Hope you don't mind, I noticed there were postfix binaries in /usr/sbin. I named the /usr/sbin/post* to OLD.post*, and I've added /opt/zimbra/postfix/sbin to root's $PATH. My reasoning was that I noticed in the /var/log/zimbra.log there were references to the "/etc/postfix/main.cf". To avoid any confusion in the future, it would be advantageous for root to find postfix's binaries in /opt/zimbra/postfix/sbin and not /usr/sbin.
    Also it seems my server had multiple instances of postfix which they cleaned up.

    Edit: How do I mark a thread as solved?

    Edit 2: Nevermind, just did an advanced edit on first post.
    Last edited by DougR; 10-10-2011 at 04:06 PM.

  3. #3
    camunai is offline Starter Member
    Join Date
    Oct 2011
    Posts
    1
    Rep Power
    3

    Default

    1)

    zmprov modifyserver mail.yourzimbra.com zimbraMtaMyNetworks '127.0.0.0/8
    x.x.x.x/x [::1]/128 [xxxx:xxxx:xxxx::x]/48'

    2)

    edit conf/zmmta.cf in the mta section and add the line

    POSTCONF inet_protocols all

    like in the example below:

    POSTCONF virtual_transport LOCAL postfix_virtual_transport
    POSTCONF inet_protocols all
    RESTART mta

    3)
    restart the mta:

    zmmtactl restart

  4. #4
    altmas5 is offline New Member
    Join Date
    Feb 2012
    Posts
    3
    Rep Power
    3

    Default Same issue

    Since I upgraded a while ago I have the same issue with the postfix conf file (main.cf):
    Code:
    Starting mta...Failed.
    postalias: fatal: bad string length 0 < 1: inet_protocols = 
    postfix failed to start
    I did what camunai suggested and now I got this on my zimbra.log when tried to start postfix manually
    Code:
    Feb  8 11:01:21 mail postfix/master[29724]: daemon started -- version 2.7.7, configuration /opt/zimbra/postfix-2.7.7.3z/conf
    Feb  8 11:01:22 mail saslauthd[29732]: detach_tty      : master pid is: 29732
    Feb  8 11:01:22 mail saslauthd[29732]: ipc_init        : listening on socket: /opt/zimbra/cyrus-sasl-2.1.23.3z/state/mux
    Feb  8 11:01:22 mail zimbramon[27471]: 27471:info: Starting stats via zmcontrol
    Feb  8 11:01:23 mail postfix/smtpd[29795]: fatal: host/service 127.0.0.1/None not found: Servname not supported for ai_socktype
    Feb  8 11:01:24 mail postfix/master[29724]: warning: process /opt/zimbra/postfix/libexec/smtpd pid 29795 exit status 1
    Feb  8 11:01:24 mail postfix/master[29724]: warning: /opt/zimbra/postfix/libexec/smtpd: bad command startup -- throttling

    I have googled a lot but i didn't find anything similar.
    I did search for smtp in my /etc/services file and it's ok.
    When i got this issue I manually edited my main.cf via vim or postconf and then started postfix via /opt/zimbra/postfix/sbin/postfix {start | reload} but this time is not working.
    Then i mainly got this in my zimbra.log
    Code:
    Feb  8 11:02:25 mail postfix/master[29724]: warning: process /opt/zimbra/postfix/libexec/smtpd pid 31239 exit status 1
    Feb  8 11:02:25 mail postfix/master[29724]: warning: process /opt/zimbra/postfix/libexec/smtpd pid 31240 exit status 1
    Feb  8 11:02:25 mail postfix/master[29724]: warning: process /opt/zimbra/postfix/libexec/smtpd pid 31241 exit status 1
    Is there anyone with the same problem?

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    The inet_protocols setting should be as noted below not set to "all":

    Code:
    inet_protocols = ipv4
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    altmas5 is offline New Member
    Join Date
    Feb 2012
    Posts
    3
    Rep Power
    3

    Default Alrealdy tried

    Thanks for the reply phoenix, I already tried with ipv4 and the result is the same.
    I found in some searches this kind of error in ntp configuration but this one is not showing which is the service. Any idea?

  7. #7
    altmas5 is offline New Member
    Join Date
    Feb 2012
    Posts
    3
    Rep Power
    3

    Default again

    I migrated my server into a new one and got the same mistake.
    Code:
    Feb  9 14:29:23 mail postfix/smtpd[17340]: fatal: host/service 127.0.0.1/None not found: Servname not supported for ai_socktype
    Any idea?

  8. #8
    adfacom is offline Starter Member
    Join Date
    Oct 2009
    Location
    Italy
    Posts
    1
    Rep Power
    5

    Default

    same problem here with upgrading from 7.1.1 to 7.1.4

    solved with camunai and phoenix suggestions:

    zmprov modifyserver mail.yourzimbra.com zimbraMtaMyNetworks '127.0.0.0/8
    192.168.1.0/24 '

    edit conf/zmmta.cf
    POSTCONF inet_protocols ipv4

    dunno if the first is neeeded

  9. #9
    malayo is offline Special Member
    Join Date
    Apr 2011
    Posts
    117
    Rep Power
    3

    Default

    from
    Code:
    POSTCONF inet_protocols				VAR zimbraPostconfProtocol
    i changed it to
    Code:
    POSTCONF inet_protocols			ipv4
    then mta service can be started again

    i don't know what caused that since this is a fresh install

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 05-11-2012, 02:16 PM
  2. Upgrade from 6.0.10 to 7 beta4
    By alex70 in forum Installation
    Replies: 14
    Last Post: 05-11-2012, 02:02 PM
  3. MySQL errors
    By mludwig in forum Administrators
    Replies: 1
    Last Post: 07-11-2011, 03:40 AM
  4. Replies: 6
    Last Post: 03-14-2011, 04:21 AM
  5. [SOLVED] New zcs 7 install : database errors founds
    By dkbk in forum Administrators
    Replies: 4
    Last Post: 03-01-2011, 06:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •