Results 1 to 5 of 5

Thread: [SAMBA + Zimbra] Could not get domain info,

  1. #1
    jomach is offline Junior Member
    Join Date
    Jun 2011
    Posts
    9
    Rep Power
    4

    Default [SAMBA + Zimbra] Could not get domain info,

    Hi everyone, I'm Trying to apply this post :

    UNIX and Windows Accounts in Zimbra LDAP and Zimbra Admin UI - Zimbra :: Wiki

    Everthing goes fine until they say that the domain should appear in Zimbra Admin. I'm Getting this error in samba :

    HTML Code:
    [2011/10/07 11:47:56.750897,  2] lib/smbldap_util.c:285(smbldap_search_domain_info)
      smbldap_search_domain_info: Problem during LDAPsearch: No such object
    [2011/10/07 11:47:56.751005,  2] lib/smbldap_util.c:286(smbldap_search_domain_info)
      smbldap_search_domain_info: Query was: dc=jzimbra,dc=jzimbra,dc=dyndns,dc=info, (&(objectClass=sambaDomain)(sambaDomainName=GREGZIMBRA1))
    [2011/10/07 11:47:56.751171,  2] passdb/pdb_ldap.c:6603(pdb_init_ldapsam)
      pdb_init_ldapsam: WARNING: Could not get domain info, nor add one to the domain
      pdb_init_ldapsam: Continuing on regardless, will be unable to allocate new users/groups, and will risk BDCs having inconsistent SIDs
    [2011/10/07 11:47:56.754812,  3] passdb/lookup_sid.c:1737(get_primary_group_sid)
      Forcing Primary Group to 'Domain Users' for root
    /usr/local/samba/sbin/smbd: symbol lookup error: /usr/local/samba/sbin/smbd: undefined symbol: wbcSidsToUnixIds
    Can Anyone Help ? It's a Ubunto fresh and fuly updated box.

    Thx

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Quote Originally Posted by jomach View Post
    Can Anyone Help ? It's a Ubunto fresh and fuly updated box.
    I would guess you've not followed the instructions exactly or you've made an error when editing one of the files.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    jomach is offline Junior Member
    Join Date
    Jun 2011
    Posts
    9
    Rep Power
    4

    Default

    My mystake the nameserver was not correct, I'm At the Beginning of Part 4,

    The Domain already show's up on Admin page but I can't add users because it ask for Posix Group And I Don't have any. When I try to create I got this error:

    HTML Code:
    2011-10-07 19:22:38,468 INFO  [btpool0-14://192.168.1.50:7071/service/admin/soap/CreateLDAPEntryRequest] [name=admin@jzimbra.dyndns.info;mid=1;ip=192.168.1.4;ua=ZimbraWebClient - SAF3 (Mac);] SoapEngine - handler exception
    com.zimbra.cs.account.AccountServiceException: createLDAPEntry invalid attr name: [LDAP: error code 17 - memberUid: attribute type undefined]
    ExceptionId:btpool0-14://192.168.1.50:7071/service/admin/soap/CreateLDAPEntryRequest:1318011758466:3fc76242ca17c9ec
    Code:account.INVALID_ATTR_NAME
    	at com.zimbra.cs.account.AccountServiceException.INVALID_ATTR_NAME(AccountServiceException.java:175)
    	at com.zimbra.cs.account.ldap.ZimbraLdapContext.createEntry(ZimbraLdapContext.java:757)
    	at com.zimbra.ldaputils.CreateLDAPEntry.createLDAPEntry(CreateLDAPEntry.java:84)
    	at com.zimbra.ldaputils.CreateLDAPEntry.handle(CreateLDAPEntry.java:60)
    	at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:412)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:287)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:158)
    	at com.zimbra.soap.SoapServlet.doWork(SoapServlet.java:294)
    	at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:215)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:725)
    	at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:208)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:814)
    	at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
    	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1166)
    	at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(SetHeaderFilter.java:79)
    	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)
    	at org.mortbay.servlet.UserAgentFilter.doFilter(UserAgentFilter.java:81)
    	at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter.java:132)
    	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)
    	at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:388)
    	at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:218)
    	at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
    	at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:765)
    	at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:422)
    	at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
    	at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
    	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
    	at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle(RewriteHandler.java:230)
    	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
    	at org.mortbay.jetty.handler.DebugHandler.handle(DebugHandler.java:77)
    	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
    	at org.mortbay.jetty.Server.handle(Server.java:326)
    	at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:543)
    	at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:946)
    	at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:756)
    	at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212)
    	at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:405)
    	at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:410)
    	at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:451)
    Caused by: javax.naming.directory.InvalidAttributeIdentifierException: [LDAP: error code 17 - memberUid: attribute type undefined]; remaining name 'cn=2,ou=groups,dc=jzimbra,dc=dyndns,dc=info'
    	at com.sun.jndi.ldap.LdapCtx.mapErrorCode(LdapCtx.java:3110)
    	at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:2987)
    	at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:2794)
    	at com.sun.jndi.ldap.LdapCtx.c_createSubcontext(LdapCtx.java:788)
    	at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_createSubcontext(ComponentDirContext.java:319)
    	at com.sun.jndi.toolkit.ctx.PartialCompositeDirContext.createSubcontext(PartialCompositeDirContext.java:248)
    	at javax.naming.directory.InitialDirContext.createSubcontext(InitialDirContext.java:183)
    	at com.zimbra.cs.account.ldap.ZimbraLdapContext.createEntry(ZimbraLdapContext.java:751)
    	... 37 more
    When I try to add the index : olcDbIndex: memberUid eq
    It fails and says :
    ldap_modify: Other (e.g., implementation specific) error (80)
    additional info: index attribute "memberUid" undefined

    Any Ideia ?
    THX

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Did you install the Custom Schema? Please read the instructions in detail: UNIX and Windows Accounts in Zimbra LDAP and Zimbra Admin UI - Zimbra :: Wiki
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    jomach is offline Junior Member
    Join Date
    Jun 2011
    Posts
    9
    Rep Power
    4

    Default

    Yes I did. I'm trying to implement that. The index for memberUid is realy necessary ? could be the cause of that error ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. postfix stopped
    By riegersteve in forum Administrators
    Replies: 1
    Last Post: 05-15-2007, 03:25 PM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  3. Mails accumulating in deferred queue
    By NIRMESH KUMAR in forum Administrators
    Replies: 10
    Last Post: 03-19-2007, 12:17 AM
  4. The mailbox and mta dies in FC4 GA version
    By meikka in forum Installation
    Replies: 72
    Last Post: 03-16-2006, 05:30 PM
  5. Zimbra on Debian?
    By omry_y in forum Installation
    Replies: 25
    Last Post: 11-04-2005, 11:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •