Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: zcs 7.1.2 high CPU loading used by java process

  1. #21
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    6

    Default

    Since at least some of you are on CentOS 6 - I wonder if this issue is also at the root of your problems. I have seen java consume all CPU on my windows desktop/firefox using several of the most recent java releases up until I disabled ipv6 bit networking support. Zimbra (on RHEL6) is unresponsive or extremely slow for end users

  2. #22
    shagol is offline New Member
    Join Date
    Jan 2013
    Posts
    3
    Rep Power
    2

    Default

    ...got the same problem today with two fresh installed virtual appliances (v. 8.0.2) :-( ...any ideas? rebooting or killing the process doesn't help.

  3. #23
    oliver2uk is offline Senior Member
    Join Date
    Nov 2007
    Posts
    53
    Rep Power
    7

    Default

    Shagol,

    is it just pure fresh install without any mailboxes? Or have you try to import/restore mailboxes from your old server?

    What's the operating system you use?

    Oliver

  4. #24
    shagol is offline New Member
    Join Date
    Jan 2013
    Posts
    3
    Rep Power
    2

    Default

    Hi Oliver

    The java process came up with > 100% when i migrated the first data... Yesterday night i found out that the following action triggers it:

    I connected my mac os x (10.8.2) address book (over CardDav) to the old zimbra server (V.7) and to the new installed (8.0.2 virtual appliance). Then i moved (drag-and-drop) around 120 contacts from the old to the new server (directly in die address book app on my mac). Result: java process goes up to 180% and stays there for a long time :-)

    my guess: it is something with the pictures in my contacts... do you guys have the same issue?`


    cheers

  5. #25
    oliver2uk is offline Senior Member
    Join Date
    Nov 2007
    Posts
    53
    Rep Power
    7

    Default

    Hi Shagol,

    Yes, I would say this is quite common. It happened to us mainly during imports, exports are usually fine. Depending on the import, the java process will spike to 100% from few minutes to hours.

    Because of this, we don't use Zimbra tools (command line) for import/export anymore.

    We use ZeXtras tools or simply Zimbra Desktop. We'll create a new account first, configure it in the Zimbra desktop, import the stuff there and then let it sync to server. This works well if you used Zimbra server before, which is your case and it won't cause any java spikes.

    I truly recommended ZeXtras for any migrations and backup/restore. There is nothing better than what ZeXtras team did for the whole Zimbra community. They have actually made Zimbra useable to wide public.

    And no, I don't work for ZeXtras. We are just a happy user and support everything they do.

    Oliver
    Last edited by oliver2uk; 01-08-2013 at 04:58 AM. Reason: additional information added

  6. #26
    davidkillingsworth is offline Loyal Member
    Join Date
    Feb 2012
    Location
    Hong Kong
    Posts
    77
    Rep Power
    3

    Default

    Quote Originally Posted by cadi-its View Post
    Hi all,

    The following java process using almost 100% CPU resource, and I can't find a correct solution, any one can help? Thanks a lot.

    Code:
    zimbra    7882 54.8 19.1 1471388 392812 ?      Sl   09:03 224:47 /opt/zimbra/java/bin/java -Dfile.encoding=UTF-8 -server -Djava.awt.headless=true -Dsun.net.inetaddr.ttl=60 -XX:+UseConcMarkSweepGC -XX:PermSize=128m -XX:MaxPermSize=128m -XX:SoftRefLRUPolicyMSPerMB=1 -verbose:gc -XX:+PrintGCDetails -XX:+PrintGCTimeStamps -XX:+PrintGCApplicationStoppedTime -XX:-OmitStackTraceInFastThrow -Xss256k -Xms512m -Xmx512m -Xmn128m -Djava.io.tmpdir=/opt/zimbra/mailboxd/work -Djava.library.path=/opt/zimbra/lib -Djava.endorsed.dirs=/opt/zimbra/mailboxd/common/endorsed -Dzimbra.config=/opt/zimbra/conf/localconfig.xml -Djetty.home=/opt/zimbra/mailboxd -DSTART=/opt/zimbra/mailboxd/etc/start.config -jar /opt/zimbra/mailboxd/start.jar /opt/zimbra/mailboxd/etc/jetty.properties /opt/zimbra/mailboxd/etc/jetty-setuid.xml /opt/zimbra/mailboxd/etc/jetty.xml
    I'm having this exact same problem. I upgraded from 7.2.2 to 7.2.3 about a month ago and we are getting this constantly.

    Here's the output from top -c
    Code:
    16510 zimbra    20   0 1869m 1.4g  11m S    1 29.8 470:06.18 /opt/zimbra/java/bin/java -Dfile.encoding=UTF-8 -server -Djava.awt.headless=true -Dsun.net.inetaddr.ttl=60 -XX:+UseConcMarkSweepGC -XX:PermSize
    What is the fix for this? I see lots of reports of this issue, but no fixes. The only thing I do see is that this problem existed in 7.1.x and there was a patch in 7.1.4.
    Last edited by davidkillingsworth; 05-29-2013 at 06:31 PM.
    Release 7.2.4_GA_2900.UBUNTU10_64 UBUNTU10_64 FOSS edition.

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Unable to start all of the blackberry services
    By scasperson in forum Zimbra Connector for BlackBerry
    Replies: 8
    Last Post: 11-18-2011, 07:30 AM
  2. CPU Consume is High process Jetty
    By mtimbi@ups.edu.ec in forum Administrators
    Replies: 2
    Last Post: 06-21-2011, 08:33 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  4. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 08:22 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •