Results 1 to 5 of 5

Thread: How to upgrade postfix in zimbra

  1. #1
    dangcongphung is offline New Member
    Join Date
    Sep 2011
    Posts
    4
    Rep Power
    3

    Default How to upgrade postfix in zimbra

    Hi all !
    My Mail server is running zimbra (4.5.9), with postfix 2.2.9 . Now we want to use DKIM-milter to sign email. I get some information that smtp-milter is only available on postfix verions 3 and later. Please help me how to upgrade version of postfix .
    Thanks all

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,502
    Rep Power
    57

    Default

    Quote Originally Posted by dangcongphung View Post
    Hi all !
    My Mail server is running zimbra (4.5.9), with postfix 2.2.9 . Now we want to use DKIM-milter to sign email. I get some information that smtp-milter is only available on postfix verions 3 and later. Please help me how to upgrade version of postfix .
    The simple answer is, you can't upgrade just Postfix. You'd have to upgrade to the most recent version of Zimbra and as a matter of urgency you should do that as soon as possible (there have been a couple of security announcements about older versions), the version you're currently using is no longer supported.

    DKIM signing isn't actually implemented in Zimbra yet, see this RFE: Bug 11524 – DKIM/DK signing support in Amavisd - If you wish to see internal & external mail use DKIM the try the openDKIM instructions on this blog page:How to get DKIM (DomainKeys Identified Mail) working with Postfix on RHEL 5 / CentOS 5 using OpenDKIM – Steve Jenkins' Blog (although as of this posting the site seems to be down for some reason ) - you might find that useful when the site is up again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    soba@ukw.edu.pl is offline Special Member
    Join Date
    Jul 2011
    Posts
    146
    Rep Power
    4

    Default

    DKIM section can be added in amavisd.conf, but I do not know if the Zimbra amavis it supports.

    Amavisd + DKIM: http://www.ijs.si/software/amavisd/a...docs.html#dkim
    # ZCS 7.1.3 SLES11 SP1

  4. #4
    dangcongphung is offline New Member
    Join Date
    Sep 2011
    Posts
    4
    Rep Power
    3

    Default

    DKIM support isn't in Amavis until 2.5.3, but is more fully supported in the
    2.6.x series. My Mail server is running zimbra (4.5.9), which version I can upgrade to ? Pls give me help link to do .
    Thanks all

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,502
    Rep Power
    57

    Default

    Quote Originally Posted by dangcongphung View Post
    2.6.x series. My Mail server is running zimbra (4.5.9), which version I can upgrade to ? Pls give me help link to do .
    Please read the Release Notes on the download page for details of which versions you can upgrade (details are always provided in the Release Notes), you should also search the forums for further details on upgrade paths.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upgrade from 6.0.10 to 7 beta4
    By alex70 in forum Installation
    Replies: 14
    Last Post: 05-11-2012, 02:02 PM
  2. Upgrade to Zimbra 7 - Table upgrade required
    By n8bounds in forum Administrators
    Replies: 10
    Last Post: 04-25-2011, 11:07 PM
  3. Issues after upgrading from 6.0.10 to 7
    By rhorist in forum Administrators
    Replies: 8
    Last Post: 02-25-2011, 08:38 AM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. Replies: 8
    Last Post: 02-27-2007, 04:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •