Results 1 to 6 of 6

Thread: Zimbra seems to install but isn't working

  1. #1
    serverprodigy is offline Intermediate Member
    Join Date
    Sep 2011
    Posts
    15
    Rep Power
    3

    Default Zimbra seems to install but isn't working

    Hello,
    I'm trying to install the OS Collab Suite on my own VPS with CentOS 5.5 x64.

    I've made sure all the pre reqs are installed and the installer doesn't report any issues.

    I'm able to complete an install, etc but then I get a "could not create java virtual machine" error and nothing seems to work. I cannot reach the web portal, etc.

    IF there is a requirement to install Java I missed it completely, any suggestions on how to work out whats going wrong?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,504
    Rep Power
    57

    Default

    Quote Originally Posted by serverprodigy View Post
    I'm able to complete an install, etc but then I get a "could not create java virtual machine" error and nothing seems to work. I cannot reach the web portal, etc.
    That usually indicates not enough RAM on the server and a VPS is not a supported platform for Zimbra, you may or may not get it working. Have a search through the forums and wiki for some information about VPS & Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    serverprodigy is offline Intermediate Member
    Join Date
    Sep 2011
    Posts
    15
    Rep Power
    3

    Default

    My thought was to test it out on my VPS first, it has 2GB of RAM and isn't using all of it. I can assign as much RAM as I need so I guess I can try increasing it and see if it helps.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,504
    Rep Power
    57

    Default

    Quote Originally Posted by serverprodigy View Post
    My thought was to test it out on my VPS first, it has 2GB of RAM and isn't using all of it. I can assign as much RAM as I need so I guess I can try increasing it and see if it helps.
    I don't know anything about using a VPS but Zimbra will need a fixed allocation of at least 2GB to work correctly. As I mentioned above, have a look in the forums/wiki for some of the threads that cover using a VPS & Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    serverprodigy is offline Intermediate Member
    Join Date
    Sep 2011
    Posts
    15
    Rep Power
    3

    Default

    I increased RAM and ran the installer again. Here's what I get:

    Starting servers...Could not create the Java virtual machine.
    mkdir : No such file or directory at /opt/zimbra/bin/zmcontrol line 35
    done.
    sh: line 1: Could: command not found
    Checking for deprecated zimlets...done.
    Checking for network zimlets in LDAP...done.
    Removing network zimlets...
    Finished removing network zimlets.
    Installing common zimlets...
    com_zimbra_webex...failed. This may impact system functionality.
    com_zimbra_attachcontacts...failed. This may impact system functionality.
    com_zimbra_cert_manager...failed. This may impact system functionality.
    com_zimbra_bulkprovision...failed. This may impact system functionality.
    com_zimbra_social...failed. This may impact system functionality.
    com_zimbra_url...failed. This may impact system functionality.
    com_zimbra_phone...failed. This may impact system functionality.
    com_zimbra_date...failed. This may impact system functionality.
    com_zimbra_linkedin...failed. This may impact system functionality.
    com_zimbra_dnd...failed. This may impact system functionality.
    com_zimbra_attachmail...failed. This may impact system functionality.
    com_zimbra_adminversioncheck...failed. This may impact system functionality.
    com_zimbra_srchhighlighter...failed. This may impact system functionality.
    com_zimbra_email...failed. This may impact system functionality.
    Finished installing common zimlets.
    Getting list of all zimlets...done.
    Updating non-standard zimlets...
    Finished updating non-standard zimlets.
    Restarting mailboxd...done.
    Setting up zimbra crontab...done.


    Moving /tmp/zmsetup.09222011-011531.log to /opt/zimbra/log

  6. #6
    serverprodigy is offline Intermediate Member
    Join Date
    Sep 2011
    Posts
    15
    Rep Power
    3

    Default

    I set the RAM for 4GB, ran upgrade and after a restart I was able to get the web client and admin client working.

    Since it looked like RAM was the critical issue, I ran a new install w/ the new setting and I end up with the following issues and now the web & admin client aren't working (I haven't tried a reboot yet which did at least get those up last time)

    Everything in the install succeeded up to this point -

    Installing webclient skins...
    bare...done.
    sky...done.
    sand...done.
    tree...done.
    lemongrass...failed.
    steel...failed.
    pebble...failed.
    beach...failed.
    oasis...failed.
    waves...failed.
    twilight...failed.
    smoke...failed.
    lake...failed.
    carbon...failed.
    hotrod...failed.
    lavender...failed.
    bones...failed.
    Finished installing webclient skins.
    Setting zimbraFeatureTasksEnabled=TRUE...failed.
    Setting zimbraFeatureBriefcasesEnabled=TRUE...failed.
    Setting MTA auth host...failed.
    Setting TimeZone Preference...failed.
    Initializing mta config...done.
    Setting services on zim.spectrehosting.com...done.
    Creating domain zim.spectrehosting.com...failed.
    Setting default domain name...failed.
    Creating domain zim.spectrehosting.com...failed.
    Creating admin account admin@zim.spectrehosting.com...failed.
    Creating root alias...failed.
    Creating postmaster alias...failed.
    Creating user spam.iw_jt7w_kd@zim.spectrehosting.com.../opt/zimbra/bin/zmshutil: line 39: Error: command not found
    failed.
    Creating user ham.tkzhvm41pb@zim.spectrehosting.com.../opt/zimbra/bin/zmshutil: line 39: Error: command not found
    failed.
    Creating user virus-quarantine.oaxwi2vi_k@zim.spectrehosting.com.../opt/zimbra/bin/zmshutil: line 39: Error: command not found
    failed.
    Setting spam training and Anti-virus quarantine accounts...failed.
    Initializing store sql database...done.
    Setting zimbraSmtpHostname for zim.spectrehosting.com...failed.
    Configuring SNMP...done.
    Checking for default IM conference room...not present.
    Initializing default IM conference room...failed.
    Setting up syslog.conf...done.

    You have the option of notifying Zimbra of your installation.
    This helps us to track the uptake of the Zimbra Collaboration Suite.
    The only information that will be transmitted is:
    The VERSION of zcs installed (7.1.2_GA_3268_CentOS5_64)
    The ADMIN EMAIL ADDRESS created (admin@zim.spectrehosting.com)

    Notify Zimbra of your installation? [Yes]

    Starting servers...mkdir : No such file or directory at /opt/zimbra/bin/zmcontrol line 35
    done.
    sh: line 1: java.lang.OutOfMemoryError:: command not found
    Installing common zimlets...
    com_zimbra_webex...failed. This may impact system functionality.
    com_zimbra_attachcontacts...failed. This may impact system functionality.
    com_zimbra_cert_manager...failed. This may impact system functionality.
    com_zimbra_bulkprovision...failed. This may impact system functionality.
    com_zimbra_social...failed. This may impact system functionality.
    com_zimbra_url...failed. This may impact system functionality.
    com_zimbra_phone...failed. This may impact system functionality.
    com_zimbra_date...failed. This may impact system functionality.
    com_zimbra_linkedin...failed. This may impact system functionality.
    com_zimbra_dnd...failed. This may impact system functionality.
    com_zimbra_attachmail...failed. This may impact system functionality.
    com_zimbra_adminversioncheck...failed. This may impact system functionality.
    com_zimbra_srchhighlighter...failed. This may impact system functionality.
    com_zimbra_email...failed. This may impact system functionality.
    Finished installing common zimlets.
    Restarting mailboxd...done.
    Setting up zimbra crontab...done.


    Moving /tmp/zmsetup.09222011-013727.log to /opt/zimbra/log

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 11:13 AM
  3. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  4. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •