Results 1 to 6 of 6

Thread: Services not starting - Need cli help ASAP

  1. #1
    mdelamater is offline New Member
    Join Date
    Aug 2011
    Posts
    4
    Rep Power
    3

    Exclamation Services not starting - Need cli help ASAP

    This is NOT a new installation.

    Release 5.0.5_GA_2201.RHEL5_20080417012110 CentOS5 FOSS edition

    This morning some knucklehead unchecked all the services boxes in admin, and now I cannot log back in.

    When I run zmprov ms mail01.connect-technology.net +zimbraServiceEabled mta I get the following error:

    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)

    if I run zmprov -l ms mail01.connect-technology.net +zimbraServiceEabled mta I get this one:

    ERROR: account.INVALID_ATTR_NAME (invalid attr name: [LDAP: error code 17 - zimbraServiceEabled: attribute type undefined]) (cause: javax.naming.directory.InvalidAttributeIdentifierE xception [LDAP: error code 17 - zimbraServiceEabled: attribute type undefined])

    I am completely confused and frustrated and boss dude is screaming at me because the mail server is down... can anyone help?

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,496
    Rep Power
    56

    Default

    Run the following command on the server to check the enabled services:

    Code:
    zmprov -l gs `zmhostname` | grep  zimbraServiceEnabled
    It should list the following (assuming it's the OSS version):

    Code:
    zimbraServiceEnabled: antivirus
    zimbraServiceEnabled: antispam
    zimbraServiceEnabled: logger
    zimbraServiceEnabled: mailbox
    zimbraServiceEnabled: mta
    zimbraServiceEnabled: stats
    zimbraServiceEnabled: snmp
    zimbraServiceEnabled: ldap
    zimbraServiceEnabled: spell
    Enable all the services that need it by running the "ms" command with the "zmprov -l" option then try a start of the services. Failing that, I'd take a backup of the /opt/zimbra directory then run an 'upgrade' install of the same version of Zimbra that you have currently installed.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    mdelamater is offline New Member
    Join Date
    Aug 2011
    Posts
    4
    Rep Power
    3

    Default

    [zimbra@JXN-CT-MAIL01 root]$ zmprov -l gs `zmhostname` | grep zimbraServiceEnabled
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail01.connect-technology.net:389)

  4. #4
    mdelamater is offline New Member
    Join Date
    Aug 2011
    Posts
    4
    Rep Power
    3

    Default

    This is insane... I cannot find the version that is apparently installed here...

    1209426987: INSTALLED zimbra-core-5.0.5_GA_2201.RHEL5-20080417012110.i386.rpm
    1209426990: INSTALLED zimbra-ldap-5.0.5_GA_2201.RHEL5-20080417012110.i386.rpm
    1209426997: INSTALLED zimbra-logger-5.0.5_GA_2201.RHEL5-20080417012110.i386.rpm
    1209427002: INSTALLED zimbra-mta-5.0.5_GA_2201.RHEL5-20080417012110.i386.rpm
    1209427005: INSTALLED zimbra-snmp-5.0.5_GA_2201.RHEL5-20080417012110.i386.rpm
    1209427019: INSTALLED zimbra-store-5.0.5_GA_2201.RHEL5-20080417012110.i386.rpm
    1209427031: INSTALLED zimbra-apache-5.0.5_GA_2201.RHEL5-20080417012110.i386.rpm
    1209427034: INSTALLED zimbra-spell-5.0.5_GA_2201.RHEL5-20080417012110.i386.rpm

    I followed the link from this post: 5.0.5 is Released! clicked on the 5.0.5 Open Source Edition downloads link and only see 5.0.26 or 6.0.x and higher.

    Any ideas guys? I'm under the gun here...

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,496
    Rep Power
    56

    Default

    The download for that version (and all previous releases) is in the Archive download section, to of the download page.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    mdelamater is offline New Member
    Join Date
    Aug 2011
    Posts
    4
    Rep Power
    3

    Default

    I would like very much for you to show me... I looked in the archive section of the download page (as stated above).

    It no longer matters... management has decided to go with another solution (against my objections).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Simple backup script for OSE version
    By soulskater in forum Administrators
    Replies: 64
    Last Post: 08-03-2011, 07:47 AM
  2. Debian - Upgrade from 4.5.6
    By magikman in forum Installation
    Replies: 1
    Last Post: 01-19-2008, 12:59 PM
  3. RHEL4 services not starting
    By reza225 in forum Installation
    Replies: 3
    Last Post: 09-01-2006, 03:35 PM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  5. Zimbra on Debian?
    By omry_y in forum Installation
    Replies: 25
    Last Post: 11-04-2005, 11:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •