Results 1 to 6 of 6

Thread: LDAP Authentication with Zimbra

  1. #1
    SamTzu's Avatar
    SamTzu is offline Loyal Member
    Join Date
    Jan 2006
    Location
    Finland
    Posts
    83
    Rep Power
    9

    Default LDAP Authentication with Zimbra

    I have tried to get Joomla to authenticate against Zimbra 7 without much success. Can someone tell me what the proper DN's are?
    I have been trying with these settings in Joomla LDAP plugin.

    Host | mail.xxx.com
    Port | 389
    LDAP V3 | Yes
    Negotiate TLS | Yes (We have external Certificate in use but both servers are on LAN)
    Follow Referrals | No
    Authorisation Method | Bind and Search
    Base DN | ou=users,ou=contacts,dc=xxx,dc=com
    Search String | uid=[search]
    User's DN |
    Connect Username |
    Connect Password |
    Map: Full Name | fullName
    Map: email | E-mail
    Map: User ID | uid=%u




    Sami Mattila
    Internet-Content

    Telephone: +358.9.42833310
    Email: firstname.lastname@internet-content.org
    Shop: https://shop.internet-content.net
    Site: Internet-Content Services
    Blog: Internet-Content.net Blog
    SamTzu
    -----------------------------------------------
    "I keep hitting the esc key, why am I still here?"

  2. #2
    bdial's Avatar
    bdial is offline Moderator
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    the dn should be

    Code:
    ou=people,dc=yourdomain,dc=com

  3. #3
    SamTzu's Avatar
    SamTzu is offline Loyal Member
    Join Date
    Jan 2006
    Location
    Finland
    Posts
    83
    Rep Power
    9

    Default

    Thx, one step closer.
    Still not working though.
    SamTzu
    -----------------------------------------------
    "I keep hitting the esc key, why am I still here?"

  4. #4
    SamTzu's Avatar
    SamTzu is offline Loyal Member
    Join Date
    Jan 2006
    Location
    Finland
    Posts
    83
    Rep Power
    9

    Thumbs down

    This place is so dead you could hear a pin drop...
    SamTzu
    -----------------------------------------------
    "I keep hitting the esc key, why am I still here?"

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Quote Originally Posted by SamTzu View Post
    This place is so dead you could hear a pin drop...
    You've already been given the correct details to authenticate against the server, what have you tried while you've been waiting for an answer? For instance, have you tried using something like Apache Directory Studio (or an similar client) to browser the tree? Have you tried doing an ldapsearch against the server to see what errors you get?

    The following doesn't actually tell us much:

    Quote Originally Posted by SamTzu View Post
    Thx, one step closer.
    Still not working though.
    What does 'one step closer' actually mean? The comment 'still not working' doesn't tell us what errors you're seeing so without any clear information on the problem it's difficult to give you any advice on solving the problem.

    BTW, don't forget that people who answer questions volunteer to do so and do it in their free time - work and real life permitting.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    cyber7 is offline Special Member
    Join Date
    May 2010
    Location
    Cape Town; South Africa
    Posts
    102
    Rep Power
    5

    Default

    Hi Bill.
    After having a 5 hour problem getting this to work, I finally got it going (Zimbra 8/Joomla 3) by using the following:

    It is quite different from the other posts (Zimbra 7), so here goes:

    Setting the details:
    Host: mail.server.co.za
    Port: 389
    LDAP V3: YES
    Negotiate TLS: No
    Follow Referrals: No
    Authorisation Method: Bind and Search
    Base DN: ou=people,dc=server,dc=co,dc=za
    Search String: uid=[search]
    User's DN: uid=zimbra,cn=admins,cn=zimbra
    Connect Username: zimbra
    Connect Password: <zmlocalconfig -s | grep zimbra_ldap>
    Map Full Name:
    Map email: mail
    Map User ID: uid

    NOTES:
    The <zmlocalconfig -s | grep zimbra_ldap> run on your ZIMBRA server will give you the username and password. If your username is different to zimbra change accordingly.

    NOTE: To get the User's name and surname combination use:
    Map Full Name: displayName

    Kind regards
    Aubrey Kloppers
    Cape Town
    South Africa
    Last edited by cyber7; 01-31-2013 at 12:37 PM.
    Code:
    Never trust a fart...
    Release 8.0.0_GA_5434.RHEL6_64_20120907144743 CentOS6_64 NETWORK edition.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 11:13 AM
  2. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •