Results 1 to 6 of 6

Thread: Caused by: com.mysql.jdbc.exceptions.MySQLSyntaxErrorExceptio n: Table 'mboxgroup17.ma

  1. #1
    check-ict is offline Junior Member
    Join Date
    Aug 2011
    Posts
    7
    Rep Power
    4

    Exclamation Caused by: com.mysql.jdbc.exceptions.MySQLSyntaxErrorExceptio n: Table 'mboxgroup17.ma

    We have a Zimbra server setup with 4 servers (mta, proxy, ldap and store).

    The Store recently crashed and there was some disk corruption. fsck checked the disks and restored it, but the Zimbra database was still corrupted.

    We went back to a full back-up that was created earlier, now the database starts again.

    We thougt everything was fine again (except for some lost e-mails), but now several accounts are getting corrupted:

    Caused by: com.mysql.jdbc.exceptions.MySQLSyntaxErrorExceptio n: Table 'mboxgroup17.mail_item' doesn't exist

    These mailboxes worked after restore. Somehow they suddenly couldn't login anymore (hanging). Now I see this error everywhere on the crashed mailboxes.

    I tried:
    zmblobchk -m 117 start -v
    nogo
    /opt/zimbra/mysql/bin/mysqlcheck --defaults-file=/opt/zimbra/conf/my.cnf -S /opt/zimbra/db/mysql.sock -A -C -s -u root --password pass --auto-repair
    nogo

    How can I restore the database or recreate the tables?

    I tried to restore with zmlmtpinject to a new account, but that's a big pile of mails without timestamp etc.

  2. #2
    check-ict is offline Junior Member
    Join Date
    Aug 2011
    Posts
    7
    Rep Power
    4

    Default

    Can someone please help? Our database needs to be repaired!

  3. #3
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    10

    Default

    Have you tried reindexing the mailboxes, from the Admin Console?

    Hope that helps,
    Mark

  4. #4
    check-ict is offline Junior Member
    Join Date
    Aug 2011
    Posts
    7
    Rep Power
    4

    Default

    Yes we tried, but it stops after 1 second. In the log I see the same mysql error, it's missing the mail_item table.

  5. #5
    CustomSoft B.V. is offline New Member
    Join Date
    Aug 2011
    Posts
    3
    Rep Power
    3

    Default

    Same issue here! Running ZCS v6 (till update 12). Reindexing mailbox doesn't seem to work (is finished after 1 sec; obviously doesn't do anything). The log shows mysql error, it's missing the mail_item table. Could someone please help a.s.a.p.? (Otherwise our whole zimbra setup is useless / too corrupted!)

  6. #6
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    10

    Default

    Quote Originally Posted by check-ict View Post
    Yes we tried, but it stops after 1 second. In the log I see the same mysql error, it's missing the mail_item table.
    I see you are using the FOSS edition. How did you restore from backup; what backup methodology did you use?

    Are there any other errors in any other Zimbra or system log files?

    Lastly, if you run dmesg as root, does it show an errors?

    Hope that helps,
    Mark

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 05-11-2012, 02:16 PM
  2. MySQL errors
    By mludwig in forum Administrators
    Replies: 1
    Last Post: 07-11-2011, 03:40 AM
  3. [SOLVED] Zimbra 7.0.1 Database Issue after upgrade
    By n.bochev in forum Administrators
    Replies: 3
    Last Post: 03-16-2011, 01:07 AM
  4. Replies: 6
    Last Post: 03-14-2011, 04:21 AM
  5. [SOLVED] New zcs 7 install : database errors founds
    By dkbk in forum Administrators
    Replies: 4
    Last Post: 03-01-2011, 06:49 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •