Results 1 to 7 of 7

Thread: Sending OK, Receive NOT OK

  1. #1
    duks is offline New Member
    Join Date
    Aug 2011
    Location
    Honiara, Solomon Islands
    Posts
    4
    Rep Power
    3

    Default Sending OK, Receive NOT OK

    Hi, I'm a newbie but a big fan of Zimbra.

    Just installed Zimbra (ZCS-7.1.1_GA.RHEL) on a Centos 5 (i386) machine using this guide, Zimbra Collaboration Suite Open Source Edition On CentOS | HowtoForge - Linux Howtos and Tutorials.

    During installation, I have been warned of the following
    - platform: this platform is CentOS5, packages found: RHEL5, this may or may not work.

    - port conflict detected: 25 (zimbra-mta)

    Apart from those, I think installation was completed properly.

    I was able to send email from an account I created on my new Zimbra server to externally hosted addresses, including @live.com. But my problem is receiving incoming emails. I believe the messages reached my Zimbra server but not delivered to the intended mailbox.

    I can see from the Administration console that there are messages being held up in the 'Deferred' category with the error/reason: "connect to quake.ourtelekom.net.sb[202.1.180.72]:7025: connection refused". There is one with the the port indicated as 25.

    Can someone please assist.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,506
    Rep Power
    57

    Default

    Quote Originally Posted by duks View Post
    I can see from the Administration console that there are messages being held up in the 'Deferred' category with the error/reason: "connect to quake.ourtelekom.net.sb[202.1.180.72]:7025: connection refused". There is one with the the port indicated as 25.

    Can someone please assist.
    You could find the answer to these questions by searching the forums. Did you disable and stop the default mail server in CentOS? Did you set-up a Split DNS with correct DNS A & MX records and a valid /etc/hosts file?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    duks is offline New Member
    Join Date
    Aug 2011
    Location
    Honiara, Solomon Islands
    Posts
    4
    Rep Power
    3

    Default

    I went through the installations again and this time I don't have any port conflict message or any other error.

    I can send messages to any address hosted anywhere fine. I was able to receive emails sent from domain names hosted within the country, except I am not receiving emails from externally hosted domain names, example, from @live.com.

    [root@mail ~]# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    192.168.1.3 mail.ourtelekom.net.sb mail

    [root@mail ~]# cat /etc/resolv.conf
    search ourtelekom.net.sb
    domain ourtelekom.net.sb
    nameserver 192.168.1.3
    nameserver 202.1.180.72

    What could I be possibly missing? Any assistance?

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,506
    Rep Power
    57

    Default

    Quote Originally Posted by duks View Post
    What could I be possibly missing? Any assistance?
    The answer to this problem is all over the forums as I've already mentioned, did you search? I've already given you the answer to this problem, you need to read the Split DNS article and configure your DNS records, hosts file and resolv.conf as described in that article - you can check your configuration by running all the commands in the 'Verify....' of that article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    duks is offline New Member
    Join Date
    Aug 2011
    Location
    Honiara, Solomon Islands
    Posts
    4
    Rep Power
    3

    Default

    The guide I followed (Install Zimbra Collaboration Suite 7 on Centos 5.5 – Part 1) includes setting up of DNS so I believe that part is covered.

    Here are my verifications;

    Code:
    [root@mail ~]# dig ourtelekom.net.sb mx
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> ourtelekom.net.sb mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41053
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;ourtelekom.net.sb.             IN      MX
    
    ;; ANSWER SECTION:
    ourtelekom.net.sb.      2592000 IN      MX      10 mail.ourtelekom.net.sb.
    
    ;; AUTHORITY SECTION:
    ourtelekom.net.sb.      2592000 IN      NS      ns.ourtelekom.net.sb.
    
    ;; ADDITIONAL SECTION:
    mail.ourtelekom.net.sb. 2592000 IN      A       192.168.1.3
    ns.ourtelekom.net.sb.   2592000 IN      A       192.168.1.3
    
    ;; Query time: 5 msec
    ;; SERVER: 192.168.1.3#53(192.168.1.3)
    ;; WHEN: Thu Aug 18 09:09:48 2011
    ;; MSG SIZE  rcvd: 105
    Code:
    [root@mail ~]# dig ourtelekom.net.sb any
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> ourtelekom.net.sb any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4024
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;ourtelekom.net.sb.             IN      ANY
    
    ;; ANSWER SECTION:
    ourtelekom.net.sb.      2592000 IN      SOA     ourtelekom.net.sb. hostmaster.ourtelekom.net.sb. 2011081701 43200 3600 3600000 2592000
    ourtelekom.net.sb.      2592000 IN      NS      ns.ourtelekom.net.sb.
    ourtelekom.net.sb.      2592000 IN      A       192.168.1.3
    ourtelekom.net.sb.      2592000 IN      MX      10 mail.ourtelekom.net.sb.
    
    ;; ADDITIONAL SECTION:
    ns.ourtelekom.net.sb.   2592000 IN      A       192.168.1.3
    mail.ourtelekom.net.sb. 2592000 IN      A       192.168.1.3
    
    ;; Query time: 23 msec
    ;; SERVER: 192.168.1.3#53(192.168.1.3)
    ;; WHEN: Thu Aug 18 09:11:06 2011
    ;; MSG SIZE  rcvd: 168
    Code:
    [root@mail ~]# host $(hostname)
    mail.ourtelekom.net.sb has address 192.168.1.3
    Code:
    [root@mail ~]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain   localhost
    192.168.1.3     mail.ourtelekom.net.sb  mail
    Code:
    [root@mail ~]# cat /etc/resolv.conf
    search ourtelekom.net.sb
    nameserver 127.0.0.1
    Last edited by phoenix; 08-17-2011 at 10:54 PM.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,506
    Rep Power
    57

    Default

    The information you've posted above looks OK but the problem is it confilcts with the information you gave in your original post;

    Quote Originally Posted by duks View Post
    I can see from the Administration console that there are messages being held up in the 'Deferred' category with the error/reason: "
    connect to quake.ourtelekom.net.sb[202.1.180.72]:7025: connection refused". There is one with the the port indicated as 25.
    The IP address and the FQDN of the server are different that the one in your DNS regords above. In addition, when I do a check of your DNS records I see the following:

    Code:
    dig ourtelekom.net.sb any
    
    ; <<>> DiG 9.7.3-P3 <<>> ourtelekom.net.sb any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39469
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;ourtelekom.net.sb.             IN      ANY
    
    ;; ANSWER SECTION:
    ourtelekom.net.sb.      86362   IN      NS      ns.ourtelekom.net.sb.
    ourtelekom.net.sb.      86362   IN      MX      10 mail.ourtelekom.net.sb.
    
    ;; ADDITIONAL SECTION:
    mail.ourtelekom.net.sb. 86362   IN      A       192.168.1.3
    ns.ourtelekom.net.sb.   86362   IN      A       192.168.1.3
    
    ;; Query time: 3 msec
    ;; SERVER: 192.168.1.10#53(192.168.1.10)
    ;; WHEN: Thu Aug 18 07:58:20 2011
    ;; MSG SIZE  rcvd: 105
    That shows your private LAN IP and that's incorrect, it should be the public IP address of your server in the public DNS server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    duks is offline New Member
    Join Date
    Aug 2011
    Location
    Honiara, Solomon Islands
    Posts
    4
    Rep Power
    3

    Default

    Ignore my initial post, I have made some changes to the name. my latest/current should be considered, sorry for the confusion.

    Where should I made the change to reflect my public IP?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Lot of mails deferred
    By pigui in forum Administrators
    Replies: 17
    Last Post: 04-10-2012, 05:15 AM
  2. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 04:32 PM
  3. Problem on receive mail and send mail
    By isacap18 in forum Administrators
    Replies: 1
    Last Post: 01-25-2008, 01:26 PM
  4. Replies: 3
    Last Post: 07-19-2007, 02:00 AM
  5. Cannot receive mails
    By zzzzsg in forum Installation
    Replies: 3
    Last Post: 11-28-2005, 10:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •