Results 1 to 3 of 3

Thread: Cannot display subject and/or from in Traditional Chinese correctly

  1. #1
    SeanTsang is offline Junior Member
    Join Date
    Nov 2010
    Posts
    8
    Rep Power
    4

    Default Cannot display subject and/or from in Traditional Chinese correctly

    Hi,

    I think it should be an old problem. But after plenty of searching, I still can't find any solution suitable for my scenario.

    My zimbra version: ZCA 6.0.13.406

    I have posted two headers for your reference
    ================================================== =======
    Problem headers:

    Return-Path: epaper@epaper.books.com.tw
    Received: from mail.XXXX.com (LHLO zcs01.XXXX.com)
    (61.67.240.110) by zcs01.XXXX.com with LMTP; Mon, 8 Aug 2011
    06:16:32 +0800 (CST)
    Received: from localhost (localhost.localdomain [127.0.0.1])
    by zcs01.XXXX.com (Postfix) with ESMTP id 343F1340B8;
    Mon, 8 Aug 2011 06:16:32 +0800 (CST)
    X-Quarantine-ID: <ed+5wItkvuC0>
    X-Virus-Scanned: amavisd-new at zcs01.XXXX.com
    X-Amavis-Alert: BAD HEADER SECTION, Non-encoded 8-bit data (char A5 hex):
    Subject:
    \245\360\266\242\276c\272\241\242\261\242\264\242\ 257\242\257[...]
    X-Spam-Flag: NO
    X-Spam-Score: 4.92
    X-Spam-Level: ****
    X-Spam-Status: No, score=4.92 tagged_above=-10 required=6.6
    tests=[BAYES_50=0.8, HTML_COMMENT_SAVED_URL=1.391,
    HTML_IMAGE_RATIO_02=0.437, HTML_MESSAGE=0.001, MIME_HTML_ONLY=0.723,
    NORMAL_HTTP_TO_IP=0.001, SUBJECT_NEEDS_ENCODING=0.049,
    SUBJ_ILLEGAL_CHARS=1.518, T_REMOTE_IMAGE=0.01,
    T_RP_MATCHES_RCVD=-0.01] autolearn=no
    Received: from zcs01.XXXX.com ([127.0.0.1])
    by localhost (zcs01.XXXX.com [127.0.0.1]) (amavisd-new, port 10024)
    with ESMTP id ed+5wItkvuC0; Mon, 8 Aug 2011 06:16:31 +0800 (CST)
    Received: from epaper.books.com.tw (prometheus.books.com.tw [61.31.206.134])
    by zcs01.XXXX.com (Postfix) with SMTP id A1A443404E
    for <sean@YYYY.com>; Mon, 8 Aug 2011 06:16:28 +0800 (CST)
    Received: By OpenMail Mailer;Mon, 08 Aug 2011 06:08:00 +0800 (CST)
    Date: Mon, 08 Aug 2011 06:08:00 +0800 (CST)
    From: "=?Big5?B?s9WryKjToWmqQbmisHSl88BdoWo=?=" <mailsender@books.com.tw>
    Reply-To: "=?Big5?B?s9WryKjT?=" <mailsender@books.com.tw>
    MIME-Version: 1.0
    Subject: �𶢾c�������������b�A�E��I�I���]�R���d�A�e���ʡI�I�u�좷��������
    Content-Type: text/html; charset=big5
    Content-Transfer-Encoding: base64
    X-Mailer: MIME::Lite 2.105
    Message-Id: <20110807221628.A1A443404E@zcs01.XXXX.com>
    To: undisclosed-recipients:;

    ================================================== =======
    Normal Hearders:

    Return-Path: member@cyber2.happygocard.com.tw
    Received: from mail.XXXX.com (LHLO zcs01.XXXX.com)
    (61.67.240.110) by zcs01.XXXX.com with LMTP; Mon, 8 Aug 2011
    05:39:27 +0800 (CST)
    Received: from localhost (localhost.localdomain [127.0.0.1])
    by zcs01.XXXX.com (Postfix) with ESMTP id 08F81340B7;
    Mon, 8 Aug 2011 05:39:27 +0800 (CST)
    X-Quarantine-ID: <bo5Xp362teng>
    X-Virus-Scanned: amavisd-new at zcs01.XXXX.com
    X-Spam-Flag: NO
    X-Spam-Score: 4.663
    X-Spam-Level: ****
    X-Spam-Status: No, score=4.663 tagged_above=-10 required=6.6
    tests=[BAYES_99=3.5, FROM_MISSP_DKIM=0.001, FROM_MISSP_EH_MATCH=0.001,
    HTML_IMAGE_RATIO_02=0.437, HTML_MESSAGE=0.001, MIME_HTML_ONLY=0.723,
    T_REMOTE_IMAGE=0.01, T_RP_MATCHES_RCVD=-0.01] autolearn=no
    Received: from zcs01.XXXX.com ([127.0.0.1])
    by localhost (zcs01.XXXX.com [127.0.0.1]) (amavisd-new, port 10024)
    with ESMTP id bo5Xp362teng; Mon, 8 Aug 2011 05:39:25 +0800 (CST)
    Received: from smtp2.cyber.happygocard.com.tw (smtp2.cyber.happygocard.com.tw [218.32.214.185])
    by zcs01.XXXX.com (Postfix) with ESMTP id 68AA83404E
    for <sean@YYYY.com>; Mon, 8 Aug 2011 05:38:52 +0800 (CST)
    Received: from cyberap (cyberap.happygocard.com.tw [10.97.2.64])
    by smtp2.cyber.happygocard.com.tw (Postfix) with ESMTP id 4ABB810585FA
    for <sean@YYYY.com>; Mon, 8 Aug 2011 03:06:26 +0800 (CST)
    Date: Mon, 8 Aug 2011 03:06:36 +0800
    From: "=?big5?B?R09IQVBQWafWvNbByqqruvQ=?="<member@cyber 2.happygocard.com.tw>
    To: sean@YYYY.com
    Reply-To: "=?big5?B?R09IQVBQWafWvNbByqqruvQ=?="<service@happ ygocard.com.tw>
    Subject: =?big5?B?oqtWUzinbLnQvrmsvbH+oUmtrTgvOKH3w3qx/jM5OTCiqDE0plS1TLitpPmtt66wofsxOTgwobutuKdRrvqyYqT 0vrmh+zk5MKG7pEW2p6invN++96H7Mjk5OQ==?=
    Message-ID: <t0ta4c045cet0t14930t1ac1ct1012bt2t111t0.t0ta4c04@ cyber2.happygocard.com.tw>
    Importance: normal
    Priority: normal
    Sensitivity: none
    MIME-Version: 1.0
    X-Mailer: OMICard 5.8
    Content-Type: text/html;
    charset="big5"
    Content-Transfer-Encoding: base64
    ================================================== =======
    It's quite annoying and I don't think it's a problem caused by MUA.
    I have tried at least the following:
    1) Zimbra Desktop
    2) Zimbra Web Client
    3) Mozilla Thunderbird
    4) Evolution
    5) Blackberry 9700

    None of them work correctly.

    I guess it's a problem of decoding a subject string especially in case of having different encodings of subject and body.

    Any help will be great appreciated and accept my apologize if this is a duplicated post.
    Yours sincerely,
    Sean Tsang

    Ultimate Thinking Tech Taiwan.
    ------------------------------------------------------
    Release 6.0.13_GA_2918.UBUNTU8_64 UBUNTU8_64 NETWORK edition.
    I am from Taiwan. I love my beautiful country.
    zh_TW Wanted!

  2. #2
    shawnchu is offline New Member
    Join Date
    Aug 2011
    Posts
    3
    Rep Power
    4

    Default

    Do you meaning that your email subject can't display traditional Chinese correctly?

    I'm Taiwanese too,
    I use zimbra 7.1.1 and traditional Chinese title shown fine.
    But I notice that my charset is UTF8.

    Maybe we can discuss by Chinese via gmail.

    shawnchu1014@gmail.com

  3. #3
    SeanTsang is offline Junior Member
    Join Date
    Nov 2010
    Posts
    8
    Rep Power
    4

    Default

    Not all of them display with problems. Some emails from specific senders got display problems.
    However, I used to receiving those problematic mails using MS exchange 2007 and their subjects just got decoded and display perfectly.
    Yours sincerely,
    Sean Tsang

    Ultimate Thinking Tech Taiwan.
    ------------------------------------------------------
    Release 6.0.13_GA_2918.UBUNTU8_64 UBUNTU8_64 NETWORK edition.
    I am from Taiwan. I love my beautiful country.
    zh_TW Wanted!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 04-01-2011, 12:58 PM
  2. Shared folder hierarchy fails to display correctly
    By thomas wyse in forum Administrators
    Replies: 3
    Last Post: 04-10-2008, 08:35 AM
  3. can not display the language correctly
    By stc_mis in forum Installation
    Replies: 0
    Last Post: 05-30-2007, 03:31 AM
  4. Replies: 10
    Last Post: 07-16-2006, 12:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •