Results 1 to 7 of 7

Thread: MX Record Lookup for Remote Servers

  1. #1
    jdp459 is offline Active Member
    Join Date
    Sep 2008
    Location
    Georgia, USA
    Posts
    28
    Rep Power
    6

    Default [SOLVED] MX Record Lookup for Remote Servers

    SOLVED!

    Sending Email issue. We can receive fine and can send and receive between our domains without issue.

    We recently switched ISP connections. Now a relay is not needed - no relayhost. I think that's where the issue lies.

    Running Zimbra 7.1.1 OSE.

    When sending, the /var/log/zimbra.log shows that connections to remove servers are to the domain, not the DNS MX record. Huh? I'm wondering what could cause that issue?

    For example, an email to a gmail.com address has this in the logfile.
    Aug 4 08:16:05 mail postfix/smtp[3832]: connect to gmail.com[74.125.157.18]:25: Connection timed out


    But a 'dig mx gmail' shows that the IP used by Zimbra isn't any of the MX records.
    ;; ANSWER SECTION:
    gmail.com. 2754 IN MX 20 alt2.gmail-smtp-in.l.google.com.
    gmail.com. 2754 IN MX 30 alt3.gmail-smtp-in.l.google.com.
    gmail.com. 2754 IN MX 40 alt4.gmail-smtp-in.l.google.com.
    gmail.com. 2754 IN MX 10 alt1.gmail-smtp-in.l.google.com.
    gmail.com. 2754 IN MX 5 gmail-smtp-in.l.google.com.

    ;; ADDITIONAL SECTION:
    alt4.gmail-smtp-in.l.google.com. 45 IN A 74.125.77.27
    alt1.gmail-smtp-in.l.google.com. 16 IN A 74.125.113.27
    gmail-smtp-in.l.google.com. 272 IN A 74.125.47.27

    My Zimbra server should attempt to connect with 74.125.47.27, right?

    We're running the 'dig' command on the Zimbra server and I can
    $ telnet 74.125.47.27 25
    to the remote machine and get the ESMTP connection just fine. Did someone, probably me, screw up the postfix lookup config?

    $ postconf relayhost
    relayhost =


    relayhost is empty, so MX record lookups should happen, right?

    I thought the issue was with disable_dns_lookups being "yes" and changed it to "no"
    postconf -e disable_dns_lookups=no
    $ postconf disable_dns_lookups
    disable_dns_lookups = no

    Then reloaded postfix and checked it again.
    $ postfix reload
    $ postconf disable_dns_lookups
    disable_dns_lookups = yes


    YES!? Huh? What?

    I'm pretty certain this is a simple configuration issue. I've failed to find a solution searching here and on the postfix forums. Is the antivirus getting in the way?

    Thanks for reading.
    Last edited by jdp459; 08-04-2011 at 06:12 AM. Reason: issue resolved.
    OSS Zimbra 7.2.7 64-bit ... er ... now.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,493
    Rep Power
    56

    Default

    Quote Originally Posted by jdp459 View Post
    We're running the 'dig' command on the Zimbra server and I can
    $ telnet 74.125.47.27 25
    to the remote machine and get the ESMTP connection just fine. Did someone, probably me, screw up the postfix lookup config?
    That isn't really a test of anything other than the server is 'alive', what happens if you run the following (on the zimbra server):

    Code:
    telnet alt2.gmail-smtp-in.l.google.com 25
    Have you enabled the "Enable DNS lookups" in the admin UI?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    jdp459 is offline Active Member
    Join Date
    Sep 2008
    Location
    Georgia, USA
    Posts
    28
    Rep Power
    6

    Default

    Just found this in another thread.

    -go to global settings>mta tab and check the box for dns lookups
    or: zmprov mcf zimbraMtaDnsLookupsEnabled TRUE (zmprov mc zimbraMtaDnsLookupsEnabled TRUE)

    I feel so dumb. ;O
    OSS Zimbra 7.2.7 64-bit ... er ... now.

  4. #4
    jdp459 is offline Active Member
    Join Date
    Sep 2008
    Location
    Georgia, USA
    Posts
    28
    Rep Power
    6

    Default

    The reason for the telnet was to show that the ISP wasn't blocking port 25. That's all. I wanted to remove and DNS issues, since at the time, it appeared to be the issue (to me).

    BTW, thanks for the quick reply. This issue has bothered me for about a day.
    OSS Zimbra 7.2.7 64-bit ... er ... now.

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,493
    Rep Power
    56

    Default

    Quote Originally Posted by jdp459 View Post
    Just found this in another thread.

    -go to global settings>mta tab and check the box for dns lookups
    or: zmprov mcf zimbraMtaDnsLookupsEnabled TRUE (zmprov mc zimbraMtaDnsLookupsEnabled TRUE)
    That's the command line version of the Admin UI setting I mentioned above.

    Quote Originally Posted by jdp459 View Post
    I feel so dumb. ;O
    There's no need to, it's easy to overlook a setting. Glad you've fixed it.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    tuaris's Avatar
    tuaris is offline New Member
    Join Date
    Dec 2008
    Posts
    3
    Rep Power
    6

    Default

    Why is that even an option? For what possible reason would anyone want to disable it?
    President/CEO
    PacyWorld.com

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,493
    Rep Power
    56

    Default

    Quote Originally Posted by tuaris View Post
    Why is that even an option? For what possible reason would anyone want to disable it?
    Split Domain.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Crashes every day
    By feiticeir0 in forum Administrators
    Replies: 10
    Last Post: 10-13-2011, 06:53 AM
  2. Issue: MX Record & Multi-domain
    By wcbenyip in forum Installation
    Replies: 5
    Last Post: 06-23-2009, 06:15 PM
  3. [SOLVED] Amavisd-Postfix RCPT TO Takes a long time
    By samuraii in forum Administrators
    Replies: 8
    Last Post: 02-11-2009, 03:34 PM
  4. [SOLVED] Mail failing for servers with no A record
    By timwiel in forum Administrators
    Replies: 3
    Last Post: 02-26-2008, 06:07 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •